[ISPConfig3] Frage zu Domain/vhost redirect

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Okumba, 11. Juni 2010.

  1. Okumba

    Okumba New Member

    Hi,

    mir ist aufgefallen, dass sich (denke mit irgendeinem Update - wir nutzen ISPConfig Version: 3.0.2.1) etwas an den Domain redirects geändert hat.

    Hier mal die vhost wie sie mal aussah:

    Code:
    <Directory /var/www/domain.de>
        AllowOverride All
        Order Deny,Allow
        Deny from all
    </Directory>
    
    <VirtualHost *:80>
        DocumentRoot /var/www/clients/client1/web6/web
    
        ServerName domain.de
        ServerAlias www.domain.de 
        ServerAlias files.domain.de 
        ServerAlias stats.domain.de 
        ServerAdmin webmaster@domain.de
    
        ErrorLog /var/log/ispconfig/httpd/domain.de/error.log
    
        ErrorDocument 400 /error/400.html
        ErrorDocument 401 /error/401.html
        ErrorDocument 403 /error/403.html
        ErrorDocument 404 /error/404.html
        ErrorDocument 405 /error/405.html
        ErrorDocument 500 /error/500.html
        ErrorDocument 503 /error/503.html
        
        <Directory /var/www/domain.de/web>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
        <Directory /var/www/clients/client1/web6/web>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
    
        # suexec enabled
        SuexecUserGroup web6 client1
        # suphp enabled
        <Directory /var/www/clients/client1/web6/web>
            suPHP_Engine on
            # suPHP_UserGroup web6 client1
            AddHandler x-httpd-suphp .php .php3 .php4 .php5
            suPHP_AddHandler x-httpd-suphp
        </Directory>
        
        RewriteEngine on
        RewriteCond %{HTTP_HOST}   ^domain.de [NC]
        RewriteRule   ^/(.*)$ /domain.de/$1  
        RewriteCond %{HTTP_HOST}   ^www.domain.de [NC]
        RewriteRule   ^/(.*)$ /domain.de/$1  
        RewriteCond %{HTTP_HOST}   ^files.domain.de [NC]
        RewriteRule   ^/(.*)$ /files/$1  
        RewriteCond %{HTTP_HOST}   ^stats.domain.de [NC]
        RewriteRule   ^/(.*)$ /stats/$1  
    
        # add support for apache mpm_itk
        <IfModule mpm_itk_module>
          AssignUserId web6 client1
        </IfModule>
    php_admin_flag safe_mode on
    </VirtualHost>
    
    Hier bin ich mir nicht sicher, ob das schon immer drin stand:
    Code:
    <Directory /var/www/domain.de>
        AllowOverride All
        Order Deny,Allow
        Deny from all
    </Directory>
    Das Problem ist nun, die Domain steht auf Redirect: No Flag mit Redirect-Pfad: /domain.de/

    Speichere ich das nun ab passiert folgendes:

    Code:
        RewriteEngine on
        RewriteCond %{HTTP_HOST}   ^domain.de [NC]
        RewriteRule   ^/(.*)$ /var/www/clients/client1/web6/web/$1  
        RewriteCond %{HTTP_HOST}   ^www.domain.de [NC]
        RewriteRule   ^/(.*)$ /var/www/clients/client1/web6/web/$1
    Warum scrhreibt er nun den /var/www.... pfad hin, statt das was ich beim Redirect-Pfad (/domain.de/) angebe?

    Ich bin mir sicher, das es mal ging, weil bei vhost dateien, die schon ewig nicht mehr geändert wurden, steht es noch drin, genauso bei subdomains... da funktioniert es auch noch wie gehabt.

    Jemand ne Idee?


    P.S.: noch was: anscheinend wird nun auch das php_admin_flag ganz am ende ignoriert?

    - Gruß Okumba
     
  2. Till

    Till Administrator

  3. Okumba

    Okumba New Member

    Danke Till, hat geholfen.

    Trotzdem noch die Frage: php_admin_flag safe_mode on

    Hab ich als Apache Direktive drin und trotzdem ist safemode in der phpinfo() Anzeige zweimal auf off (local / master value).

    Ne Idee?

    Gruß,
    Okumba
     
  4. Till

    Till Administrator

    Was hast Du denn als php mode ausgewählt? Settings mittels php_admin_flag und php_admin_value sind Funktionen des Apache Modules mod_php
     
  5. Okumba

    Okumba New Member

    Oh, hast natürlich wieder recht, sorry...

    FastCGI ist aktiviert bei den Domains.
    Gibts schon eine Möglichkeit pro Domain bzw. Kunde eine eigenen PHP.ini zu definieren?

    Gruß,
    Okumba
     
  6. Till

    Till Administrator

  7. Okumba

    Okumba New Member

    Alles klar, danke dir :)
     
  8. mzerbe

    mzerbe New Member

    php_admin_flag fuer Unterverzeichnis wirkungslos (Mod-PHP)

    Dieses Problem habe ich in aehnlicher Form auch
    Allerdings ist bei mir Mod-PHP eingestellt. (ausfuehrlicher stehts im Englischen Teil des Forums.)
     

Diese Seite empfehlen