ISPConfig3 Frage

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von F12012, 22. Dez. 2011.

  1. F12012

    F12012 New Member

    Hallo

    Auf der Dokumentationsseite steht dieses:
    Code:
    # /etc/fstab: static file system information. # # Use 'blkid -o value -s
    UUID' to print the universally unique identifier # for a device; this may be 
    used with UUID= as a more robust way to name # devices that works even 
    if disks are added and removed. See fstab(5). # # <file system> <mount
    point>   <type>  <options>       <dump>  <pass> proc            /proc     
    proc    nodev,noexec,nosuid 0       0 /dev/mapper/server1-root /  
    ext4    errors=remount-
    ro,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0 0       1 # 
    /boot was on /dev/sda1 during installation UUID=deae7cd1-b106-47aa-
    9a7c-512f046d2ebf /boot           ext2    defaults        0       2 
    /dev/mapper/server1-swap_1 none            swap    sw              0       0 
    /dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
    
    
    Hier nochmal mit bessere Sicht: C code - 13 lines - codepad


    Aber als Text steht darüber dass ich nur das einfügen soll:

    Code:
    ,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0
    
    Das hatte ich auch gemacht und sieht aktuell so aus:
    Code:
    # /etc/fstab: static file system information. # # Use 'blkid -o value -s 
    UUID' to print the universally unique identifier # for a device; this may be 
    used with UUID= as a more robust way to name # devices that works even 
    if disks are added and removed. See fstab(5). # # <file system> <mount 
    point>   <type>  <options>       <dump>  <pass> proc            /proc         
    proc    nodev,noexec,nosuid 0       0 # / was on /dev/sda1 during 
    installation $remount-
    ro,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0 0       1 # 
    swap was on /dev/sda5 during installation #UUID=c4ea56ba-
    d826-4e09-8545-015d64fab5cd none            swap    sw          $ /dev/fd0 
    /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0 /dev/mapper
    /cryptswap1 none swap sw 0 0
    
    Hier nochmal mit bessere Sicht: C code - 14 lines - codepad

    Und wenn ich beides vergleiche merke ich doch noch unterschiede. Ich hatte das mal gespeichert und dann die nächsten 2 Sachen befolgt aber bekomme dann angezeigt:
    Code:
    quotacheck: Kann kein Dateisystem zum Prüfen finden oder Dateisystem nicht mit der Quota-Option gemountet.
    
    
    Nun stellt sich bei mir die Frage ob ich da an meinen Code da noch was ändern muss. Und wenn ja was müsste ich da noch ändern?

    Gruß
    Julian
     
  2. Till

    Till Administrator

  3. F12012

    F12012 New Member

    Danke für die Hilfe hat geklappt. Nun bekam ich gegen Ende diesen Fehler:


    Code:
    Syntax error on line 27 of /etc/apache2/sites-enabled/000-apps.vhost:
    Invalid command 'SuexecUserGroup', perhaps misspelled or defined by a module not included in the server configuration
    Action 'configtest' failed.
    The Apache error log may have more information.
       ...fail!
    Restarting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -O clf:/var/log/pure-ftpd/transfer.log -b -E -u 1000 -8 UTF-8 -H -A -D -Y 1 -B
    Installation completed.
    Ich sollt vllt. nun dazu sagen dass ich ubuntu 11.04 verwende.

    Edit:
    und ich kann mich nicht einloggen mit admin admin


    Gruß
    Julian
     
    Zuletzt bearbeitet: 23. Dez. 2011
  4. F12012

    F12012 New Member

    So hab mal die Log geöffnet:


    Code:
    [Thu Dec 22 06:49:16 2011] [error] [client 199.167.133.128] File does not exist: /var/www/robots.txt
    
    [Thu Dec 22 10:10:45 2011] [error] [client 222.208.183.218] script '/var/www/getip.php' not found or unable to stat
    
    [Thu Dec 22 12:01:05 2011] [error] [client 58.218.199.147] script '/var/www/proxyheader.php' not found or unable to stat
    
    [Thu Dec 22 15:57:22 2011] [error] [client 58.218.199.147] script '/var/www/proxyheader.php' not found or unable to stat
    
    [Thu Dec 22 23:51:18 2011] [error] [client 61.190.172.2] File does not exist: /var/www/user
    
    [Fri Dec 23 00:25:15 2011] [error] [client 58.218.199.250] script '/var/www/proxyheader.php' not found or unable to stat
    Manche sind noch vom gestern weil ich gestern keine Zeit dafür hatte.
     
  5. Till

    Till Administrator

    Du hast vergessen das suexec Modul in Deinem apache zu aktivieren:

    a2enmod suexec

    Schau am besten nochmal in die perfect server anleitung, da steht das alles drin.
     
  6. F12012

    F12012 New Member

    danke hab den schritt wiederholt und nun geht dass. Dafür ist nun die anwendung lahm :D
    Aber danke. Antscheint hab ich diesen Schritt übersehen.
     

Diese Seite empfehlen