ISPConfig3, IP Adresse nur für den Mailversand ändern

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von andy1965, 18. März 2014.

  1. andy1965

    andy1965 Member

    Hallo!

    Nachdem unser Server auf Spamlisten geladet ist und sich von einigen hartnäckig nicht entfernen lässt :-/ folgende Frage:

    Ich möchte die ausgehende IP Adresse für den Mailversand ändern, wegen der DNS Einträge für die Zustellung nicht die eingehende IP!

    Ich habe einige Tipps zu postfix gefunden, fürchte jedoch das diese bei IPSConfig3 nicht anwendbar sind.

    Gibt es dazu schon eine empfohlene Vorgangsweise?

    Danke vorab.


    Versionsstand: ISPC 3.0.5.3; CentOS 6.5 64bit
     
    Zuletzt bearbeitet: 18. März 2014
  2. andy1965

    andy1965 Member

    Folgende Änderungen habe ich für die master.cf gefunden


    smtp unix - - - - - smtp
    ......-o smtp_bind_address=192.168.1.1
    # When relaying mail as backup MX, disable fallback_relay to avoid MX loops relay
    unix - - - - - smtp
    ......-o smtp_bind_address=192.168.1.1
    ......-o smtp_fallback_relay=

    Wird das mit ISPC3 funktionieren?
    Wobei die IP 192.168.1.1 natürlich durch die neu offizielle IP ersetzt wird.
     
    Zuletzt bearbeitet: 18. März 2014
  3. andy1965

    andy1965 Member

    Ich habe testweise die Konfiguration geändert.

    Leider sendet der Server scheinbar noch immer mit der alten IP Adresse.

    Hat niemand einen Tipp? Werde wohl nicht der Erste sein der mit solchen Problemen zu kämpfen hat.

    Vorab dieser Tipp mit "smtp_bind_address = 192.168.0.1" funktioniert auch nicht:
    Send all outgoing email trough one IP address in postfix « FAQforge
    Her kommt folgende Fehlermeldung: (lost connection with 127.0.0.1[127.0.0.1] while receiving the initial server greeting)



    Danke vorab.
     
    Zuletzt bearbeitet: 19. März 2014
  4. florian030

    florian030 Member

    Hast Du die IP oder "all" unter inet_interfaces eingetragen?
     
  5. andy1965

    andy1965 Member

    hmm ...

    in der main.cf ist der Eintrag "inet_interfaces" nicht vorhanden.
    Damit ist der default Wert auf "all".
    Denke so soll es auch sein, da Postfix unter allen IP Adressen weiterhin Emails empfangen soll
    (siehe http://www.postfix.org/postconf.5.html#inet_interfaces
    inet_interfaces (default: all) The network interface addresses that this mail system receives mail on. Specify "all" to receive mail on all network interfaces (default)....
    )
    Dort steht auch

    A better solution for multi-homed firewalls is to leave inet_interfaces at the default value and instead use explicit IP addresses in the master.cf SMTP server definitions.

    Was ich mit

    smtp unix - - - - - smtp
    ......-o smtp_bind_address=192.168.1.1
    # When relaying mail as backup MX, disable fallback_relay to avoid MX loops relay
    unix - - - - - smtp
    ......-o smtp_bind_address=192.168.1.1
    ......-o smtp_fallback_relay=

    gemacht habe.
    Jedoch sendet der postfix trotzdem noch mit der alten IP Adresse.
     
    Zuletzt bearbeitet: 19. März 2014

Diese Seite empfehlen