ispconfig3 mysql problem

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von tutnix, 2. Sep. 2009.

  1. tutnix

    tutnix New Member

    Nach einer installation von ispconfig3 habe ich das problem das ich mich im backend mit admin//admin nicht einloggen kann.

    meldung:
    Code:
    [B]Warning[/B]:  mysql_connect() [[URL="http://www.havoc-the-chaos.de:8060/function.mysql-connect"]function.mysql-connect[/URL]]: Access denied for user 'ispconfig'@'apache2' (using password: YES) in [B]/usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php[/B] on line [B]73
    [/B]
    Das ist recht klar, da ich mich auch per console
    Code:
    mysql -h database.havoc-the-chaos.de -u ispconfig -p
    nicht einloggen kann.

    Das problem ist, dass ein genau gleich konfigurierter benutzer auch von meinem webserver auf den database-server zugreifen kann.
    Weder der FQDN noch ein apache2 noch die ip im host-feld bringen ein Ergebnis.

    Ein eintrag eines bereits bestehenden nutzers in die config_inc.php mit korrektem password wird mit erfolgreichem einloggen belohnt.
    ist vielleicht das in die db eingetragene password falsch?
     
  2. tutnix

    tutnix New Member

    so.
    eine Lösung ist gefunden, aber mir scheint, dass dort etwas beim install (4 mal versucht) schief läuft.

    wenn ich den user mit den gleichen rechten wie vom installer vorgesehen (configure_database()) anlege und das dort verwendete password in die config_inc.php schreibe, dann funktioniert es. allerdings steht in der options_conf.php nen anderes password für den ispconfig user als in der config.inc.php.
    Da in der Config.inc.php das password auch im Klartext steht scheint da irgendwas schief zu laufen.

    kann, sofern es working as inteded ist geschlossen werden, ansonsten bitte als bug aufnehmen und entfernen, auch wenn ich scheinbar der einzige bin der damit zu tun hat.
     
  3. Till

    Till Administrator

    Also von einem Fehler im Installer gehe ich mal nicht aus, da wir mehere hundert erfolgreiceh Installationen pro Tag haben und ich denke dass das dann innerhalb einiger Monate bereist aufgetaucht wäre. Es gibt auch garkeine Datei options_conf.php und keine config_inc.php in ISPConfig, somit frage ich mich, welche Software Du da gerade installierst. Es gibt nur eine Datei config.inc.php und natürlich steht das Passwort dort im Klartext drin, wie sollte sich ISPConfig denn sonst auch an der mysql DB anmelden.
     
  4. tutnix

    tutnix New Member

    aus dem grund, dass ich noch garnichts zu dem problem gefunden hatte habe ich auch eine fehlfunktion des installers fürunwahrscheinlich gehalten, aber es sah halt so aus, als ob da falsche werte, warum auch immer eingetragen wurden.

    wenn ich nacher auf der arbeit bin werde ich noch mal gucken und dann sagen woher die scheinbar ominösen dateien kommen.
    bis etwas später.
     
  5. tutnix

    tutnix New Member

    Sorry die Dateien müssen natürlich
    Code:
    options.conf.php und config.inc.php
    heissen. ist scheinbar nen typo von mir gewesen.

    Im installationsordner:
    Code:
    ./isp3config_install/install/options.conf.php
    gibt es die Zeile
    Code:
    $conf['mysql']['ispconfig_password'] = 'XXXYYYZZZ';
    Genau diese Variable ($conf['mysql']['ispconfig_password'] wird von dem Installer ausgwertet in der Funktion configure_database().

    In
    Code:
    /usr/local/ispconfig/interface/lib/config.inc.php
    steht jedoch folgendes für ein password drin, was, falls es wie ich annehme wirklich Klartext ist, doch sehr seltsam ist da die beiden Passwörter nicht matchen.
    Code:
    $conf["db_password"] = 'string_der_aussieht_wie_ein_md5()_hash';
    Mir ist klar, das es sich scheinbar um ein einzel Problem handelt und daher nur unwahrscheinlicherweise ein installerproblem ist, aber das Problem ist zumindest bei mir auf jeden fall gegeben.
    Nein ich habe keine von beiden Dateien vorab geändert, was die unterschiedlichkeit ja sonst sofort erklären könnte.
     
    Zuletzt bearbeitet: 3. Sep. 2009
  6. Till

    Till Administrator

    Da bringst Du einiges durcheinander. Die Datei options.conf.php wird von ISPConfig seit langem nicht mehr verwendet. Die ist nur noch nicht im SVN gelöscht worden und ist auch auf keinem installierten System vorhhanden. Insbesondere musst Du bei ISPConfig grundsätzlich keine config Datein manuell ändern, also einfach nur exakt der Installationsanleitung folgen.
     
  7. tutnix

    tutnix New Member

    Wenn ich genau der Installationsanleitung folge, dann bekomme ich das problem was ich im ersten post beschreibe: ich kann mich nicht einloggen, da sich der ispconfig usernicht mit der datenbank verbinden kann.
    Habe mir mal nen neuen server aufgesetzt, dann das perfect server tutorial durgemacht und der Fehler tritt auch auf.
    Nächstes Problem bei Lenny installationen: die /etc/debian_version enthält auf einem aktuellen system den 5.0.2 string welcher ispconfig dazu veranlasst sich direkt nicht zu installieren, weil das system nicht supportet wird, was aber leicht zu ändern ist.
    Wie gesagt auf die idee mit dem ändern in den Dateien bin ich nur gekommen weil es wieder holt (100% reproduzierbarkeit) den Fehler hatte, dass sich ispconfig nicht zur datenbank connecten konnte.
     
  8. Till

    Till Administrator

    Habe gestern ispconfig 3 mehrfach auf Debian Lenny mit 5.0.2 string installiert, ohne probleme. Vermutlich versuchst Du eine alte Version zu installieren. Lade Dir doch mal eine aktuelle von ISPConfig.org runter.
     
  9. tutnix

    tutnix New Member

    So nacher werde ich das mal probieren mit der 3.0.1.3 habe bisher die 3.0.1 verwendet da die im tutorial verlinkt war. und ich in meinem Leichtsinn annahm, das sich in der vierten Stelle der Versionsangabe nicht so viel getan hat. Aber ich werde es testen keine Frage, auch wenn ich mit dem Backend leider noch so garnicht zurecht komme.
    Hoffe bekomme das ans rennen weil ich mir mal nen Ersatz für syscp anschauen mag.
     
    Zuletzt bearbeitet: 3. Sep. 2009
  10. chatty

    chatty New Member

    Also ich habs ebenfalls auf Debian 5 Lenny (5.03) nach zig Updates :) installiert. Ohne irgend eine Fehlermeldung. ISPCOnfig 3.0.1.4

    Ohne Schwierigkeiten ging die Installation ohne Meldung das er nicht installieren könne.

    Bin gespannt worans bei Dir hakte.
     
  11. tutnix

    tutnix New Member

    So 3.0.1.3 installiert, diesmal ohne Fehlermeldung. Beim Connecten leider wieder der fehler das sich der ispconfig user sich nicht an der datenbank anmelden kann. password in mysql geändert und es läuft. ich habe leider keine idee woran es liegt.
     
  12. Till

    Till Administrator

    Tja, dazu fällt mir auch nichts ein. Hab bis jetzt noch nie davon gehört, dass jenmand das Passwort manuell ändern musste. Vielleicht ein Problem mit dem Hostoder Du nutzt irgendwelche Sonderzeichen im Passwort, bei dem sich die Shell verschluckt.
     
  13. tutnix

    tutnix New Member

    @till
    DAS könnte natürlich das Problem sein, auch wenn ich das Password ja nirgendwo eingeben muss, daher bin ich auf die Idee noch nicht gekommen.
    Aber in dem Password aus der config.inc.php sind eigentlich keine Sonderzeichen drin... naja wie dem auch sei, jetzt läuft es erstmal und ich versuche mich rein einzuarbeiten.
    Gibt es irgendwo eigentlich schon ein manual/howto/tutorial zu der 3er Version? Ich habe bisher leider immer nur 2er Sachen gefunden.
     
  14. Till

    Till Administrator

    Ich meinte das mysql root Passwort und dass musstest Du ja eingeben.

    Da wäre ich mir nicht so sicher, denn wenn Du das Passwort manuell ändern musstest dann gehe ich nicht davon aus dass die Software komplett richtig installeirt ist. Immerhin steht dass Passwort in 5 oder 6 Dateien und wenn auch nur in eriner ein Fehler ist, dann werden diverse Dienste nicht gehen.

    Nur jede Menge Installations manuals.
     
  15. tutnix

    tutnix New Member

    Das root password hat ja scheinbar funktioniert, denn sonst hätte er den ispconfig Benutzer ja überhaupt nicht anlegen können.
    Nur der Ispconfig benutzer hatte nacher scheinbar ein "falsches" password.
     

Diese Seite empfehlen