Kein Mailempfang: Debian Squeeze, Postfix, Dovecot, ISP Config 3

#1
Hallo,

ich habe ein Problem mit dem Mailempfang,
Es funktioniert nichts..

Kann zB nicht über Squirell verschicken oder eine Mail empfangen die zB von GMX kommt..

Grundconfig des Servers ist:
The Perfect Server - Debian Squeeze (Debian 6.0) With BIND & Dovecot [ISPConfig 3] | HowtoForge - Linux Howtos and Tutorials

/var/log/mail.log

Nov 25 07:21:33 server postfix/master[3406]: daemon started -- version 2.7.1, configuration /etc/postfix
Nov 25 07:21:44 server dovecot: Dovecot v1.2.15 starting up (core dumps disabled)
Nov 25 07:21:44 server dovecot: auth-worker(default): mysql: Connected to localhost (dbispconfig)
Nov 25 07:25:02 server dovecot: pop3-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
Nov 25 07:25:02 server dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
Nov 25 07:25:02 server postfix/smtpd[3876]: connect from localhost.localdomain[127.0.0.1]
Nov 25 07:25:02 server postfix/smtpd[3876]: SSL_accept error from localhost.localdomain[127.0.0.1]: -1
Nov 25 07:25:02 server postfix/smtpd[3876]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Nov 25 07:25:02 server postfix/smtpd[3876]: disconnect from localhost.localdomain[127.0.0.1]
Nov 25 07:26:04 server postfix/smtpd[3876]: connect from mailout-de.gmx.net[213.165.64.22]

auch tauchen immer Eintraege wie folgender auf:

Nov 25 07:29:03 server postfix/smtpd[3876]: SSL_accept error from mailout-de.gmx.net[213.165.64.22]: -1
Nov 25 07:29:03 server postfix/smtpd[3876]: lost connection after CONNECT from mailout-de.gmx.net[213.165.64.22]
Nov 25 07:29:03 server postfix/smtpd[3876]: disconnect from mailout-de.gmx.net[213.165.64.22]

Nov 25 07:20:34 server dovecot: dovecot: Killed with signal 15 (by pid=11554 uid=0 code=kill)
Nov 25 07:20:34 server postfix/master[3415]: terminating on signal 15


Ich weiß nicht was verkehrt läuft,
könnt ihr mir helfen mal einen Anfang zu finden?

LG
Juggler
 
Zuletzt bearbeitet:

Till

Administrator
#2
Es scheint so als ob gmx deine mails nicht annehmen will. Steht der server in einem rechenzentrum mit fester ip oder hat er eine dynamische ip?
 
#3
Hallo Till,

er steht in einem Rechenzentrum von OVH, feste IP. Weder gmail noch andere Emails kommen an. Ich kann nichtmal eine absetzen wenn ich mich via Squirell einloge..
 

Till

Administrator
#4
Logge dich mal in squirrelmail ein und sende eine email an die adresse mit der Du in squirrelmail eingeloggt bist und poste dann die Meldungen die im mail.log neu hinzugekommen sind.
 
#5
mail.log

Nov 25 14:30:01 server dovecot: pop3-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
Nov 25 14:30:01 server dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
Nov 25 14:30:01 server postfix/smtpd[32302]: connect from localhost.localdomain[127.0.0.1]
Nov 25 14:30:01 server postfix/smtpd[32302]: SSL_accept error from localhost.localdomain[127.0.0.1]: -1
Nov 25 14:30:01 server postfix/smtpd[32302]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Nov 25 14:30:01 server postfix/smtpd[32302]: disconnect from localhost.localdomain[127.0.0.1]
Nov 25 14:30:02 server postfix/pickup[28056]: 1CE2838E0F28: uid=33 from=<www-data>
Nov 25 14:30:02 server postfix/cleanup[32332]: 1CE2838E0F28: message-id=<20121125133002.1CE2838E0F28@server.meinedomain.de>
Nov 25 14:30:02 server postfix/qmgr[3413]: 1CE2838E0F28: from=<www-data@server.meinedomain.de>, size=875, nrcpt=1 (queue active)
Nov 25 14:30:02 server postfix/smtpd[32337]: connect from localhost.localdomain[127.0.0.1]
Nov 25 14:30:02 server postfix/smtpd[32337]: 6E45638E0EC9: client=localhost.localdomain[127.0.0.1]
Nov 25 14:30:02 server postfix/cleanup[32332]: 6E45638E0EC9: message-id=<20121125133002.1CE2838E0F28@server.meinedomain.de>
Nov 25 14:30:02 server postfix/smtpd[32337]: disconnect from localhost.localdomain[127.0.0.1]
Nov 25 14:30:02 server postfix/qmgr[3413]: 6E45638E0EC9: from=<www-data@server.meinedomain.de>, size=1365, nrcpt=1 (queue active)
Nov 25 14:30:02 server amavis[29613]: (29613-02) Passed CLEAN, <www-data@server.meinedomain.de> -> <www-data@server.meinedomain.de>, Message-ID: <20121125133002.1CE2838E0F28@server.meinedomain.de>, mail_id: I36o+N0Wlq4q, Hits: -0.001, size: 875, queued_as: 6E45638E0EC9, 326 ms
Nov 25 14:30:02 server postfix/smtp[32334]: 1CE2838E0F28: to=<www-data@server.meinedomain.de>, orig_to=<www-data>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.72, delays=0.38/0/0/0.33, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=29613-02, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 6E45638E0EC9)
Nov 25 14:30:02 server postfix/qmgr[3413]: 1CE2838E0F28: removed
Nov 25 14:30:02 server postfix/local[32338]: 6E45638E0EC9: to=<www-data@server.meinedomain.de>, relay=local, delay=0.07, delays=0.03/0/0/0.03, dsn=2.0.0, status=sent (delivered to mailbox)
Nov 25 14:30:02 server postfix/qmgr[3413]: 6E45638E0EC9: removed
Nov 25 14:30:19 server dovecot: imap-login: Login: user=<tobias@meinedomain.de>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
Nov 25 14:30:19 server dovecot: IMAP(tobias@meinedomain.de): Disconnected: Logged out bytes=44/709
Nov 25 14:30:19 server dovecot: imap-login: Login: user=<tobias@meinedomain.de>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
Nov 25 14:30:19 server dovecot: IMAP(tobias@meinedomain.de): Disconnected: Logged out bytes=443/1902
Nov 25 14:30:19 server dovecot: imap-login: Login: user=<tobias@meinedomain.de>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
Nov 25 14:30:19 server dovecot: IMAP(tobias@meinedomain.de): Disconnected: Logged out bytes=117/1446
Nov 25 14:30:52 server postfix/smtpd[32302]: connect from localhost.localdomain[127.0.0.1]
Nov 25 14:31:52 server postfix/smtpd[32302]: SSL_accept error from localhost.localdomain[127.0.0.1]: -1
Nov 25 14:31:52 server postfix/smtpd[32302]: warning: TLS library problem: 32302:error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown protocol:s23_srvr.c:578:
Nov 25 14:31:52 server postfix/smtpd[32302]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Nov 25 14:31:52 server postfix/smtpd[32302]: disconnect from localhost.localdomain[127.0.0.1]

Auch scheint die IP des Servers bei Barracuda gelistet zu sein, neuer Server wohlgemerkt..

und wenn ich einen Mailserver SMTP Test von außen starte kann er nicht verbinden..
Port 25 und 143 sind aber erreichbar denke ich, zumindest laut Scans von MXToolbox

11/25/2012 7:41:31 AM Connection attempt #1 - Timeout occurred due to inactivity. [16.22 sec]


edit:

mail.warn

Nov 25 06:20:08 ks359960 amavis[31353]: (31353-05) (!)ClamAV-clamd av-scanner FAILED: run_av error: Too many retries to talk to /var/run/clamav/clamd.ctl (Can't connect to UNIX socket /var/run/clamav/clamd.ctl: No such file or directory) at (eval 105) line 373.\n
Nov 25 06:20:08 ks359960 amavis[31353]: (31353-05) (!!)WARN: all primary virus scanners failed, considering backups
Nov 25 06:25:35 ks359960 amavis[2466]: (02466-03) (!)ClamAV-clamd: Can't connect to UNIX socket /var/run/clamav/clamd.ctl: No such file or directory, retrying (2)
 
Zuletzt bearbeitet:

Till

Administrator
#7
Ist die mail denn im webmail Postfach angekommen? Laut Log müsste sie da sein. Wenn das der Fall ist, dann liegt das Problem wahrscheinlich nicht aufd em lokalen Server.
 

Till

Administrator
#9
Nach der Anleitung sollte es an sich problemlos gehen, ich nutze die auch immer als copy&paste Vorlage für Installationen von Kundenservern. Am einfachsten ist es wenn Du Dich mit einem ssh Client wie putty mit dem Server verbindest und dann stur per copy & paste die Befehle rüber kopierst. Nur wenn irgendwo vermerkt ist dass der Hostname oder eine Ip drin steht, dann die natürlich ändern :)
 
#10
Hi,

ja das hatte ich auch so gemacht, einmal das howto fuer Ubuntu 12.10 und diesen fuer Debian. Beide male das selbe Ergebnis, kein Mailempfang.

Der Hase muss irgendwo anders im Pfeffer liegen.
Ich habe keine Ahnung wie ich das Spitz kriege..

Evtl. weil die IP des neuen Servers bei Barracuda gelistet ist?
Ich habe keine Idee, bin auch noch nicht dazu gekommen den Server neu aufzusetzen, denke aber auch das ich zum gleichen Ergebnis kommen wuerde.

Ratlos..
 

Till

Administrator
#11
Kannst Du Dich denn von außen mit dem Server verbinden, so in der Form:

telnet servername.tld 25

wenn Du dann einen prompt bekommst gib ein:

ehlo localhost

und dann return drücken, dann sollte er Dir sowas ausgeben:

Code:
220 server.abcde.de ESMTP Postfix (Debian/GNU)
ehlo localhost
250-server.abcde.de
250-PIPELINING
250-SIZE
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
 
#12
Jugglers-Mac-mini:~ Juggler$ telnet meinedomain.de 25
Trying xxxx.xxx.xxx.xxxx...
Connected to meinedomain.de.
Escape character is '^]'.
ehlo localhost
Connection closed by foreign host.
Jugglers-Mac-mini:~ Juggler$

mhh
 
#14
Nov 27 17:16:32 server postfix/smtpd[5616]: connect from dtmd-xxxx362e.pool.mediaWays.net[xxx.xxx.54.46]
Nov 27 17:16:48 server postfix/smtpd[5616]: SSL_accept error from dtmd-xxxx362e.pool.mediaWays.net[xxx.xxxx.54.46]: -1
Nov 27 17:16:48 server postfix/smtpd[5616]: warning: TLS library problem: 5616:error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown protocol:s23_srvr.c:578:
Nov 27 17:16:48 server postfix/smtpd[5616]: lost connection after CONNECT from dtmd-xxxx362e.pool.mediaWays.net[xxx.xxx.54.46]
Nov 27 17:16:48 server postfix/smtpd[5616]: disconnect from dtmd-xxxx362e.pool.mediaWays.net[xxx.xxx.54.46]
 

Till

Administrator
#15
Poste mal bitte Deine master.cf Datei. Es kann auch sein dass Du irgendwelche Sonderzeichen bei der Erzeugung des SSL zertifikates für die Emaildienste verwendest hast und somit die Zertuifikate jetzt nicht funktionieren. Openssl ist da sehr spezifisch, am besten immer nur a-z sowie 0-9 und Punkt nehmen, keine Umlaute oder sonstige Sonderzeichen.
 
#16
#
# Postfix master process configuration file. For details on the format
# of the file, see the master(5) manual page (command: "man 5 master").
#
# Do not forget to execute "postfix reload" after editing this file.
#
# ==========================================================================
# service type private unpriv chroot wakeup maxproc command + args
# (yes) (yes) (yes) (never) (100)
# ==========================================================================
smtp inet n - - - - smtpd
#submission inet n - - - - smtpd
-o smtpd_tls_security_level=encrypt
-o smtpd_sasl_auth_enable=yes
-o smtpd_client_restrictions=permit_sasl_authenticated,reject
# -o milter_macro_daemon_name=ORIGINATING
#smtps inet n - - - - smtpd
-o smtpd_tls_wrappermode=yes
-o smtpd_sasl_auth_enable=yes
-o smtpd_client_restrictions=permit_sasl_authenticated,reject
# -o milter_macro_daemon_name=ORIGINATING
#628 inet n - - - - qmqpd
pickup fifo n - - 60 1 pickup
cleanup unix n - - - 0 cleanup
qmgr fifo n - n 300 1 qmgr
#qmgr fifo n - - 300 1 oqmgr
tlsmgr unix - - - 1000? 1 tlsmgr
rewrite unix - - - - - trivial-rewrite
bounce unix - - - - 0 bounce
defer unix - - - - 0 bounce
trace unix - - - - 0 bounce
verify unix - - - - 1 verify
flush unix n - - 1000? 0 flush
proxymap unix - - n - - proxymap
proxywrite unix - - n - 1 proxymap
smtp unix - - - - - smtp
# When relaying mail as backup MX, disable fallback_relay to avoid MX loops
relay unix - - - - - smtp
-o smtp_fallback_relay=
# -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq unix n - - - - showq
error unix - - - - - error
retry unix - - - - - error
discard unix - - - - - discard
local unix - n n - - local
virtual unix - n n - - virtual
lmtp unix - - - - - lmtp
anvil unix - - - - 1 anvil
scache unix - - - - 1 scache
#
# ====================================================================
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# Many of the following services use the Postfix pipe(8) delivery
# agent. See the pipe(8) man page for information about ${recipient}
# and other message envelope options.
# ====================================================================
#
# maildrop. See the Postfix MAILDROP_README file for details.
# Also specify in main.cf: maildrop_destination_recipient_limit=1
#
maildrop unix - n n - - pipe
flags=DRhu user=vmail argv=/usr/bin/maildrop -d vmail ${extension} ${recipient} ${user} ${nexthop} ${sender}
#
# ====================================================================
#
# Recent Cyrus versions can use the existing "lmtp" master.cf entry.
#
# Specify in cyrus.conf:
# lmtp cmd="lmtpd -a" listen="localhost:lmtp" proto=tcp4
#
# Specify in main.cf one or more of the following:
# mailbox_transport = lmtp:inet:localhost
# virtual_transport = lmtp:inet:localhost
#
# ====================================================================
#
# Cyrus 2.1.5 (Amos Gouaux)
# Also specify in main.cf: cyrus_destination_recipient_limit=1
#
#cyrus unix - n n - - pipe
# user=cyrus argv=/cyrus/bin/deliver -e -r ${sender} -m ${extension} ${user}
#
# ====================================================================
# Old example of delivery via Cyrus.
#
#old-cyrus unix - n n - - pipe
# flags=R user=cyrus argv=/cyrus/bin/deliver -e -m ${extension} ${user}
#
# ====================================================================
#
# See the Postfix UUCP_README file for configuration details.
#
uucp unix - n n - - pipe
flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
#
# Other external delivery methods.
#
ifmail unix - n n - - pipe
flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp unix - n n - - pipe
flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
scalemail-backend unix - n n - 2 pipe
flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
mailman unix - n n - - pipe
flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
${nexthop} ${user}

dovecot unix - n n - - pipe
flags=DRhu user=vmail:vmail argv=/usr/lib/dovecot/deliver -f ${sender} -d ${user}@${nexthop}
amavis unix - - - - 2 smtp
-o smtp_data_done_timeout=1200
-o smtp_send_xforward_command=yes

127.0.0.1:10025 inet n - - - - smtpd
-o content_filter=
-o local_recipient_maps=
-o relay_recipient_maps=
-o smtpd_restriction_classes=
-o smtpd_client_restrictions=
-o smtpd_helo_restrictions=
-o smtpd_sender_restrictions=
-o smtpd_recipient_restrictions=permit_mynetworks,reject
-o mynetworks=127.0.0.0/8
-o strict_rfc821_envelopes=yes
-o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
-o smtpd_bind_address=127.0.0.1

Als Sonderzeichen bei den SSL Zertifikaten kamen Punkte . und @ vor.
Eigentlich nichts ungewöhnliches..
 

Till

Administrator
#17
Du ast Dich bei den Kommentaren in der master.cf vertan. entferne mal das # vor den Zeilen:

#submission inet n - - - - smtpd

und

#smtps inet n - - - - smtpd

und starte postfix neu.
 

Werbung

Top