Kein Zugriff auf phpmyadmin

#3
Hier die Fehlermeldung aus dem Apache2 error Log:

Code:
[Sun Nov 29 10:28:03 2009] [notice] Apache/2.2.8 (Ubuntu) PHP/5.2.4-2ubuntu5.7 with Suhosin-Patch mod_ssl/2.2.8 OpenSSL/0.9.8g configured -- resuming normal operations
[Sun Nov 29 10:28:08 2009] [error] [client 188.23.42.151] client denied by server configuration: /usr/share/phpmyadmin
[Sun Nov 29 10:28:11 2009] [error] [client 188.23.42.151] client denied by server configuration: /usr/share/phpmyadmin
[Sun Nov 29 10:28:11 2009] [error] [client 188.23.42.151] client denied by server configuration: /usr/share/phpmyadmin
[Sun Nov 29 10:28:11 2009] [error] [client 188.23.42.151] client denied by server configuration: /usr/share/phpmyadmin
[Sun Nov 29 10:28:11 2009] [error] [client 188.23.42.151] client denied by server configuration: /usr/share/phpmyadmin
[Sun Nov 29 10:28:12 2009] [error] [client 188.23.42.151] client denied by server configuration: /usr/share/phpmyadmin
[Sun Nov 29 10:28:12 2009] [error] [client 188.23.42.151] client denied by server configuration: /usr/share/phpmyadmin
[Sun Nov 29 10:28:12 2009] [error] [client 188.23.42.151] client denied by server configuration: /usr/share/phpmyadmin
[Sun Nov 29 10:28:12 2009] [error] [client 188.23.42.151] client denied by server configuration: /usr/share/phpmyadmin
[Sun Nov 29 10:28:46 2009] [error] [client 188.23.42.151] client denied by server configuration: /usr/share/phpmyadmin
[Sun Nov 29 10:28:46 2009] [error] [client 188.23.42.151] File does not exist: /usr/local/ispconfig/interface/web/favicon.ico
[Sun Nov 29 10:28:49 2009] [error] [client 188.23.42.151] File does not exist: /usr/local/ispconfig/interface/web/favicon.ico
[Sun Nov 29 10:29:15 2009] [error] [client 188.23.42.151] client denied by server configuration: /usr/share/phpmyadmin
[Sun Nov 29 10:31:12 2009] [notice] mod_fcgid: call /var/www/segelcheck.at/web/test/index.php with wrapper /var/www/php-fcgi-scripts/web10/.php-fcgi-starter
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613+lfs/htscanner.so' - /usr/lib/php5/20060613+lfs/htscanner.so: cannot open shared object file: No such file or directory in Un$
[Sun Nov 29 10:34:40 2009] [error] [client 188.23.42.151] client denied by server configuration: /usr/share/phpmyadmin
[Sun Nov 29 10:49:41 2009] [error] [client 188.23.42.151] client denied by server configuration: /usr/share/phpmyadmin, referer: http://www.howtoforge.de/forum/showthread.php?t=2556
[Sun Nov 29 10:51:01 2009] [notice] Graceful restart requested, doing restart
 
#6
Hier der Inhalt:

Code:
root@server:~# cat /etc/apache2/sites-enabled/000-ispconfig.conf


################################################
# ISPConfig Logfile configuration for vlogger ################################################

LogFormat "%v %h %l %u %t \"%r\" %>s %B \"%{Referer}i\" 
\"%{User-Agent}i\"" combined_ispconfig
CustomLog "| /usr/local/ispconfig/server/scripts/vlogger -s access.log 
-t \"%Y%m%d-access.log\" -d \"/etc/vlogger-dbi.conf\" 
/var/log/ispconfig/httpd" combined_ispconfig

<Directory /var/www/clients>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

<Directory />
       AllowOverride None
       Order Deny,Allow
       Deny from all
</Directory>


NameVirtualHost 192.168.1.99:80
NameVirtualHost 192.168.1.99:443

root@server:~#
 

Till

Administrator
#7
Ok, da fehlen ein paar Zeilen. Ist wohl was bei der Aktualisierung der Datei schief gegangen. Füg mal die folgenden Zeilen am Ende dazu und starte apache neu:

Code:
# Except of the following directories that contain website scripts
<Directory /usr/share/phpmyadmin>
        Order allow,deny
        Allow from all
</Directory>

<Directory /usr/share/phpMyAdmin>
        Order allow,deny
        Allow from all
</Directory>

<Directory /usr/share/squirrelmail>
        Order allow,deny
        Allow from all
</Directory>
 

pee

New Member
#9
Hallo,

habe das Problem auch und deshalb bereits unter http://www.howtoforge.de/forum/showthread.php?t=2567 gepostet. Nur habe ich PhpMyAdmin nach /var/www/ hochgeladen und nicht über den Paketmanager installiert. Ich habe immer PhpMyAdmin über http://SERVER-IP/phpmyadmin aufgerufen. Nun erhalte ich da plötzlich den 403-Forbidden Fehler vom Apache. Dasselbe beim Aufruf von Squirrelmail (unter http://SERVER-IP/webmail), welchen ich jedoch über den Paketmanager installiert habe.

Meine 000-ispconfig.conf aus /etc/apache2/sites-enabled:

################################################
# ISPConfig Logfile configuration for vlogger
################################################

LogFormat "%v %h %l %u %t \"%r\" %>s %B \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
CustomLog "| /usr/local/ispconfig/server/scripts/vlogger -s access.log -t \"%Y%m%d-access.log\" -d \"/etc/vlogger-dbi.conf\" /var/log/ispconfig/httpd" combined_ispconfig

<Directory /var/www/clients>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

# Do not allow access to the root file system of the server for security reasons
<Directory />
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

# Except of the following directories that contain website scripts
<Directory /usr/share/phpmyadmin>
Order allow,deny
Allow from all
</Directory>

<Directory /usr/share/squirrelmail>
Order allow,deny
Allow from all
</Directory>

NameVirtualHost ... (Server IPs..)
Mit der Konfiguration von Till und dem Neustart von Apache2 erhalte ich weiterhin die Fehlermeldung.

Hoffe jemand von euch hat eine Idee. Ich freue mich auf eure Antwort.

lg
 

Till

Administrator
#10
Du benutzt ja auch ein nicht standard Verzeichnis, d.h. Du musst natürlich die Config Deinem Verzeichnis anpassen:

<Directory /var/www/phpmyadmin>
Order allow,deny
Allow from all
</Directory>
 

pee

New Member
#11
Ich hab das in die 000-ispconfig.conf unter /etc/apache2/sites-enabled eingetragen und den Apache neu gestartet. Allerdings ging der Zugriff auf http://SERVER-ADRESSE/phpmyadmin weiterhin nicht.

Auch verstehe ich nicht, wieso ich das »natürlich« eintragen muss. Schließlich nutze ich ISPC schon eine Weile und der Zugriff auf den manuell hochgeladenen phpmyadmin ging sonst immer problemlos.
 

Till

Administrator
#12
Ich hab das in die 000-ispconfig.conf unter /etc/apache2/sites-enabled eingetragen und den Apache neu gestartet. Allerdings ging der Zugriff auf http://server-adresse/phpmyadmin weiterhin nicht.
Dann scahu ins log und sieh nach welcher pfad genau nicht erlaubt ist und füge deisen hinzu.

Auch verstehe ich nicht, wieso ich das »natürlich« eintragen muss. Schließlich nutze ich ISPC schon eine Weile und der Zugriff auf den manuell hochgeladenen phpmyadmin ging sonst immer problemlos.
das ist richtig. Es ging aber auch ein Zugriff auf diverse andere Verzeichnisse auf die man nicht zugreifen können sollte und das ist jetzt unterbunden.
 

pee

New Member
#13
Dann scahu ins log und sieh nach welcher pfad genau nicht erlaubt ist und füge deisen hinzu.
In meiner error.log unter /var/log/apache2 steht davon nichts:

[Wed Dec 02 13:15:59 2009] [error] [client 174.129.107.207] File does not exist: /usr/local/ispconfig/interface/web/index.htm
[Wed Dec 02 13:27:05 2009] [notice] caught SIGTERM, shutting down
[Wed Dec 02 13:27:07 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Wed Dec 02 13:27:07 2009] [notice] Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny3 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resuming normal operations
[Wed Dec 02 13:43:59 2009] [notice] caught SIGTERM, shutting down
[Wed Dec 02 13:44:01 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Wed Dec 02 13:44:01 2009] [notice] Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny3 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resuming normal operations
Der Webmailer (Squirrelmail) ist ja auch nicht erreichbar, obwohl er vom Paketmanager aus installiert wurde.
 

Till

Administrator
#14
Wenn im normalen apache log nichts steht dann greisft Du nicht über den default vhost auf diese tools zu. Dann musst Du in das log des vhosts sehen, den Du zum Zugriff benutzt.
 

pee

New Member
#15
Welcher Vhost soll das denn sein, es ist doch http://SERVER-IP/phpmyadmin. Hab dafür keinerlei Domain oder Client im ISPC-Panel angelegt.

Nachtrag:

Hab nun unter /etc/apache2/sites-enabled in der 000-default und 000-ispconfig.conf

<Directory /var/www/phpmyadmin>
Order allow,deny
Allow from all
</Directory>
eingetragen. Weiterhin bekomme ich die 403 Forbidden-Meldung vom Apache. In welche Config-Datei kann ich denn sonst noch eine Erlaubnis für das PhpMyAdmin-Verzeichnis eintragen?

lg
 
Zuletzt bearbeitet:

Till

Administrator
#16
Hast Du die Zeilen auch ganz am Ende der datei eingetragen?

Wenn ja, überprüfe mal ob /var/www/phpmyadmin wirklich ein Verzeichnis und kein Symlink ist.
 

Till

Administrator
#18
Hast Du denn den apache neu gestartet, nachdem Du das geändert hast?

Wenn ja, dann musst Du nochmal in den Logs suchen, es muss dort in einem der Error logs gelistet werden, warum der Zugriff nicht erlaubt ist.

Oder Du kommentierst die Zeilen:

<Directory />
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

aus, ist aber vom Sicherheitsstandpunkt aus nicht zu empfehlen.
 

pee

New Member
#19
Hab die Zeilen in der 000-ispconfig.conf unter /etc/apache2/sites-enabled auskommentiert, hat jedoch nach dem Apache-Neustart keine Wirkung gezeigt.

In der error.log ist m.E. nach auch nichts zu erkennen:

[Fri Dec 04 11:37:03 2009] [error] [client 216.245.205.242] File does not exist: /usr/local/ispconfig/interface/web/proxy
[Fri Dec 04 11:37:44 2009] [error] [client 216.245.205.242] File does not exist: /usr/local/ispconfig/interface/web/proxy
sh: host: command not found
sh: host: command not found
sh: host: command not found
[Fri Dec 04 12:46:32 2009] [error] [client 62.120.250.1] File does not exist: /usr/local/ispconfig/interface/web/config
sh: host: command not found
[Fri Dec 04 13:40:19 2009] [notice] caught SIGTERM, shutting down
[Fri Dec 04 13:40:22 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Fri Dec 04 13:40:22 2009] [notice] Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny3 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resuming normal operations
[Fri Dec 04 13:40:57 2009] [notice] caught SIGTERM, shutting down
[Fri Dec 04 13:40:59 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Fri Dec 04 13:40:59 2009] [notice] Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny3 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resuming normal operations
[Fri Dec 04 13:41:45 2009] [notice] caught SIGTERM, shutting down
[Fri Dec 04 13:41:47 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Fri Dec 04 13:41:47 2009] [notice] Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny3 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resuming normal operations
Also auf dem Server läuft sonst alles gut. Nur eben PhpMyAdmin (welches ich auch testweise per Paketmanager installiert habe) und Squirrelmail lassen sich seit einigen Tagen plötzlich nicht mehr aufrufen.

Würde mich sehr freuen, wenn ich mit eurer Hilfe das Problem lösen könnte.

lg

Nachtrag:
Was war denn die konkrekte Änderung in dem erwähnten Update? Vielleicht kann ich diese einfach wieder rückgängig machen.
 
Zuletzt bearbeitet:

pee

New Member
#20
Ich habe ISPC laut der HowTo-Anleitung für Debian Lenny installiert und nur immer mal wieder per apt-get update + apt-get upgrade Aktualisierungen durchgeführt.

In welche Datei könnte der Apache, außer der error.log, sonst seine Fehlermeldungen schreiben? Ist wirklich ärgerlich. Denn ich bin vorsichtig mit dem System umgegangen und habe trotzdem einen solchen Fehler..
 

Werbung

Top