Mail und FTP Login nicht möglich, teilweise kein Mailempfang

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Srux, 5. Dez. 2009.

  1. Srux

    Srux New Member

    Hallo zusammen!

    Ich habe das Problem, dass ich mich weder per Mailclient/Webmail, noch per FTP einloggen kann. Ich habe kein myDNS installiert, bei schlundt habe ich für MX jeweils mail.domain.tld. eingetragen. Die A Records lauten mail-/www-/ftp.domain.tld und zeigen auf die IP des Servers.

    Wenn ich eine Site anlege muss ich die IP statt * eintragen, sonst zeigt alles auf default in /var/www/
    mail.domain.tld,... tun dies ebenfalls, es sei denn ich wähle * als Auto-Subdomain aus. Auch nur dann kommen die Mails an.

    /var/log/mail.log sagt nach LoginVersuch immer nur LOGIN DENIED for user test@domain.tld

    auf den Telnet Ports der Maildaemons werde ich freundlich begrüßt, auch die Dienste saslauth, postfix, courier, smtp, imap, amavi, vsftpd usw laufen ohne Fehlermeldungen in den Logs.

    Nehme ich die Zeile 127.0.0.1 localhost.localdomain localhost aus der /etc/hosts raus, dann kommen die Mails an, und werden nicht rejected, wenn kein * bei Auto-Subdomain. Squirrelmail-Loginversuche melden jetzt postfix error: localhost not found.


    Hintergrundinfos:
    vServer mit Debian 4 LAMP -> dist-upgraded to Lenny
    hostname und hostname -f = vsXXXXXX.vserver.de
    vsftpd da pure-ftp nicht startete
    php safe mode off
    mysql not bind to 127.0.0.1
    saslauthd Standardname gefixt
    habe mich an das Perfect Server und dieses Howto gehalten


    Irgendwas übersehe ich da. Mittlerweile versuche ich seit ein paar Tagen alles aus, was ich per Netzsuche finden kann. Leider ohne Erfolg. Ich hoffe, jemand kann mit anderer Sichtweise auf diese Dinge ein paar Tips geben. Ich wäre euch sehr dankbar dafür! Ich hantiere eher mit Gentoo/Debian mit LVM und LUKS und habe keine Ahnung von Webservern.

    Anbei noch etwas Consolenoutput
    Code:
    netstat -tulpen
    
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       User       Inode       PID/Program name
    tcp        0      0 0.0.0.0:25              0.0.0.0:*               LISTEN      0          1662590499  11936/master    
    tcp        0      0 0.0.0.0:443             0.0.0.0:*               LISTEN      0          1662189583  8031/apache2    
    tcp        0      0 0.0.0.0:993             0.0.0.0:*               LISTEN      0          1662188879  7838/couriertcpd
    tcp        0      0 0.0.0.0:995             0.0.0.0:*               LISTEN      0          1662188919  7862/couriertcpd
    tcp        0      0 127.0.0.1:10024         0.0.0.0:*               LISTEN      107        1662185495  6067/amavisd (maste
    tcp        0      0 127.0.0.1:10025         0.0.0.0:*               LISTEN      0          1662590626  11936/master    
    tcp        0      0 0.0.0.0:3306            0.0.0.0:*               LISTEN      100        1662185720  7193/mysqld     
    tcp        0      0 0.0.0.0:110             0.0.0.0:*               LISTEN      0          1662188896  7847/couriertcpd
    tcp        0      0 0.0.0.0:143             0.0.0.0:*               LISTEN      0          1662188856  7819/couriertcpd
    tcp        0      0 127.0.0.1:783           0.0.0.0:*               LISTEN      0          1662186712  7342/spamd.pid  
    tcp        0      0 0.0.0.0:8080            0.0.0.0:*               LISTEN      0          1662189590  8031/apache2    
    tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      0          1662189581  8031/apache2    
    tcp        0      0 0.0.0.0:21              0.0.0.0:*               LISTEN      0          1662189449  7987/vsftpd     
    tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      0          1662184756  6010/sshd       
    

    Code:
    cat /var/log/mail.log
    
    Fri Dec  4 19:12:51 2009 [pid 19477] [test@domain.tld] FAIL LOGIN: Client "80.187.108.24"
    
    bei Webmail entsprechend mit 127.0.0.1
    

    Code:
    cat /var/log/vsftpd.log
    
    [B][I]Alle 5 Minuten das hier: (korrekt?)[/I][/B]
    Fri Dec  4 19:15:01 2009 [pid 22110] CONNECT: Client "127.0.0.1"
    Fri Dec  4 19:20:01 2009 [pid 28642] CONNECT: Client "127.0.0.1"
    Fri Dec  4 19:25:02 2009 [pid 4090] CONNECT: Client "127.0.0.1"
    

    Log bei Versuch Mailclient zu konfigurieren (Mail OSX)
    Code:
    Dec  4 23:18:48 vsXXXXXX postfix/smtpd[15434]: connect from ip-88-153-56-185.unitymediagroup.de[88.153.56.185]
    Dec  4 23:18:48 vsXXXXXX postfix/smtpd[15434]: SSL_accept error from ip-88-153-56-185.unitymediagroup.de[88.153.56.185]: -1
    Dec  4 23:18:48 vsXXXXXX postfix/smtpd[15434]: lost connection after STARTTLS from ip-88-153-56-185.unitymediagroup.de[88.153.56.185]
    Dec  4 23:18:48 vsXXXXXX postfix/smtpd[15434]: disconnect from ip-88-153-56-185.unitymediagroup.de[88.153.56.185]
    Dec  4 23:18:50 vsXXXXXX postfix/smtpd[15434]: connect from ip-88-153-56-185.unitymediagroup.de[88.153.56.185]
    Dec  4 23:18:50 vsXXXXXX postfix/smtpd[15434]: warning: SASL authentication failure: Can only find author (no password)
    Dec  4 23:18:50 vsXXXXXX postfix/smtpd[15434]: warning: ip-88-153-56-185.unitymediagroup.de[88.153.56.185]: SASL PLAIN authentication failed: bad protocol / cancel
    Dec  4 23:18:50 vsXXXXXX postfix/smtpd[15434]: lost connection after AUTH from ip-88-153-56-185.unitymediagroup.de[88.153.56.185]
    Dec  4 23:18:50 vsXXXXXX postfix/smtpd[15434]: disconnect from ip-88-153-56-185.unitymediagroup.de[88.153.56.185]
    Dec  4 23:19:17 vsXXXXXX imapd-ssl: Unexpected SSL connection shutdown.
    

    Code:
    ps aux | grep postfix
    root     11936  0.0  0.2   5408  1800 ?        Ss   18:41   0:00 /usr/lib/postfix/master
    postfix  11938  0.0  0.2   7812  2316 ?        S    18:41   0:00 qmgr -l -t fifo -u
    postfix  13472  0.0  0.3   5788  2616 ?        S    18:42   0:00 tlsmgr -l -t unix -u -c
    postfix   9424  0.0  0.2   5420  1724 ?        S    22:01   0:00 pickup -l -t fifo -u -c
    

    Code:
    ps aux | grep courier
    root      7806  0.0  0.0   1752   428 ?        S    18:14   0:00 /usr/sbin/courierlogger -pid=/var/run/courier/authdaemon/pid -start /usr/lib/courier/courier-authlib/authdaemond
    root      7807  0.0  0.0   1884   604 ?        S    18:14   0:00 /usr/lib/courier/courier-authlib/authdaemond
    root      7809  0.0  0.0   1884   300 ?        S    18:14   0:00 /usr/lib/courier/courier-authlib/authdaemond
    root      7810  0.0  0.0   1884   216 ?        S    18:14   0:00 /usr/lib/courier/courier-authlib/authdaemond
    root      7811  0.0  0.0   1884   216 ?        S    18:14   0:00 /usr/lib/courier/courier-authlib/authdaemond
    root      7812  0.0  0.0   1884   272 ?        S    18:14   0:00 /usr/lib/courier/courier-authlib/authdaemond
    root      7813  0.0  0.0   1884   300 ?        S    18:14   0:00 /usr/lib/courier/courier-authlib/authdaemond
    root      7817  0.0  0.0   1756   432 ?        S    18:14   0:00 /usr/sbin/courierlogger -pid=/var/run/courier/imapd.pid -start -name=imapd /usr/sbin/couriertcpd -address=0 -maxprocs=40 -maxperip=20 -nodnslookup -noidentlookup 143 /usr/lib/courier/courier/imaplogin /usr/bin/imapd Maildir
    root      7819  0.0  0.0   1860   604 ?        S    18:14   0:00 /usr/sbin/couriertcpd -address=0 -maxprocs=40 -maxperip=20 -nodnslookup -noidentlookup 143 /usr/lib/courier/courier/imaplogin /usr/bin/imapd Maildir
    root      7837  0.0  0.0   1756   432 ?        S    18:14   0:00 /usr/sbin/courierlogger -pid=/var/run/courier/imapd-ssl.pid -start -name=imapd-ssl /usr/sbin/couriertcpd -address=0 -maxprocs=40 -maxperip=20 -nodnslookup -noidentlookup 993 /usr/bin/couriertls -server -tcpd /usr/lib/courier/courier/imaplogin /usr/bin/imapd Maildir
    root      7838  0.0  0.0   1860   604 ?        S    18:14   0:00 /usr/sbin/couriertcpd -address=0 -maxprocs=40 -maxperip=20 -nodnslookup -noidentlookup 993 /usr/bin/couriertls -server -tcpd /usr/lib/courier/courier/imaplogin /usr/bin/imapd Maildir
    root      7845  0.0  0.0   1756   432 ?        S    18:14   0:00 /usr/sbin/courierlogger -pid=/var/run/courier/pop3d.pid -start -name=pop3d /usr/sbin/couriertcpd -maxprocs=40 -maxperip=4 -nodnslookup -noidentlookup -address=0 110 /usr/lib/courier/courier/courierpop3login /usr/lib/courier/courier/courierpop3d Maildir
    root      7847  0.0  0.0   1860   604 ?        S    18:14   0:00 /usr/sbin/couriertcpd -maxprocs=40 -maxperip=4 -nodnslookup -noidentlookup -address=0 110 /usr/lib/courier/courier/courierpop3login /usr/lib/courier/courier/courierpop3d Maildir
    root      7861  0.0  0.0   1756   432 ?        S    18:14   0:00 /usr/sbin/courierlogger -pid=/var/run/courier/pop3d-ssl.pid -start -name=pop3d-ssl /usr/sbin/couriertcpd -address=0 -maxprocs=40 -maxperip=4 -nodnslookup -noidentlookup 995 /usr/bin/couriertls -server -tcpd /usr/lib/courier/courier/courierpop3login /usr/lib/courier/courier/courierpop3d Maildir
    root      7862  0.0  0.0   1860   604 ?        S    18:14   0:00 /usr/sbin/couriertcpd -address=0 -maxprocs=40 -maxperip=4 -nodnslookup -noidentlookup 995 /usr/bin/couriertls -server -tcpd /usr/lib/courier/courier/courierpop3login /usr/lib/courier/courier/courierpop3d Maildir
    root     32364  0.0  0.0   1640   544 pts/0    S+   23:34   0:00 grep courier
    

    Code:
    /etc/init.d/openbsd-inetd start
    Not starting internet superserver: no services enabled.
    Nachtrag: zufällig beim neustarten der Dienste entdeckt:
    Code:
    /etc/init.d/saslauthd restart
    Stopping : saslauthd.
    Starting : saslauthdsaslauthd[24350] :detach_tty      : Cannot start saslauthd
    saslauthd[24350] :detach_tty      : Another instance of saslauthd is currently running
     failed!
    root@vsXXXXXX:~# /etc/init.d/saslauthd stop
    Stopping : saslauthd.
    root@vsXXXXXX:~# /etc/init.d/saslauthd start
    Starting : saslauthdsaslauthd[24550] :detach_tty      : Cannot start saslauthd
    saslauthd[24550] :detach_tty      : Another instance of saslauthd is currently running
     failed!
    
    [B][I]Kümmert sich courier/postfix um den Dienst??[/I][/B]
    s aux | grep sasl
    root      7982  0.0  0.0   8156   752 ?        Ss   Dec04   0:00 /usr/sbin/saslauthd -a shadow -c -r -m /var/run/saslauthd -n 1
    
    
     
    Zuletzt bearbeitet: 5. Dez. 2009
  2. Till

    Till Administrator

    Websites haben mit mails nichts zu tun, es kann da also keinen Zusammenhang geben. Das sind komplett unterschiedliche Dienste die sich gegenseitig nicht beeinflussen können. Dass Du die IP im Web auswählen musst ist ok und hängt u.a. von der Konfiguration Deines Servers ab.

    Stell bitte sicher dass Du als Basis des Servers ein minimalsystem genommen hast und dann exakt dem Tutorial gefolgt bist. Außerdem musst Du sicherstellen dass Du nicht versucht hast irgend ein anderes Controlpanbel vorher zu installieren, so dass Du wirklich ein sauberes System als Grundlage genommen hast!

    Ganz schlechte Idee, so wirst Du keinen FTP ZUgang bekommen. Deinstallier es bitte und installier wieder pure-ftpd. Wenn es bei Deinem vserver nicht startet, musst Du enteweder capabilities im vserver setup aktivieren lassen oder pure-ftpd ohne capabilitis kompilieren. dazu gibt es diverse threads hier und auch ein Tutorial.

    Es sind keinerlei Änderunge notwendig, da der ISPConfig installer das richtig konfiguriert. Wenn Du was geändert hast, kann das gut den Fehler verursacht haben.
     
  3. Srux

    Srux New Member

    Erstmal vielen Dank für dein Hilfe!

    Den Server habe ich jetzt noch einmal neu aufgesetzt und das Minimal Image verwendet. Pure-ftp habe ich mit --without-capabilities kompiliert und erfolgreich installiert. Startet! Und funktioniert auch mit 2 unterschiedlichen Domains wunderbar!

    Allerdings kann ich mich weder in Squirrelmail noch per Client anmelden:
    Code:
    Dec  7 16:02:11 vsXXXXXX postfix/smtpd[28543]: connect from p5087799E.dip.t-dialin.net[XXX.YYY.XXX.YYY]
    Dec  7 16:02:12 vsXXXXXX postfix/smtpd[28543]: SSL_accept error from p5087799E.dip.t-dialin.net[XXX.YYY.XXX.YYY]: -1
    Dec  7 16:02:12 vsXXXXXX postfix/smtpd[28543]: lost connection after STARTTLS from p5087799E.dip.t-dialin.net[XXX.YYY.XXX.YYY]
    Dec  7 16:02:12 vsXXXXXX postfix/smtpd[28543]: disconnect from p5087799E.dip.t-dialin.net[XXX.YYY.XXX.YYY]
    Dec  7 16:02:13 vsXXXXXX postfix/smtpd[28543]: connect from p5087799E.dip.t-dialin.net[XXX.YYY.XXX.YYY]
    Dec  7 16:02:13 vsXXXXXX postfix/smtpd[28543]: SSL_accept error from p5087799E.dip.t-dialin.net[XXX.YYY.XXX.YYY]: -1
    Dec  7 16:02:13 vsXXXXXX postfix/smtpd[28543]: lost connection after STARTTLS from p5087799E.dip.t-dialin.net[XXX.YYY.XXX.YYY]
    Dec  7 16:02:13 vsXXXXXX postfix/smtpd[28543]: disconnect from p5087799E.dip.t-dialin.net[XXX.YYY.XXX.YYY]
    Dec  7 16:02:13 vsXXXXXX postfix/smtpd[28543]: connect from p5087799E.dip.t-dialin.net[XXX.YYY.XXX.YYY]
    Dec  7 16:02:15 vsXXXXXX postfix/smtpd[28543]: warning: SASL authentication failure: Password verification failed
    Dec  7 16:02:15 vsXXXXXX postfix/smtpd[28543]: warning: p5087799E.dip.t-dialin.net[XXX.YYY.XXX.YYY]: SASL PLAIN authentication failed: authentication failure
    Dec  7 16:02:15 vsXXXXXX postfix/smtpd[28543]: disconnect from p5087799E.dip.t-dialin.net[XXX.YYY.XXX.YYY]
    Dec  7 16:02:23 vsXXXXXX imapd-ssl: Connection, ip=[::ffff:XXX.YYY.XXX.YYY]
    Dec  7 16:02:23 vsXXXXXX imapd-ssl: LOGIN FAILED, user=test@domain.tld, ip=[::ffff:XXX.YYY.XXX.YYY]
    
    Die Benutzernamen habe ich der mit der ispconfig Datenbank verglichen, ich melde mich in der Form test@domain.tld an.

    vsftpd wird doch unterstützt, oder ist es dann ein ähnliches "capabilities" Problem. Das LAMP Image hatte ich benutzt, da es sich um eine kleine RAM schonende Konfiguration handelte, vsftpd war bereits inbegriffen. Bevor ich was neues getestet habe, habe ich jedesmal neu intsalliert um ein sauberes System zu haben. Andere Control Panels waren keine drauf, dafür gibts ein Image.

    Jetzt muss ich mich doch noch was mehr einlesen, wo ich RAM sparen kann. Aber wichtiger ist, dass die Mails noch laufen, brauch ich ab und an mal ;)

    Was mich noch ein wenig wundert ist, dass ich per domain.tld/phpmyadmin fündig werde, aber domain.tld/webmail in eine Fehlerseite führt. Ist das so gewollt?
     
  4. Srux

    Srux New Member

    So, ich denke, dass ich das Mailproblem noch etwas eingrenzen kann:

    - per telnet konnte ich eine Nachricht verschicken -> ist auch angekommen.
    - Mails empfangen kann der Server auch
    - möchte ich aber per telnet meine mails abrufen, bleibe ich immer mit einem angeblich falschem Passwort hängen. Auch, wenn ich es noch einmal abändere.

    Jemand eine Idee?
     
  5. Burge

    Burge Member

    da hängt was wie im oberen log schon sieht an deiner tls / ssl einstellung.

    Schau nochmal bei den entsprechenden stellen im howto nach.
     
  6. Srux

    Srux New Member

    DANKE, das wars!!!!
    Beim neustarten aller Dienste habe ich folgende Zeile gefunden:
    Code:
    Dec  7 19:04:24 vs184165 authdaemond: libauthmysql.so: cannot open shared object file: No such file or directory
    
    Nach einem
    Code:
    aptitude install courier-authlib-mysql
    
    und einem
    Code:
    php -q update.php
    sowie neukonfigurieren aller Dienste lief es dann wie geschmiert!!!!

    Ich danke euch beiden vielmals für eure Hilfe! Vielen Dank!

    Jetzt hätte ich nur noch eine kleine offene Frage:
     
  7. Burge

    Burge Member

    was steht dazu im error log des apachen drin.

    Wobei ich mal anmerken muss das du kein howto von howtoforge verwendet hast.
    Mal schauen ob ma helfen können ;)
     
  8. Srux

    Srux New Member

    In der error.log kann ich diesbezüglich keinen Fehler erkennen

    cat /var/log/apache2/other_vhosts_access.log
    meldet nur die Verbindung.

    Ich werde mir das Howto von hier nochmal ganz genau ansehen und lasse mir mal etwas mehr Zeit beim installieren!!
    Denn wie ich gerade feststellen musste, kann ich noch nicht über den Mailclient senden, nur Webmail (inkl. senden) und Empfangen geht.

    Ich melde mich dann wieder hier.
    Bis hier hin nochmals Danke!
     
  9. Srux

    Srux New Member

    So weit - so gut!!! Jetzt läuft beinahe alles inkl. Mails senden/empfangen mit und ohne SSL, FTP, vHosts und die Datenbanken. Ich habe mich dieses mal ausschließlich an das verlinkte HowTo für Lenny gehalten.

    Zum Abschluss wäre es allerdings noch wunderbar, wenn mir jemand erklären könnte, wie ich das oben beschriebene Problem mit dem Webmailer zu der entsprechenden Domain in den Griff bekomme.

    phpMyAdmin ist von jeder Domain aus zu erreichen, obwohl nicht einmal ein symlink in /var/www/ liegt.

    Die log-Dateien in /var/log/apache2/ geben dazu kein Kommentar ab, lediglich das oben genannte.

    In der /etc/apache2/sites-enabled/000-ispconfig.conf steht
    Code:
    ################################################
    # ISPConfig Logfile configuration for vlogger
    ################################################
    
    LogFormat "%v %h %l %u %t \"%r\" %>s %B \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
    CustomLog "| /usr/local/ispconfig/server/scripts/vlogger -s access.log -t \"%Y%m%d-access.log\" -d \"/etc/vlogger-dbi.conf\" /var/log/ispconfig/httpd" combined_ispconfig
    
    <Directory /var/www/clients>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    # Do not allow access to the root file system of the server for security reasons
    <Directory />
           AllowOverride None
           Order Deny,Allow
           Deny from all
    </Directory>
    
    # Except of the following directories that contain website scripts
    <Directory /usr/share/phpmyadmin>
            Order allow,deny
            Allow from all
    </Directory>
    
    <Directory /usr/share/squirrelmail>
            Order allow,deny
            Allow from all
    </Directory>
    
    gleiches gilt für sites-available/...

    Der Log in /var/log/ispconfig/httpd/domain.tld/error.log steht
    Code:
    [Mon Dec 07 22:26:21 2009] [error] [client [I]XXX.YYY.XXX.YYY[/I]] File does not exist: /var/www/[I]domain.tld[/I]/web/webmail
    
     
  10. Srux

    Srux New Member

    Ich habe weitere Configs für phpMyAdmin im System gefunden und analog zu dessen config Datei die u.a. webmail.conf angelegt. Den Autentifizierungsteil von phpmyadmin habe ich weggelassen.

    cat /etc/apache2/conf.d/webmail.conf
    Code:
    Alias /webmail /usr/share/squirrelmail
    
    <Directory /usr/share/squirrelmail>
    	Options Indexes FollowSymLinks
    	#DirectoryIndex login.php
    
    	<IfModule mod_php4.c>
    		AddType application/x-httpd-php .php
    
    		php_flag magic_quotes_gpc Off
    		php_flag track_vars On
    		php_flag register_globals Off
    		php_value include_path .
    	</IfModule>
    	<IfModule mod_php5.c>
    		AddType application/x-httpd-php .php
    
    		php_flag magic_quotes_gpc Off
    		php_flag track_vars On
    		php_flag register_globals Off
    		php_value include_path .
    	</IfModule>
    </Directory>
    
    Es funktioniert! Kurze Frage nur an euch ob ich das so stehen lassen kann, oder ob ihr bedenken habt.
    Dann kann dieser Thread eigentlich auch geschlossen werden.
     
  11. Till

    Till Administrator

    Das funktioniert leider nur solange, wie Du in allen Websites mod_php aktiviert hast. Bei suphp bzw. php-fcgi wirst Du einen Zugriffsfehler erhalten und wenn garkein PHp aktiviert ist, erhalten die User den Quelltext im Browser.
     
  12. Srux

    Srux New Member

    Hmm....Deine Angabe kann ich leider nicht nachvollziehen. Der Webmailer wird mit allen Verfügbaren PHP Modi angezeigt, selbst dann wenn PHP deaktiviert ist.

    Gibt es denn ansonsten eine bessere Lösung?

    ISPConfig ist wirklich toll, ich habe noch z-Push nachträglich installiert und es funktioniert bestens in Zusammenarbeit mit meinem iPhone. Es sind diverse kleinere Änderungen nötig, damit eMails auch verschoben bzw. gelöscht werden können, aber es pusht wunderbar vor sich hin.

    Als dank für eure Hilfe kann ich gerne ein kleines Howto fürs Forum schreiben, auch wenn alle nötigen Infos per Websuche zu finden sind.
     
  13. Till

    Till Administrator

    Die Lösung die ich grundsätzlich empfehle, ist einen eigen vhost für webmail und php anzulegen.

    Also erstelle eine neue webseite in ispconfig mit der domain:

    webmail.deinedomain.de

    und installiere einen beliebigen webmail client darin. das gleiche für phpmyadmin mit z.B. phpmyadmin.deinedomain.de. So wirst Du ein gut laufendes und vor allem sicheres setup erhalten.
     
  14. Srux

    Srux New Member

    Ok, dann werde ich das so machen. Danke für den Hinweis!
     

Diese Seite empfehlen