Mailaccount login

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von brave_snoopy, 23. Apr. 2008.

  1. brave_snoopy

    brave_snoopy New Member

    Hallo,

    ich habe nun für meine Webs emailaccounts eingerichtet.
    Allerdings kann man sich nicht am webserver per pop3 anmelden.

    emailadresse eines webs.

    test@test.de

    username web8_test
    kennwort test

    Wenn ich nun im Outlook ein konto einrichte. sage pop3 und smtp sind die und die server.

    als benutzername gebe ich web8_test an und als kennwort test.

    allerding kann sich outlook dann nicht anmelden, es kommt immerwieder die meldung, ich solle doch benutzername und kennwort eingeben.

    Was mach ich falsch?
     
  2. Till

    Till Administrator

    Poste bitte mal die Ausgabe der Befehle:

    iptables -L

    und

    netstat -tap
     
  3. brave_snoopy

    brave_snoopy New Member

    Code:
    
    phoenix:~ # iptables -L
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
    phoenix:~ #
    
    und netstat -tap

    Code:
    netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 *:5801                  *:*                     LISTEN      3829/xinetd
    tcp        0      0 *:5802                  *:*                     LISTEN      4231/Xvnc
    tcp        0      0 *:mysql                 *:*                     LISTEN      2447/mysqld
    tcp        0      0 *:5901                  *:*                     LISTEN      3829/xinetd
    tcp        0      0 *:pop3                  *:*                     LISTEN      29276/couriertcpd
    tcp        0      0 *:5902                  *:*                     LISTEN      4231/Xvnc
    tcp        0      0 *:sunrpc                *:*                     LISTEN      3462/portmap
    tcp        0      0 *:www-http              *:*                     LISTEN      27827/httpd2-prefor
    tcp        0      0 *:hosts2-ns             *:*                     LISTEN      3202/ispconfig_http
    tcp        0      0 *:6002                  *:*                     LISTEN      4231/Xvnc
    tcp        0      0 *:980                   *:*                     LISTEN      3782/rpc.rquotad
    tcp        0      0 *:ftp                   *:*                     LISTEN      4398/proftpd: (acce
    tcp        0      0 phoenix:domain          *:*                     LISTEN      30105/named
    tcp        0      0 localhost:domain        *:*                     LISTEN      30105/named
    tcp        0      0 *:ssh                   *:*                     LISTEN      3833/sshd
    tcp        0      0 localhost:ipp           *:*                     LISTEN      3483/cupsd
    tcp        0      0 *:smtp                  *:*                     LISTEN      16565/master
    tcp        0      0 localhost:953           *:*                     LISTEN      30105/named
    tcp        0      0 *:https                 *:*                     LISTEN      27827/httpd2-prefor
    tcp        0   1332 phoenix:ssh             localhos:bv-queryengine ESTABLISHED 18456/0
    phoenix:~ #
    
    Aber courier-pop läuft ja. er verbindet ich ja mit dem server, es kommt halt nur die meldung, das der benutzername bzw. kennwort falsch ist und ich ihn doch gerne erneut und richtig eingeben soll.
     
  4. Till

    Till Administrator

    Poste mal die Ausgabe von:

    grep web8_test /etc/passwd
     
  5. brave_snoopy

    brave_snoopy New Member

    web8_test:x:10039:10008:test:/srv/www/web8/user/web8_test:/bin/false
     
  6. Till

    Till Administrator

    Das sieht soweit ok aus. Was ist denn die exakte Fehlermeldunf, die Du im mail log erhältst?
     
  7. brave_snoopy

    brave_snoopy New Member

    in der /var/log/mail steht folgendes

    Code:
    
    Apr 28 10:55:29 phoenix pop3d: Connection, ip=[::ffff:192.168.0.53]
    Apr 28 10:55:29 phoenix pop3d: chdir Maildir: No such file or directory
    Apr 28 10:55:31 phoenix pop3d: Connection, ip=[::ffff:192.168.0.53]
    Apr 28 10:55:31 phoenix pop3d: chdir Maildir: No such file or directory
    
    
     
  8. Till

    Till Administrator

    Mache bitte unter Administration > Server > Einstellungen in ISPConfig bei "Maildir" einen haken.
     
  9. brave_snoopy

    brave_snoopy New Member

    ok, empfangen geht. Danke.

    Allerdings klappt das senden noch nicht.

    Er versucht über SASL die Authentifizierung zu machen. Allerdings möchte ich keine Verschlüsselte Verbindung.

    Wen nich nun eine Mail versuche zu verschicken, erscheint im Log folgendes:

    Code:
    Apr 28 11:06:01 phoenix postfix/smtpd[29445]: warning: 192.168.0.53: address not listed for hostname localhost
    Apr 28 11:06:01 phoenix postfix/smtpd[29445]: connect from unknown[192.168.0.53]
    Apr 28 11:06:01 phoenix postfix/smtpd[29445]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
    Apr 28 11:06:01 phoenix postfix/smtpd[29445]: warning: unknown[192.168.0.53]: SASL LOGIN authentication failed: generic failure
    Apr 28 11:06:01 phoenix postfix/smtpd[29445]: lost connection after AUTH from unknown[192.168.0.53]
    Apr 28 11:06:01 phoenix postfix/smtpd[29445]: disconnect from unknown[192.168.0.53]
    Apr 28 11:06:03 phoenix postfix/smtpd[29445]: warning: 192.168.0.53: address not listed for hostname localhost
    Apr 28 11:06:03 phoenix postfix/smtpd[29445]: connect from unknown[192.168.0.53]
    Apr 28 11:06:03 phoenix postfix/smtpd[29445]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
    Apr 28 11:06:03 phoenix postfix/smtpd[29445]: warning: unknown[192.168.0.53]: SASL LOGIN authentication failed: generic failure
    Apr 28 11:06:03 phoenix postfix/smtpd[29445]: lost connection after AUTH from unknown[192.168.0.53]
    Apr 28 11:06:03 phoenix postfix/smtpd[29445]: disconnect from unknown[192.168.0.53]
    Apr 28 11:06:03 phoenix pop3d: Connection, ip=[::ffff:192.168.0.53]
    Apr 28 11:06:03 phoenix pop3d: LOGIN, user=web8_test, ip=[::ffff:192.168.0.53]
    Apr 28 11:06:03 phoenix pop3d: LOGOUT, user=web8_test, ip=[::ffff:192.168.0.53], top=0, retr=0, rcvd=12, sent=39, time=0
    phoenix:/var/log #
    
     
  10. Till

    Till Administrator

    Die Verbindung ist nicht verschlüsselt, SASL ist nicht SSL.

    Dein SASL Daemon ist nicht richtig konfigueriert, vergleiche bitte nochmal alle Konfigurationsdateien für SASL und Postfix (ist der Bereich des Postfix Setup im Howto) auf Deinem Server mit dem Perfect Setup.
     
  11. brave_snoopy

    brave_snoopy New Member

    stimmt, der saslauthd lief nicht. nun kann ich mails an den mailserver verschicken. allerdings schickt dieser diese nicht raus.

    was mich wundert, im log tauchen noch diese warnungen auf

    Code:
    Apr 28 11:27:57 phoenix postfix/smtp[31515]: fatal: specify a password table via the `smtp_sasl_password_maps' configuration parameter
    Apr 28 11:27:58 phoenix postfix/master[31410]: warning: process /usr/lib/postfix/smtp pid 31515 exit status 1
    Apr 28 11:27:58 phoenix postfix/master[31410]: warning: /usr/lib/postfix/smtp: bad command startup -- throttling
    
    zudem auch wenn ich mich mit meinem user anmelde und mir selber eine email schreibe, bleibt diese in der mailwarteschlange des postfix hängen. auch ein postfix flush versendet die mails nicht.

    kann dies mit oben genannten fehlermeldungen zutun haben?
     
  12. Till

    Till Administrator

    Hast Du Deinen Server nach der Beschreibung im perfect Setup konfiguriert? Der von Postfix bemängelte Fehler dürfte mit dem Perfect Setup nicht auftreten.

    Gehe bitte nochmal die gesamte Postfix Konfiguration durch und vergleiche Sie mit dem Perfect setup. Wenn der Postfix danach immer noch nicht startet, poste mal die main.cf datei, Kommentare in der Datei kannst Du entfernen.
     
  13. brave_snoopy

    brave_snoopy New Member

    Ich bin die Seite jetzt das dritte mal durchgegangen und finde keinen Fehler.
    Das einzige was ich nicht gemacht habe, sind die TLS Sachen. Da ich dies ja nicht benötige.

    hier meine main.cf

    Code:
    sendmail_path = /usr/sbin/sendmail
    
    # newaliases_path: The full pathname of the Postfix newaliases command.
    # This is the Sendmail-compatible command to build alias databases.
    #
    newaliases_path = /usr/bin/newaliases
    
    # mailq_path: The full pathname of the Postfix mailq command.  This
    # is the Sendmail-compatible mail queue listing command.
    #
    mailq_path = /usr/bin/mailq
    
    # setgid_group: The group for mail submission and queue management
    # commands.  This must be a group name with a numerical group ID that
    # is not shared with other accounts, not even with the Postfix account.
    #
    setgid_group = maildrop
    
    # html_directory: The location of the Postfix HTML documentation.
    #
    html_directory = /usr/share/doc/packages/postfix/html
    
    # manpage_directory: The location of the Postfix on-line manual pages.
    #
    manpage_directory = /usr/share/man
    
    # sample_directory: The location of the Postfix sample configuration files.
    # This parameter is obsolete as of Postfix 2.1.
    #
    sample_directory = /usr/share/doc/packages/postfix/samples
    
    # readme_directory: The location of the Postfix README files.
    #
    readme_directory = /usr/share/doc/packages/postfix/README_FILES
    inet_protocols = all
    biff = no
    mail_spool_directory = /var/mail
    canonical_maps = hash:/etc/postfix/canonical
    #virtual_alias_maps = hash:/etc/postfix/virtual
    virtual_alias_domains = hash:/etc/postfix/virtual
    relocated_maps = hash:/etc/postfix/relocated
    transport_maps = hash:/etc/postfix/transport
    sender_canonical_maps = hash:/etc/postfix/sender_canonical
    masquerade_exceptions = root
    masquerade_classes = envelope_sender, header_sender, header_recipient
    myhostname = phoenix.oftecs.de
    program_directory = /usr/lib/postfix
    inet_interfaces = all
    masquerade_domains =
    #mydestination = $myhostname, localhost.$mydomain
    defer_transports =
    mynetworks_style = subnet
    disable_dns_lookups = no
    relayhost =
    strict_8bitmime = no
    disable_mime_output_conversion = no
    smtpd_sender_restrictions = hash:/etc/postfix/access
    smtpd_client_restrictions =
    smtpd_helo_required = no
    smtpd_helo_restrictions =
    strict_rfc821_envelopes = no
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_relay_domains
    smtp_sasl_auth_enable = yes
    smtpd_sasl_auth_enable = yes
    smtpd_use_tls = no
    smtp_use_tls = no
    alias_maps = hash:/etc/aliases
    mailbox_size_limit = 0
    message_size_limit = 10240000
    
    virtual_maps = hash:/etc/postfix/virtusertable
    
    mydestination = /etc/postfix/local-host-names
    mydomain = oftecs.local
    mynetworks = 127.0.0.0/8
    smtpd_tls_auth_only = no
    smtpd_sasl_local_domain =
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    phoenix:/etc/postfix #
    
    Hoffe du kannst damit nun mehr anfangen.

    Das einzige was nun in der mail.err Datei tonnenweise steht ist folgendes:

    Code:
    
    Apr 28 15:48:21 phoenix postfix/smtp[14436]: fatal: specify a password table via the `smtp_sasl_password_maps' configuration parameter
    
    
    Dies taucht jede Minute auf. Ich würde es mit dem Problem in zusammenhang bringen, denn postfix versucht ja wahrscheinlich jede Minute die Mails in der mailq zu senden..

    Aber mit der Fehlermeldung kann ich rein gar nichts anfangen.
     
  14. Till

    Till Administrator

    Kommentier bitte mal die Folgende Teile aus:

    smtp_sasl_auth_enable = yes

    und start dann postfix neu.

    Alternativ, wenn Du wirklich durch einen externen Mailserver relayen möchtest (z.B. den Deines Zugansproviders, wenn Du eine dynamsiche IP hats), dann müsstest Du den Server und die Passworte angeben wie hier beschrieben:

    http://www.howtoforge.com/postfix_relaying_through_another_mailserver
     
  15. brave_snoopy

    brave_snoopy New Member

    ok, jetzt sendet er auch raus.
    allerdings steht in der mailq nicht die richtige emailadresse, sondern derweb name..

    z.b. web8_info@domain.de

    ist das normal?
     
  16. Till

    Till Administrator

    Du musst die Absenderadresse immer in den Optionen Deines Mail-Clients einstellen, das gilt auch für Webmail Programme.
     
  17. brave_snoopy

    brave_snoopy New Member

    ich habe als absender die emailadresse im emailclient programm eingegeben.

    wenn ich z.b. nun mir selber eine emailschreibe, steht in der mailq folgendes:

    Code:
    
    -Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
    C110117085BE*    1387 Tue Apr 29 12:11:33  [EMAIL="test@alsweder-bautoffhandel.de"]test@alsweder-bautoffhandel.de[/EMAIL]
                                             [EMAIL="web8_test@phoenix.oftecs.de"]web8_test@phoenix.oftecs.de[/EMAIL]
    -- 1 Kbytes in 1 Request.
    
    
    also irgendwas scheint hier ja schiefzulaufen, oder wieso steht als recipient web8_test@phoenix.... ?
     
  18. Till

    Till Administrator

    Schau bitte nochmal in Deinem Mailclient nach, wie gesagt, das wird ausschließlich im mail Client konfiguriert.

    Die Ausgabe in der mailqueue des lokalen Systems ist auch nicht aussagekräftig, da die Zustellung zu System usern immer den Usernamen beinhaltet. was steht denn im Mail-Client als absender der Mail?

    Welchen Client nimmst Du denn?
     
  19. brave_snoopy

    brave_snoopy New Member

    zum testen hab ich outlook express genommen.

    ok dann ist es wegen den internen usern.

    was mri allerdings noch aufgefallen ist, die mails werden zwar rausgeschickt, aber nicht angenommen.

    Code:
    relay=mx10.unit.tiscali.de[213.205.33.195]:25, delay=0.46, delays=0.07/0/0.31/0.08, dsn=5.0.0, status=bounced (host mx10.unit.tiscali.de[213.205.33.195] said: 553 <[EMAIL="test@alsweder-bautoffhandel.de"]test@alsweder-bautoffhandel.de[/EMAIL]> unable to verify address (in reply to MAIL FROM command))
    
    
    
    dns eintrag für den mailserver und ein reversedns ist vorhanden.
     
  20. Till

    Till Administrator

    Du musst auch einen MX Record anlegen, damit extrene Mailserver die Adressen akzeptieren.

    dig MX alsweder-bautoffhandel.de

    ; <<>> DiG 9.2.1 <<>> MX alsweder-bautoffhandel.de
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 35292
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;alsweder-bautoffhandel.de. IN MX

    ;; AUTHORITY SECTION:
    de. 7200 IN SOA f.nic.de. ops.denic.de. 2008042945 7200 7200 3600000 7200

    ;; Query time: 12 msec
    ;; SERVER: 212.227.21.251#53(212.227.21.251)
    ;; WHEN: Tue Apr 29 12:54:13 2008
    ;; MSG SIZE rcvd: 95
     

Diese Seite empfehlen