Mailbox Quota wird beim Ändern nicht aktualisiert

Dieses Thema im Forum "Allgemein" wurde erstellt von nekr2005, 1. Feb. 2012.

  1. nekr2005

    nekr2005 New Member

    Hallo Leute,

    bei unserem ispconfig 3.0.4.2 Server gibt es ein Problem mit der Aktualisierung der Mailbox Quotas. Evtl. war es schon bei der Vorgängerversion, aber erst jetzt aufgefallen.

    So sieht es aus:

    Mailbox eines Users läuft voll, sagen wir mal mit 150 MB Quota,
    die Mailbox nimmt keine Mails mehr an.

    Ich setze über die ispconfig-Oberfläche die Quota hoch auf 1000 MB.
    Laut ispconfig Oberfläche wird es auch geändert, wird auch überall richtig
    angezeigt.

    In den IMAP-Clients wird die Quota aber immer noch mit 150 MB und die
    Mailbox als voll angezeigt (Thunderbird, Roundcube Webmail).

    Hab auch schon versucht den dovecot-Dienst neu zu starten, trotzdem
    nimmt er immer noch die 150 MB Quota irgendwoher.

    Hat jemand eine Idee woran es liegen kann?

    ispconfig 3.0.4.2 läuft auf Debian Lenny, als IMAP-Server wird dovecot eingesetzt.

    Ich danke im voraus für Antworten
     
  2. Till

    Till Administrator

    Poste mal die /etc/dovecot/dovecot-sql.conf Datei. Passwort vorher unkenntlich machen.
     
  3. nekr2005

    nekr2005 New Member

    So sieht der Inhalt aus
    (das was nicht auskommentiert ist):

    driver = mysql
    connect = host=localhost dbname=dbispconfig user=ispconfig password=passwort_maskiert
    default_pass_scheme = CRYPT

    password_query = SELECT password FROM mail_user WHERE login = '%u' AND disable%Ls = 'n'
    user_query = SELECT email as user, maildir as home, CONCAT('maildir:', maildir, '/Maildir') as mail, uid, gid, CONCAT('*:storage=', quota, 'B') AS quota_rule, CONCAT(maildir, '/.sieve') as sieve FROM mail_user WHERE email = '%u' AND disable%Ls = 'n'
     
  4. Till

    Till Administrator

    Sieht ok aus, dovecot sollte das damit quota direkt aus der mysql DB beziehen, es ist also identisch mit dem was ISPConfig anzeigt da beide auf das Feld "quota" der mail_user Tabelle zugreifen.

    Schau mal nach ob es in dem Maildir des betroffenen Users noch eine Datei "maildirsize" gibt welche das alte Quota enthält, wenn ja, kopier die mal woanders hin und teste dann nochmal.
     
  5. nekr2005

    nekr2005 New Member

    Eine Datei maildirsize mit der alten Quota drin gab es
    in der Maildir von dem User tatsächlich.

    Ich habe die jetzt woandershin verschoben.

    Laut IMAP-Clienst ist jetzt gar keine Quota mehr gesetzt.

    Auch wenn ich über die ispconfig-Oberfläche die Quota erneut anpasse,
    wird diese Datei nicht mehr angelegt. Auch wenn neue Mails in die
    Mailbox zugestellt werden.

    Müsste die nicht automatisch neu angelegt werden?
     
  6. Till

    Till Administrator

    Nein, da quota auf dovecot servern nur über die sql Datei konfiguriert wird. Die maildirsize Datei ist von einer alten ISPConfig 3 Version die noch kein Quota über SQL konnte und wird beim aktuellen ISPConfig nicht mehr benötigt.

    Hast Du beim updaten auf ISPConfig 3.0.4.2 ausgewählt, dass er die Dienste rekonfigurieren soll?
     
  7. nekr2005

    nekr2005 New Member

    Ok, sprich man sollte jetzt hergehen und die Datei maildirsize bei allen Users in den Maildirs löschen, ist es richtig?

    Die Quota-Abfrage bei den IMAP-Clients wie Thuderbird oder Roundcube bleibt
    dann ohne Funktion? (jetzt sagen die beiden, es sei kein Quota gesetzt)
     
  8. nekr2005

    nekr2005 New Member

    Ja, das hatte ich gemacht
     
  9. Till

    Till Administrator

    Sollte an sich funktionieren. Zumindest sind mir keine Probleme in anderen Installationen damit bekannt.
     
  10. nekr2005

    nekr2005 New Member

    ja, hatte ich gemacht, soweit ich sehe wurden auch die dovecot-Konfigurationsdateien dabei überschrieben/geändert
     
  11. Till

    Till Administrator

    Welche genaue Dovecot Version hast Du auf dem Server installiert?
     
  12. nekr2005

    nekr2005 New Member

    ist die Version, wo bei Debian Lenny dabei ist:

    apt-cache showpkg dovecot-imapd
    Package: dovecot-imapd
    Versions:
    1:1.0.15-2.3+lenny1 (/var/lib/apt/lists/ftp.de.debian.org_debian_dists_lenny_main_binary-i386_Packages) (/var/lib/apt/lists/security.debian.org_dists_lenny_updates_main_binary-i386_Packages) (/var/lib/dpkg/status)
     
  13. Till

    Till Administrator

    Die Quota Konfiguration hat sich in dovecot von 1.0.x auf 1.1.x geändert. Entweder Du aktualisierts Deinen Server auf Debian squeeze (für Lenny gibt es glaube ich sowieso nur noch diesen Monat updates und patches) oder aber Du versuchst eine andere user query, z.B.:

    Code:
    user_query = SELECT email as user, maildir as home, CONCAT('maildir:', maildir, '/Maildir') as mail, uid, gid, concat('maildir:storage=', quota) AS quota, CONCAT(maildir, '/.sieve') as sieve FROM mail_user WHERE email = '%u' AND disable%Ls = 'n'
     
  14. nekr2005

    nekr2005 New Member

    Vielen Dank für deine Hilfe!

    Jetz funktioniert es, wie es sollte.

    Als Abfrage habe ich jetzt die Zeile drin:

    Code:
    user_query = SELECT email as user, maildir as home, CONCAT('maildir:', maildir, '/Maildir') as mail, uid, gid, concat('maildir:storage=', floor(quota/1024)) AS quota, CONCAT(maildir, '/.sieve') as sieve FROM mail_user WHERE email = '%u' AND disable%Ls = 'n'
    Mit deiner Abfrage war die angezeigte Quota sonst um Faktor 1000 höher als die eigentlich eingestellt war.

    Die beiden anderen ispconfig-Server, die ich betreue, laufen mit Debian 6
    und sind wie vermutet, von diesem Prpblem nicht betroffen gewesen.
     

Diese Seite empfehlen