Mails an Freenet werden geblockt - DNS-Fehler?

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Hexer, 28. Jan. 2011.

  1. Hexer

    Hexer New Member

    Hi,

    wir nutzen Debian 5 mit Ispconfig 3. Der Mailversand klappt bisher ohne Probleme nach außen, lediglich Freenet blockt unsere E-Mails. Wir nutzen den Nameserver von Hetzner. Also keinen eigenen.

    Woran kann das liegen und wie behebe ich diesen Fehler? Liebe Grüße und vielen Dank

    Die Emailadressen und Server ip habe ich unkenntlich gemacht.

    Code:
    Reporting-MTA: dns; server1.meinedomain.de
    X-Postfix-Queue-ID: 2FE9A453C269
    X-Postfix-Sender: rfc822; me[EMAIL="hexer@blacksins.de"]@meinedomain.de[/EMAIL]
    Arrival-Date: Fri, 28 Jan 2011 10:33:01 +0100 (CET)
    
    Final-Recipient: rfc822; [EMAIL="grafyves1@freenet.de"]xyzempfänger@freenet.de[/EMAIL]
    Original-Recipient: [EMAIL="rfc822;grafyves1@freenet.de"]rfc822;[/EMAIL][EMAIL="grafyves1@freenet.de"]xyzempfänger[/EMAIL][EMAIL="rfc822;grafyves1@freenet.de"]@freenet.de[/EMAIL]
    Action: failed
    Status: 5.0.0
    Remote-MTA: dns; mx.freenet.de
    Diagnostic-Code: smtp; 550 inconsistent or no DNS PTR record for *.*.*.18
        (see RFC 1912 2.1)
     
  2. Moestchen

    Moestchen New Member

    Deine DNS-Konfiguration hat einen Fehler.
    Wenn du deine Ip nicht verschleiern würdest, könnte man es auch kontrollieren.
     
  3. Hexer

    Hexer New Member

    Hier ist die besagte Server Ip:

    178.63.43.18

    Bin über jeden Tipp dankbar. Bei Hetzern lässt sich im Controlpanel ein Reserve-DNS Eintrag machen. Wie hätte dieser dann auszusehen.

    Vielen lieben Dank.
     
  4. Moestchen

    Moestchen New Member

    Hallo,
    Sorry das ich erst jetzt antworte - du wartest sicherlich schon.
    Hab grad aber nur mein Galaxy parat und da arbeitet es sich nicht so gut.

    Wenn ich von deiner Ip den Hostname abfrage, erhalte ich static.178-63-43-18.clients.your-server.de als Antwort. Frage ich hierzu die Ip ab, erhalte ich kein Ergebnis.
    Wie sieht denn deine DNS-Konfiguration aus? Verwendet du die Nameserver von Hetzner oder hast du einen eigenen?


    Edit: Wegen den DNS-Einstellungen schau auch mal hier, http://www.howtoforge.de/forum/showthread.php?t=3960.
     
    Zuletzt bearbeitet: 28. Jan. 2011
  5. Hexer

    Hexer New Member

    Hi,

    erst einmal Danke, dass du mir versuchst weiterzuhelfen.

    Ich benutze keinen eigenen Nameserver und habe bei Ispconfig3 auch nichts weiter eingestellt bezüglich DNS.

    Code:
    $TTL 86400
    @   IN SOA ns1.first-ns.de. postmaster.robot.first-ns.de. (
        2011012500   ; serial
        14400        ; refresh
        1800         ; retry
        604800       ; expire
        86400 )      ; minimum
     
    @                        IN NS      robotns3.second-ns.com.
    @                        IN NS      robotns2.second-ns.de.
    @                        IN NS      ns1.first-ns.de.
     
    @                        IN A       178.63.43.18
    localhost                IN A       127.0.0.1
    mail                     IN A       178.63.43.18
    www                      IN A       178.63.43.18
    ftp                      IN CNAME   www
    imap                     IN CNAME   www
    loopback                 IN CNAME   localhost
    pop                      IN CNAME   www
    relay                    IN CNAME   www
    smtp                     IN CNAME   www
    @                        IN MX 10   mail
    Das ist bei Hetzner eingetragen und kann von mir geändert werden. Liegt hier der Hase im Pfeffer begraben?
     
  6. Moestchen

    Moestchen New Member

    Ändere im robot von Hetzner den Reverse-DNS auf mail.DEINEDOMAIN.DE
    und passe auf deinem Server den Hostname und die /etc/hosts an.

    /etc/hostname -> mail
    /etc/mailname -> mail.DEINEDOMAIN.DE
    /etc/hosts an. -> DEINE-IP mail.DEINEDOMAIN.DE mail


    Edit: Danach musst du glaube ich nochmal dein ispc3 updaten. Dazu kann Till aber mehr sagen.
     
    Zuletzt bearbeitet: 28. Jan. 2011
  7. Hexer

    Hexer New Member

    Hey,

    ich habe jetzt statt mail.meiendomain.de, server1.meinedomain.de... verwendet.

    Code:
    127.0.0.1 localhost.localdomain   localhost
    178.63.43.18 server1.meinedomain.de server1
    
    und server1.meinedomain.de als Reverse-DNS Eintrag genommen. Das sollte reichen, oder?

    Wird die Änderung sofort wirksam, oder muss ich mehrere Stunden warten?

    Danke nochmals.
     
    Zuletzt bearbeitet: 28. Jan. 2011
  8. Hexer

    Hexer New Member

    Ich warte einfach mal ab, vielleicht kann ja Till noch genauere Infos bekannt geben. Aber ich denke, dass wir auf dem richtigen Weg sind :)
     
  9. Moestchen

    Moestchen New Member

    Dann musst du noch deinen mx-Eintrag von Mail auf Server1 ändern.
     
  10. Hexer

    Hexer New Member

    Hi Moestchen!

    Meinst du

    Code:
    @                        IN MX 10   mail
    in

    Code:
    @                        IN MX 10 Server1
    ändern?

    Oder ist das eine Ispconfig bzw. Servereinstellung?

    Danke für deine Geduld mit mir! Ich weiß das sehr zu schätzen!
     
  11. Moestchen

    Moestchen New Member

    Ganz genau.
    Dein mx verweist auf server1 und server1 auf die IP. Und zu der IP wird der Reverse-DNS auf server1 aufgelöst. Sprich: Alles super!!!
     
  12. Hexer

    Hexer New Member

    Muss das Server1 auch wirklich großgeschrieben werden? bin gespannt obs klappt. Habs geändert. Wird wohl ein paar stunden dauern, bis das weltweit registriert wurde.
     
  13. Hexer

    Hexer New Member

    Also nachdem ich Server 1 eingetragen habe, ging gar nichts mehr :( Ich konnte keine Mails mehr senden und empfangen. Der Thunderbird konnte auch keine neuen Konten mehr anlegen bzw. fand den smtp sever nicht mehr.

    Also habe ich den mx Eintrag erstmal wieder auf mail gestellt.

    Anbei übersende ich einfach mal aktuelle Screenshots. Vielleicht kommen wir so an des Rätsels Lösung:

    Das ist der DNS-Eintrag für unsere Domain blacksins.de
    Code:
    $TTL 86400
    @   IN SOA ns1.first-ns.de. postmaster.robot.first-ns.de. (
        2011013000   ; serial
        14400        ; refresh
        1800         ; retry
        604800       ; expire
        86400 )      ; minimum
     
    @                        IN NS      robotns3.second-ns.com.
    @                        IN NS      robotns2.second-ns.de.
    @                        IN NS      ns1.first-ns.de.
     
    @                        IN A       178.63.43.18
    localhost                IN A       127.0.0.1
    mail                     IN A       178.63.43.18
    www                      IN A       178.63.43.18
    ftp                      IN CNAME   www
    imap                     IN CNAME   www
    loopback                 IN CNAME   localhost
    pop                      IN CNAME   www
    relay                    IN CNAME   www
    smtp                     IN CNAME   www
    @                        IN MX 10   mail
    Debian spuckt bei hostname und hostname -f jeweils server1.blacksins.de aus.

    Das ist der Reverse DNS-Eintrag bei Hetzner
    [​IMG]

    Die /etc/hosts ist wie folgt befüllt

    Code:
    ### Hetzner Online AG installimage
    # nameserver config
    # IPv4
    127.0.0.1 localhost.localdomain   localhost
    178.63.43.18 server1.blacksins.de server1
    #
    # IPv6
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
     
  14. Moestchen

    Moestchen New Member

    Nein sorry, wird klein geschrieben oder du schreibst jedes server1 groß. Etabliert hat sich aber die Kleinschreibung.
     
  15. niclas30

    niclas30 New Member

    Was war denn nun hier die Lösung? Funktionierte es dann mit "server1" und freenet?
     

Diese Seite empfehlen