Mails werden nicht den Benutzern zugeordnetq

#1
Hallo,

ich habe heute eine neue Domain zu meinem server übertragen bekommen.

Zuerst wurden keine Mails empfangen 'Relay access denie'. Da habe ich gemerkt, das in ISPconfig die Domain ohne www nicht akzeptiert...also schnell als co-domain eingetragen und es läuft, jedoch kommen die Mails nur im postmaster an (catch all) und nicht bei den erstellten usern.

In local-host-names sind alle domains jetzt vorhanden und unter virtusertable finde ich auch alle konten einträge!

Jemand eine Idee woran es liegen kann?

Ich nutze ISPconfig 2 mit Ubuntu 8.04 LTS

Gruß
Philipp
 
#3
in der main.cf steht die neue Domain auch nicht drin, nur meine original Domain.

Allerdings hat ausschalten von catch all vom Postmaster Konto der Hauptdomain das Problem gelöst. Der hat nämlich wirklich alles gecatched :(!
 

Till

Administrator
#4
Dann hast Du wohl aus Versehen die haupdomain in der main.cf stehen. Die in der main.cf stehende Domain für myhostname bzw. mydomain darf nicht als emaildomain in ispconfig verwendet werden, da postfix sonst das von Dir beschriebene Verhalten hat. Du musst also die Domain in der main.cf ändern, indem Du z.B. eine subdomain verwendest.
 
#5
ja steht da, aus Versehen aber eher nicht, nach HowTo Perfect Server...Anleitung und Einstellungen danach nicht mehr verändert.

Egal, danke für den Tip, werde ich morgen ausprobieren...ohne catchall läuft es schon mal und catchall wollte ich eh nach kurzer Einführungsphase ausschalten ;)

schönen feierabend
 

Till

Administrator
#6
Dann schau nochmal ins howto, dort steht drin dass Du eine subdomain nehmen sollst. nämlich server1.example.com und nicht example.com ;)
 

Werbung