Mod_mono für ASP.NET Fehler?

#1
Hallo

ich habe Debian Etch, neuste Version. Habe nun vorgehabt ASP.NET durch mod_mono zu installieren.

per
Code:
apt-get install libapache2-mod-mono
habe ich das installiert. Dabei sagte er mir aber einen Fehler an.

Code:
dpkg: error processing mono-apache-server (--configure):
 subprocess post-installation script killed by signal (Interrupt)
dpkg: dependency problems prevent configuration of libapache2-mod-mono:
 libapache2-mod-mono depends on mono-apache-server (>= 1.2.1) | mono-apache-server2 (>= 1.2.1); however:
  Package mono-apache-server is not configured yet.
  Package mono-apache-server2 is not installed.
 libapache2-mod-mono depends on mono-apache-server (<< 1.2.2) | mono-apache-server2 (<< 1.2.2); however:
  Package mono-apache-server is not configured yet.
  Package mono-apache-server2 is not installed.
dpkg: error processing libapache2-mod-mono (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 mono-apache-server
 libapache2-mod-mono
E: Sub-process /usr/bin/dpkg returned an error code (1)
ich weiß net was das bedeutet und ASP.NET Seiten werde auch noch nicht wirklich echt dargestellt. Wenn das jemand sehen möchte, ich kann gerne einen Link zu einer Testseite einstellen.

Vielen Dank für Hilfe.

André
 
#3
okay, gesagt getan
Code:
Debian-40-etch-32-minimal:~# apt-get -u upgrade
Reading package lists... Done
Building dependency tree... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Debian-40-etch-32-minimal:~# apt-get install libapache2-mod-mono
Reading package lists... Done
Building dependency tree... Done
libapache2-mod-mono is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Debian-40-etch-32-minimal:~#
nun macht er aber nichts weiter. er lässt alles einfach so

Testseite http://webby24.de/test/test.aspx

André
 
#5
Habe ich gemacht :-(

Code:
Debian-40-etch-32-minimal:~# apt-get install libapache2-mod-mono
Reading package lists... Done
Building dependency tree... Done
libapache2-mod-mono is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Debian-40-etch-32-minimal:~#
aber er mag mich nicht. Sagt es sei schon. Muss ich das vielleicht erst deinstallieren? Oder muss ich das dann auch erstmal in der php.ini aktivieren?

André
 

Till

Administrator
#6
Mono hat nichts mit PHP zu tun, also auch nicht mit der php.ini Datei. Hast Du denn die notwendigen apache Direktiven, um Mono zu verwenden, in das apache Direktiven FEld der Webseite getan und eine .aspx Seite zum Testen verwendet?
 
#7
Die ASPX Testseite läuft da ja immer. Nur ebenhalt mit den Fehler.

Nein die Direktiven habe ich nicht eingetragen. :eek:
Wie sind die denn??? Oder wo finde ich die Direktiven?

Danke Dir

André
 

Werbung