MySQL Database Cluster auf Debian 8.4 -> mysql-bin.log

Dieses Thema im Forum "Fragen zu Howtos" wurde erstellt von GregorXD, 22. Juli 2016.

  1. GregorXD

    GregorXD New Member

    Hallo,

    ich habe folgendes Problem. Ich habe eine alte ISPConfig Installation auf Debian 6 geupgraded auf debian 8 und dann die Daten auf einen Frisch aufgesetzten Debian Server mit MariaDB übertragen nach dieser Anleitung (The Perfect Server - Debian 8.4 Jessie (Apache2, BIND, Dovecot, ISPConfig 3.1)). Das funktioniert so weit aber nun wollte ich das ganze noch als Cluster betreiben und ich scheitere bei einem ganz banalen schritt:
    ich habe nun schon einige Varianten in der my.cnf ausprobiert und jedesmal auch den restart vom MySQL Service gemacht... komme nicht drauf warum ich immer diesen Fehler bekomme:
    mysqldump: Couldn't execute 'SELECT BINLOG_GTID_POS('', '0')': You are not using binary logging (1381)
    dieser Fehler kommt ähnlich auch wenn ich mich in MariaDB root einlogge: und show binary logs; ausführe.

    #
    # The MySQL database server configuration file.
    #
    # You can copy this to one of:
    # - "/etc/mysql/my.cnf" to set global options,
    # - "~/.my.cnf" to set user-specific options.
    #
    # One can use all long options that the program supports.
    # Run program with --help to get a list of available options and with
    # --print-defaults to see which it would actually understand and use.
    #


    # This will be passed to all mysql clients
    # It has been reported that passwords should be enclosed with ticks/quotes
    # escpecially if they contain "#" chars...
    # Remember to edit /etc/mysql/debian.cnf when changing the socket location.
    [client]
    port = 3306
    socket = /var/run/mysqld/mysqld.sock

    # Here is entries for some specific programs
    # The following values assume you have at least 32M ram

    # This was formally known as [safe_mysqld]. Both versions are currently parsed.
    [mysqld_safe]
    socket = /var/run/mysqld/mysqld.sock
    nice = 0

    [mysqld]

    #
    # * Basic Settings
    #
    user = mysql
    pid-file = /var/run/mysqld/mysqld.pid
    socket = /var/run/mysqld/mysqld.sock
    port = 3306
    basedir = /usr
    datadir = /var/lib/mysql
    tmpdir = /tmp
    lc-messages-dir = /usr/share/mysql
    skip-external-locking
    #
    # Instead of skip-networking the default is now to listen only on
    # localhost which is more compatible and is not less secure.
    #bind-address = 127.0.0.1
    #
    # * Fine Tuning
    #
    key_buffer = 16M
    max_allowed_packet = 16M
    thread_stack = 192K
    thread_cache_size = 8
    # This replaces the startup script and checks MyISAM tables if needed
    # the first time they are touched
    myisam-recover = BACKUP
    #max_connections = 100
    #table_cache = 64
    #thread_concurrency = 10
    #
    # * Query Cache Configuration
    #
    query_cache_limit = 1M
    query_cache_size = 16M
    #
    # * Logging and Replication
    #
    # Both location gets rotated by the cronjob.
    # Be aware that this log type is a performance killer.
    # As of 5.1 you can enable the log at runtime!
    #general_log_file = /var/log/mysql/mysql.log
    #general_log = 1
    #
    # Error log - should be very few entries.
    #
    log_error = /var/log/mysql/error.log
    #
    # Here you can see queries with especially long duration
    #slow_query_log_file = /var/log/mysql/mysql-slow.log
    #slow_query_log = 1
    #long_query_time = 2
    #log_queries_not_using_indexes
    #
    # The following can be used as easy to replay backup logs or for replication.
    # note: if you are setting up a replication slave, see README.Debian about
    # other settings you may need to change.
    #server-id = 1
    #log_bin = /var/log/mysql/mysql-bin.log
    #expire_logs_days = 10
    #max_binlog_size = 100M
    #binlog_do_db = include_database_name
    #binlog_ignore_db = include_database_name
    #
    server-id = 1
    replicate-same-server-id = 0
    auto-increment-increment = 2
    auto-increment-offset = 1
    log_bin = mysql-bin.log
    expire_logs_days = 10
    max_binlog_size = 100M
    binlog_format = mixed
    sync_binlog = 1
    relay-log = slave-relay.log
    relay-log-index = slave-relay-log.index
    slave_skip_errors = 1007,1008,1050, 1396
    bind-address = ::
    # * InnoDB
    #
    # InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
    # Read the manual for more InnoDB related options. There are many!
    #
    # * Security Features
    #
    # Read the manual, too, if you want chroot!
    # chroot = /var/lib/mysql/
    #
    # For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
    #
    # ssl-ca=/etc/mysql/cacert.pem
    # ssl-cert=/etc/mysql/server-cert.pem
    # ssl-key=/etc/mysql/server-key.pem


    [mysqldump]
    quick
    quote-names
    max_allowed_packet = 16M

    [mysql]
    #no-auto-rehash # faster start of mysql but no tab completition

    [isamchk]
    key_buffer = 16M

    #
    # * IMPORTANT: Additional settings that can override those from this file!
    # The files must end with '.cnf', otherwise they'll be ignored.
    #
    !includedir /etc/mysql/conf.d/
     
  2. nowayback

    nowayback Well-Known Member

    Pfad hattest du gesetzt?
    Code:
    [mysqld]
    log-bin=path/to/bin-logs
     
  3. GregorXD

    GregorXD New Member

    Danke für die schnelle Antwort

    Ja oben im Spoiler ist die aktuelle Konfig Datei:
    aktuell
    Code:
    log_bin = mysql-bin.log
    LG
    Gregor
     
  4. wotan2005

    wotan2005 Member

    das sollte so heissen:
    log_bin = /var/log/mysql/mysql-bin.log
     
  5. GregorXD

    GregorXD New Member

    ok ich habe das problem gefunden, so wie ich es oben geschrieben habe ist es zwar richtig und es muss nicht log_bin = /var/log/mysql/mysql-bin.log sein nur wenn man keinen datensatz ändert fängt er scheinbar nicht an die logdatei anzulegen und darum kann man dann auch kein dump machen. hat sich also mit einfach einer datensatzänderung leicht beheben lassen.

    LG
    Gregor
     

Diese Seite empfehlen