mysql problem

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Swordfish, 3. Mai 2013.

  1. Swordfish

    Swordfish New Member

    mysql probleme

    hallo ich bin neu hier und auch meine suche ergab keine ergebnisse

    ich habe debian nach eurer perfect debian anleitung gemacht

    aber nun habe ich die probleme das mysql angelegte benutzer sich nicht einloggen können


    ich habe gegoogelt und da ergab sich das ich ein mysql_upgrade machen soll,
    dies habe ich gemacht und putty spuckt folgendes aus

    ~# mysql_upgrade


    Looking for 'mysql' as: mysql
    Looking for 'mysqlcheck' as: mysqlcheck
    Running 'mysqlcheck' with connection arguments: '--port=3306' '--socket=/var/run/mysqld/mysqld.sock'
    mysqlcheck: Got error: 1045: Access denied for user 'root'@'localhost' (using password: NO) when trying to connect
    FATAL ERROR: Upgrade failed



    in meiner datenbank steht unten auch in rot

    Die zusätzlichen Funktionen für verknüpfte Tabellen wurden automatisch deaktiviert. Klicken Sie hier um herauszufinden warum.


    wenn ich da drauf drücke kommt folgendes


    $cfg['Servers'][$i]['pmadb'] ... OK $cfg['Servers'][$i]['relation'] ... fehlerhaft [ Dokumentation ] Allgemeine Verknüpfungsfunktionen: Deaktiviert $cfg['Servers'][$i]['table_info'] ... fehlerhaft [ Dokumentation ] Anzeige verknüpfter Daten: Deaktiviert $cfg['Servers'][$i]['table_coords'] ... fehlerhaft [ Dokumentation ] $cfg['Servers'][$i]['pdf_pages'] ... fehlerhaft [ Dokumentation ] Erzeugen von PDFs: Deaktiviert $cfg['Servers'][$i]['column_info'] ... fehlerhaft [ Dokumentation ] Darstellung von Spaltenkommentaren: Deaktiviert Darstellungsumwandlung: Deaktiviert $cfg['Servers'][$i]['bookmarktable'] ... fehlerhaft [ Dokumentation ] Gespeicherte SQL-Abfrage: Deaktiviert $cfg['Servers'][$i]['history'] ... fehlerhaft [ Dokumentation ] SQL-Verlaufsprotokoll: Deaktiviert $cfg['Servers'][$i]['designer_coords'] ... fehlerhaft [ Dokumentation ] Designer: Deaktiviert $cfg['Servers'][$i]['tracking'] ... fehlerhaft [ Dokumentation ] Tracking: Deaktiviert




    kann mir bitte jemand helfen

    vielen dank im voraus

    gruß
     
    Zuletzt bearbeitet: 3. Mai 2013
  2. nowayback

    nowayback Well-Known Member

    Code:
    mysql_upgrade -u root -p
    dann wirst du nachm passwort gefragt, gibst es ein und fertig eigentlich
     
    Zuletzt bearbeitet: 3. Mai 2013
  3. Swordfish

    Swordfish New Member

    ich habe es eingegeben aber es kommt genau die selbe fehlermeldung
     
  4. nowayback

    nowayback Well-Known Member

    hi,

    erstmal sorry, das ich nachmittag nur fix den Befehl gepostet hatte, aber ich war gerade im aufbruch und bin davon ausgegangen, dass dir nur der Parameter für die Passwortangabe gefehlt hat.

    das kann nicht sein, denn es müsste zumindest folgendes geändert sein von:

    Access denied for user 'root'@'localhost' (using password: NO)

    in:

    Access denied for user 'root'@'localhost' (using password: YES)


    Sollte das der Fall sein, hat entweder dein Passwort nicht gestimmt, der User "root" darf sich nicht von localhost verbinden (in dem fall könnte einfach noch -h server.deinedomain.de helfen), oder es gibt keinen User "root".

    Unabhängig davon: Hast du mal versucht dich per phpmyadmin einzuloggen?

    Außerdem wäre es hilfreich wenn du deinen Fehler "aber nun habe ich die probleme das mysql angelegte benutzer sich nicht einloggen können" irgendwie mal konkretisieren könntest. Welcher Benutzer, wie wurde er angelegt, wo kann er sich nicht einloggen und was steht in der mysql.log.

    Grüße
    nwb
     
  5. Swordfish

    Swordfish New Member

    ich habe mich mit benutzer root in die phpmyadmin oberfläche angemeldet.

    habe dort einen neuen benutzer angelegt und gesagt er soll eine datenbank mit selbigen namen bekommen

    habe alle felder ausgefüllt und habe in den feld

    Benutzer: Textfeld verwenden: {NAME}
    Host: Jeder Host:

    Passwort: xxxxxxxxx



    so habe ich es gemacht
    sehe ich dann als root in der rechteverwaltung nach steht dort bei host ein % und er kann sich nicht einloggen.

    nun habe ich eine weile ausprobiert und habe es auf lokal gestellt

    nun steht dort nicht mehr % sondern localhost und es geht

    kann es sein das das ein lüchtigkeitsfehler gewesen ist oder ist es wirklich ein problem?
    ich bin ein noch nicht wirklich geübt mit mysql
    aber irgendwann muss man ja anfangen

    danke für deine hilfe
     
  6. nowayback

    nowayback Well-Known Member

    hi,

    damit hast du dein problem schon selbst gefunden... wenn du als erlaubte hosts "Jeder host" wählst dann darfst du nicht über 127.0.0.1 zum mysql server verbinden sondern über die echte ip (jedoch: siehe voraussetzung), wählst du "Lokal" aus, dann darfst du nur über localhost (127.0.0.1) verbinden.

    Voraussetzung: du hast in der my.cnf vor "bind 127.0.0.1" ein "#" geschrieben und mysql neugestartet

    Tipp: du kannst auch 2x den gleichen User anlegen, 1x auf lokal und 1x auf jeder host und beide dürfen auf die gleiche datenbank zugreifen :)

    Grüße
    nwb
     

Diese Seite empfehlen