Nach Update auf 3.0.3.2 zeigt IP auf Kundenweb

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von csiebert, 31. März 2011.

  1. csiebert

    csiebert Member

    Hi,

    ich habe heute etwas merkwürdiges festgestellt... Nach dem Update auf 3.0.3.2 und einem dist-upgrade auf Debian 6 zeigt die URL des Servers (http://serverx.firma.de/) nicht mehr auf /var/www, sondern auf das Webverzeichnisses eines Kunden.

    Gemerkt habe ich es, als ich meine Roundcubeinstallation, welche bisher immer in /var/www/webmail lag, über http://serverx.firma.de/webmail aufrufen wollte und dort einen 404-Fehler kassiert habe. Zu Testzwecken habe ich dann einmal in der Apachekonfig die Serversignatur auf EMail umgestellt und unterhalb der 404-Meldung dann die Mailadresse des Kunden entdeckt. In dessen web-Ordner habe ich dann eine test.htm angelegt, die ich über http://serverx.firma.de/test.htm aufrufen konnte.

    Nun frage ich mich, wieso http://serverx.firma.de/ nicht mehr, wie früher, auf /var/www zeigt, sonden auf ein Kundenweb...?

    Gruß, Chris
     
  2. Till

    Till Administrator

    Das wird nichts mit dem ISPConfig update zu tun haben sondern mit dem Debian Update. Schau mal nach, ob das default web von Debian durch das Debian update deaktiviert oder geändert wurde.
     
  3. csiebert

    csiebert Member

    nabend,

    da habe ich schon geschaut, /etc/apache2/sites-enabled/000-default sieht aus wie immer:

    Code:
    <VirtualHost *:80>
            ServerAdmin webmaster@localhost
    
            DocumentRoot /var/www
            <Directory />
                    Options FollowSymLinks
                    AllowOverride None
            </Directory>
            <Directory /var/www/>
                    Options Indexes FollowSymLinks MultiViews
                    AllowOverride None
                    Order allow,deny
                    allow from all
            </Directory>
    
            ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
            <Directory "/usr/lib/cgi-bin">
                    AllowOverride None
                    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                    Order allow,deny
                    Allow from all
            </Directory>
    
            ErrorLog ${APACHE_LOG_DIR}/error.log
    
            # Possible values include: debug, info, notice, warn, error, crit,
            # alert, emerg.
            LogLevel warn
    
            CustomLog ${APACHE_LOG_DIR}/access.log combined
    </VirtualHost>
    effektiv wird aber die domain des servers auf /var/www/clients/client8/web38/web geroutet... irgendwelche ideen?

    gruß, chris
     
  4. Till

    Till Administrator

    In ISPConfig mal auf system > server IP gehen, die namevirtualhost checkbox bei der IP des betroffenen webs entfernen und speichern. Danach namevirtualhost wieder aktivieren und speichern und dann ein paar Minuten warten und erneut das web testen.
     
  5. csiebert

    csiebert Member

    hat leider nichts gebracht. ich habe grade aber in der 000-default mal die zeile
    Code:
    <VirtualHost *:80>
    gegen
    Code:
    <VirtualHost IP-ADRESSE:80>
    ausgetauscht, und siehe da, es funktioniert.

    daraufhin habe ich mal in meine backups von vor dem upgrade geschaut, da war in der alten 000-default auch nur *:80 eingetragen. hier scheint sich also beim apache was geändert zu haben...

    nun ja, falls jemand vor dem gleichen problem steht, hat er nun eine lösungsmöglichkeit =)

    gruß, chris
     
  6. marmai

    marmai New Member

    Danke

    Super hat geklappt, bin schon fast verzweifelt, er hat immer die Domain als Default geladen, welche vom Namen der Konfigdatei im Alphabet als erstes kamm, da er die Configs alphabetisch lädt.
     

Diese Seite empfehlen