Neuen Server hinzugefügt - updated =0

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von mintess, 12. Jan. 2016.

  1. mintess

    mintess Member

    Hi,
    in einem Multiserver Setup hab ich einen weiteren Server hinzugefügt.
    Zur Master DB hatte er bei der Installation Verbindung, und auch manuell komme ich via mysql -h dbmaster -uroot -p drauf.
    Sein server.updated=0, die anderen Server haben server.updated=4365
    Manueller Aufruf der server.sh zeigt (mir) nix besonderes:
    Code:
    /usr/bin/fail2ban-client
    /sbin/iptables
    /sbin/ip6tables
    finished.
    
    /var/log/ispconfig/cron.log ist leer
    /var/log/ispconfig/ispconfig.log ist leer
    /var/log/ispconfig/auth.log ist leer
    Auf dem Server mit der ISPConfig GUI sind ein paar Einträge in der Jobqueue. (Anm: Es wäre echt toll wenn hier mal die Fehler mit dabei stehen würden, wem hilft denn "Update - server" ohne nachzusehen weiter?)

    Müssen die einzelnen Server nur auf den DB Server drauf und ihre ToDos abholen,
    oder muss der DB Server auch andersrum auf den neuen Server drauf, denn die Verbindung wird abgelehnt.
     
  2. Till

    Till Administrator

    Das ist ok, das updated wird gesetzt sobald Du die erste webseite auf dem Server angelegt hast.

    Die verbinden sich mit dem master server, der bei einem multiserver ach immer der server ist auf dem die master db läuft.
     
  3. mintess

    mintess Member

    Lösung steht in diesem Thread:
    Im Multiserver Setup sind die ISPConfig Daten in der Datenbank auf dem Server gespeichert, auf dem die GUI läuft.
    Da die dbispconfig Datenbank auf jedem Server dieses Setups drauf ist, kann man sich schonmal mit dem falschen Server verbinden.
    Das passiert insbesondere wenn man einen Server im ISPConfig als "Datenbankserver" deklariert - der dann eben trotzdem nicht die "Master DB" beinhaltet.

    Siehe auch: https://www.howtoforge.de/forum/threads/ispconfig-multiserver-problem.9647/#post-48237
     

Diese Seite empfehlen