nginx short_open_tag einschalten

Dieses Thema im Forum "Server Administration" wurde erstellt von etron770, 11. Apr. 2012.

  1. etron770

    etron770 Member

  2. Till

    Till Administrator

    Du must php-fpm reloaden und nicht nginx restarten.
     
  3. etron770

    etron770 Member

    nachdem ich auch den ganzen Vserver neu gestarte habe dürfte das nichts ausmachen .. was auch so ist /etc/init.d/php5-fpm reload hilft auch nicht

    Grüße Knut
     
  4. Till

    Till Administrator

    hast Du vielleicht Einträge im ustom php.ini Feld der Webseite gemacht? wenn ja, dann hat die <seite ja ine eigenen php.ini und nicht mehr die globale php.ini, dann musst Du das short open tag auch im custom php.ini Feld einfügen.
     
  5. etron770

    etron770 Member

    Das ist ein neu aufgesetzter Server mit einere in ISPCOnfig eingetragenen Seite. Ich habe es überall versucht wo ich irgendetwas gefunden habe, einschließlich über custom Einstellung der Setie in ISP config.

    Wurde dadurch ein ini file angelegt? Wenn ja wo ist das zu finden, oder ist das dann in der Datenbank.

    Grüße Knut
     
  6. Till

    Till Administrator

    Ja.

    das editierst Du durch hinzufügen eines Eintrages im php.ini Feld. Würdest Du versuchen es manuell u ändern so würden die Änderungen wieder entfernt werden, also einfach nur short open tag im php.ini Feld setzen und warten bis dieÄnderungen geschrieben wurden, was Du ja im Monitor siehst.
     
  7. etron770

    etron770 Member

    Sorry ich blicke nicht durch ...

    meinst du in den Options des Webspace in ISPconfig ? wenn ja wo sehe ich das dann?


    ich finde auf dem System nur 3 php.ini Dateien

    ./etc/php5/apache2/php.ini
    ./etc/php5/cli/php.ini
    ./etc/php5/fpm/php.ini

    und in allen steht

    short_open_tag = On

    Grüße Knut
     
  8. Till

    Till Administrator

    Ja.

    Es gibt nur eine Reiterkarte "Optionen" in den Webseiten Einstellungen und dort findest Du das Feld "Custom php.ini settings".

    Um die Dateien geht es nicht, wie oben erläutert.
     
  9. etron770

    etron770 Member

    in den Custom php.ini settings steht short_open_tag = On

    In der Jobque ist auch ein Job " .. Update web_domain", der ist irgendwann "nach langer Zeit" verschwunden. und die Einträge stehen in der Datenbank.


    Ansonsten tut sich nichts, ist es die gleiche syntax wie in den php.ini files?

    Bei Aufruf von phpinfo(); müsste doch das ini file auch zu finden sein ?
    bzw wo müsste ich dann ein ini file finden.

    Grüße Knut
     
  10. Till

    Till Administrator

    Ja.

    /var/www/conf/.....
     
  11. etron770

    etron770 Member

    ja das habe ich auch gerade gefunden
    nur dass dort:
    short_open_tag = off
    error_reporting = E_ALL
    display_errors = off
    drin steht, in der Datenbank (und in IspConig Options) aber

    short_open_tag = On
    error_reporting = E_ALL
    display_errors = On
     
  12. Till

    Till Administrator

    Und Du bist sicher dass Du die richtige Datei hast? Schau mal in phpinfo nach, dort findest Du den Pfad zur php.ini Datei.
     
  13. etron770

    etron770 Member

    Irgendwie hat es das ändern des letzten Beitrages nicht übernommen

    /var/www/conf/. gibt es nicht

    die datei ist

    /etc/php5/fpm/pool.d/web1.conf

    Dort sind auch die Zeilen die ich iengetragen hatte.
    und wenn ich dort manuell das ganze auf on setze funktioniert das System

    So nun bliebt nur noch die Frage ob die Syntax im config bereich von ISPconfig

    display_errors = On

    nicht annimmt eventuell muss man dort
    display_errors = 1 schreiben
    ich probiere es mal

    p.s wo kann ich angeben dass die Jobwarteschlange jede Minute abgearbeitet wird (crontab?)
     
  14. Till

    Till Administrator

    Die Warteschlange wird jede Minute abgearbeitet. Das kannst Du auch sehen wenn Du:

    crontab -l

    eingibst, der server.sh Job ist ein minuten cronjob.
     
  15. etron770

    etron770 Member

    Den hatte ich schon gefunden
    dann muss ich mal suchen warum das so lange dauert
     
  16. Till

    Till Administrator

    Man kann sich da leicht mal irren, wenn man drauf wartet das eine Minute rum geht :) Du kannst ja mal den Loglevel auf debug setzen und es Dir dann im ispconfig syslog mal ansehen wann der cronjob läuft.
     
  17. etron770

    etron770 Member

    So nun ... also derzeit dauert es mehr als 45 Minuten :)

    aber im ispconfig.log findet sich :
    Code:
     
     12.04.2012-17:53 - DEBUG - Writing the PHP-FPM config file: /etc/php5/fpm/pool.d/web1.conf
     12.04.2012-17:53 - DEBUG - nginx status is: 1
     12.04.2012-17:53 - DEBUG - Calling function 'restartHttpd' from module 'web_module'.
     12.04.2012-17:53 - DEBUG - nginx online status after restart is: 1
     12.04.2012-17:53 - DEBUG - Processed datalog_id 51
     12.04.2012-17:53 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
     12.04.2012-17:54 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
     12.04.2012-17:54 - DEBUG - No Updated records found, starting only the core.
     12.04.2012-17:54 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
     12.04.2012-17:55 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
     12.04.2012-17:55 - DEBUG - Found 2 changes, starting update process.
     12.04.2012-17:56 - DEBUG - There is already an instance of server.php running. Exiting.
     12.04.2012-17:57 - DEBUG - There is already an instance of server.php running. Exiting.
     12.04.2012-17:58 - DEBUG - There is already an instance of server.php running. Exiting.
     ......
     12.04.2012-18:36 - DEBUG - There is already an instance of server.php running. Exiting.
     12.04.2012-18:37 - DEBUG - There is already an instance of server.php running. Exiting.
     
     
    wenn ich den Lock lösche
    rm -f /usr/local/ispconfig/server/temp/.ispconfig_lock

    dann wird alles weiter abgearbeitet

    allerdings (ich weiss nicht ob das richtig ist) werden wieder alle einträge von domains usw in die vhost datei

    wie z.B add server alias geschrieben und diverse - chown chmod usw
     
    Zuletzt bearbeitet: 12. Apr. 2012
  18. Till

    Till Administrator

    Der PHP Prozess scheint auf Deinem System instabil zu sein. Falls es ein vserver ist dann check mal ob er genug arbeitsspeicher hat und auch sonst keine limits der vm erreicht werden.

    Wenn Du irgend was an einer Webseite geändert hast, dann ist das richtig.
     
  19. etron770

    etron770 Member

    Danke für die Hilfe, der Speicher war am Ende, aber ich habe ihn ohnehin ohnehin nochmals ohn ngix aufgesetzt.
    Da kenne ich mich besser aus und das Ding muss baldigst laufen...

    tuts auch :)

    Grüße Knut
     

Diese Seite empfehlen