Nigx und apache gemischt.

#1
Nabend,

kann mir jemand sagen ob ich im multiserver betrieb eine webserver mit apache und einen mit nginx betreiben kann oder führt das zu problemen?
 
Zuletzt bearbeitet:

Till

Administrator
#2
Das ist kein Problem, solange Du nicht mirroring zwischen diesen beiden Nodes verwendest und dabei von einem nginx auf apache spiegelst oder umgekehrt.
 
#4
Install hat alles geklappt.
Aber der nginx will auf biegen und brechen keine php ausführen.

php läuft aber.

Direkte seiten mit endung .php werden sofort zum download angeboten und html seiten wo eine php drin ist werden einfach nicht interpretiert.

in den logs ist kein fehler dazu verzeichnet.

Jemand ein tip?
 

Till

Administrator
#5
Nach welchem tutorial hast du denn installiert? Das php und nginx von debian 6 ist zb. Zu alt, daher müssen dann die pakete von dotdeb genommen werden.
 
#9
Mist genau über die Zeile hatte ick drüber gelesen und nur die drunter gecheckt ob auch alles drin ist.

Setting up nginx (1.0.15-1~dotdeb.0)
hab ich nun installiert aber änderung bringt es noch nicht.

Muss ick die php pakete auch ausstauschen?
 
#11
so alles ausgetauscht.
es wurden auch alles bis auf fcgiwrap aus den dotdeb quellen installiert. Es tut sich aber nix.

Gibt es noch einen Ansatz?
 

Till

Administrator
#12
Fcgiwrap muss glaube ich auch aus dotdeb sein, falls es das von denen gibt. Danach musst du vermutlich ispconfig nochmal aktualisieren und die dienste rekonfigurieren lassen.
 
#13
scheint es nicht zu geben er hat automatisch die squeeze quellen genutzt.

Bei aktualisieren von ispconfig gibt es das ein trick das update sagt mit das es nichts neues gibt und wenn ich es neu runterlade geht die install nicht weil er die vorhandene install erkennt und beim update sagt er auch das nix neues gibt.

Kann ich irgendwo die versionsnr zurück setzen für das update?
 

Till

Administrator
#14
scheint es nicht zu geben er hat automatisch die squeeze quellen genutzt.

Bei aktualisieren von ispconfig gibt es das ein trick das update sagt mit das es nichts neues gibt und wenn ich es neu runterlade geht die install nicht weil er die vorhandene install erkennt und beim update sagt er auch das nix neues gibt.

Kann ich irgendwo die versionsnr zurück setzen für das update?
Das steht jeweils in den release notes der Version, schau mal ganz unten unter "manual update instructions":

http://www.howtoforge.de/forum/allg...tsupdate-fuer-ispconfig-veroeffentlicht-5591/
 
#15
ok alles gemacht und bis auf die wraper alles von dotdeb installiert. manueles update gemacht. Es bleibt aber der dabei der nginx liefert keine php seiten aus.

ich konnte auch nur eine domain anlegen auf den dem server bei der 2. domain wird nur eine err vhost datei erzeugt.
 

falko

Administrator
#17
Wie ist denn der Output von
Code:
netstat -tap
? Läuft PHP-FPM?

Gibt es Fehler im nginx-Error-Log (in /var/log/nginx/) oder unter /var/log/web<id>/log/? Wie sieht denn die err vhost-Datei aus?
 
#18
nignx error log ist leer.

aus dem log des Webs
188.40.xxx.xxx - beta [23/Apr/2012:12:52:14 +0200] "GET / HTTP/1.1" 200 347 "-" "Mozilla/5.0 (X11; Linux i686 on x86_64; rv:11.0) Gecko/20100101 Firefox/11.0"
188.40.xxx.xxx - beta [23/Apr/2012:12:52:14 +0200] "GET /index.php HTTP/1.1" 200 1193 "http://test.xxx.com/" "Mozilla/5.0 (X11; Linux i686 on x86_64; rv:11.0) Gecko/20100101 Firefox/11.0"
aus dem error log
2012/04/23 09:54:01 [error] 13370#0: *175 no user/password was provided for basic authentication, client: 188.40.xxx.xx, server: test.fluxandvision.com, request: "GET / HTTP/1.1", host: "test.xxx.com"
und die vhost
server {
listen 188.40.xxx.xxx:80;


server_name test.xxx.com www.test.xxx.com;

root /var/www/test.xxx.com/web;



index index.html index.htm index.php index.cgi index.pl index.xhtml;



error_log /var/log/ispconfig/httpd/test.xxx.com/error.log;
access_log /var/log/ispconfig/httpd/test.xxx.com/access.log combined;

## Disable .htaccess and other hidden files
location ~ /\. {
deny all;
access_log off;
log_not_found off;
}

location = /favicon.ico {
log_not_found off;
access_log off;
}

location = /robots.txt {
allow all;
log_not_found off;
access_log off;
}

location /stats {
index index.html index.php;
auth_basic "Members Only";
auth_basic_user_file /var/www/clients/client1/web44/.htpasswd_stats;
}

location ^~ /awstats-icon {
alias /usr/share/awstats/icon;
}

location ~ \.php$ {
try_files $uri =404;
include /etc/nginx/fastcgi_params;
fastcgi_pass 127.0.0.1:9053;
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
fastcgi_param PATH_INFO $fastcgi_script_name;
fastcgi_intercept_errors on;
}




location ^~ / {
auth_basic "Members Only";
auth_basic_user_file /var/www/clients/client1/web44/web/.htpasswd;
}

}
noch das netstat vergessen
hier die relevanten sachen
tcp 0 0 localhost:9053 *:* LISTEN 1285/php-fpm: pool
tcp 0 0 localhost:9054 *:* LISTEN 1241/php-fpm: pool
 
Zuletzt bearbeitet:

falko

Administrator
#20
Das Problem scheint zu sein, daß er nach einem Passwort fragt. Kommentier doch mal

Code:
auth_basic "Members Only";
                auth_basic_user_file /var/www/clients/client1/web44/web/.htpasswd;
aus und reloade nginx.
 

Werbung

Top