Opensuse11 und Ruby

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von HolgerEx, 17. Nov. 2008.

  1. HolgerEx

    HolgerEx New Member

    Moin Forum,

    ich beabsichtige, auf einen Webserver von Hetzner umzusteigen. Derzeit bin ich bei Server4you. Ich will darauf ein OpenSuSE 11 mit ispconfig fahren.
    Nun teste ich die Installation in einer VBox. Hierbei gehe ich nach howto (The Perfect Server von Til Brehm) vor.

    Der Befehl:
    ./configure.rb --with-apr-includes=/usr/include/apr-1
    gibt folgenden Fehler aus:
    /usr/bin/env: ruby: No such file or directory
    Die Datei ist aber vorhanden. Sie ist ausführbar und hat 100755 als Berechtigung gesetzt.

    Wer kann helfen und wie wichtig ist Ruby für die Installation? Was mache ich falsch? Bis dahin lief die Installation fehlerfrei.

    Danke im Voraus und liebe Grüße ins Forum

    Holger
     
  2. Till

    Till Administrator

    Die ruby Pakete hast Du installiert?

    Ein Kleiner Hinweis, Hetzner bietet auch gute Debian images an, würde ich Dir auf jeden Fall empfehlen. OpenSuSe macht in Hosting Umgebungen häufiger mal Ärger.
     
  3. HolgerEx

    HolgerEx New Member

    Moin Till,

    Ne, hatte ich natürlich nicht:(. OK, jetzt läuft natürlich alles, danke für den Hinweis.

    Mein Partner und ich arbeiten seit der Version 6.x mit SuSE und wir hatten bislang keine Probs. Wir sind es halt gewohnt und alte Gewohnheiten legt man ungern ab. Im Job verwende ich allerdings Debian.

    Lieben Gruß
    Holger
     

Diese Seite empfehlen