ownCloud Grundinstallation

Dieses Thema im Forum "Allgemein" wurde erstellt von Benedict, 9. Sep. 2013.

  1. Benedict

    Benedict Member

    Ok,
    vielleicht weiss jemand Rat?!
    Ich habe mich grundlegend mit der Installation von owncloud beschäftigt. Dabei habe ich zunächst auf einem Testserver ohne ISPConfig in einer Kombination aus debian wheezy, nginx, mysql und eben owncloud begonnen. Die verschiedenen Dokumentationen haben zum Erfolg geführt, aber webdav will nicht recht ?!
    Dann habe ich alles "wiederholt" mit ISPConfig 3, Debian 7, apache (anderer Server). Ich dachte es geht out of the box, aber nein: Nach dem ersten Login-Versuch (mit Datenbankangaben etc) setzt es aus. Also meine Frage ist, welche grundlegenden Einstellungen sind hier zunächst zu setzten, ohne Berüchsichtung irgendewlcher Limits, die man auch später noch anpassen kann?

    Bereits eingestellt ist:

    PHP: Fast-CGI

    Custom php.ini settings:

    memory_limit = 512M
    post_max_size = 512M
    upload_max_filesize = 512M

    Danke für jeden Hinweis!
     
  2. nowayback

    nowayback Well-Known Member

    in verbindung mit apache2 hast du eigentlich nichts weiter zutun und es sollte auch so ohne probleme funktionieren. Webdav könnte bei dir jedoch damit zutun haben dass das basic auth level 2 nicht eingestellt ist

    Code:
    Klicke auf Start –> regedit in dem Feld Suche starten oder Ausführen eingeben
    
    im Registry-Editor:
    
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters -> klick doppelt auf den Eintrag “BasicAuthLevel” und ändere den Wert auf “2″ und bestätige mit “OK”.
    
    Wenn nicht vorhanden dann erstellen
    
    grüße
    nwb
     
  3. Benedict

    Benedict Member

    Besten Dank! Aber noch ohne Erfolg.
    Ich möchte mal aufdröseln, was ich gemacht haben bzw. was vorliegt:

    1. Debian Wheezy, Apache, MySQL ... nach "Perfect Server..." eben
    2. Dann Subdomain als Website angelgt (ISPConfig)
    2.1 Optionen: CGI, SSI, SuEXEC, SSL, Fast-CGI
    3. Download "owncloud", entpackt, Anpassen der Rechte unter /var/www/domain/web/owncloud
    4. MySQL Datenbank (ISPConfig)
    5. Aufruf im Browser
    5.1 Nach Eingabe der initialen Daten (Benutzer, Datenbank usw. Also das geht nocht!!) und Bestätigung bleibt die Verarbeitung stehen. Auch wird die Datenbank nicht beschrieben?

    Erkennst Du da einen Fehler? Was übersehen?
     
  4. nowayback

    nowayback Well-Known Member

    hi,

    evtl sagen die error logs etwas.

    einloggen im web funktioniert?
    wenn nicht, dann aus der anleitung:
    Code:
    apt-get install php5 php5-gd php-xml-parser php5-intl
    apt-get install php5-sqlite php5-mysql smbclient curl libcurl3 php5-curl
    a2enmod rewrite
    /etc/init.d/apache2 restart
    
     
  5. Till

    Till Administrator

    Schau mal ins error.log der Webseite.
     
  6. Benedict

    Benedict Member

    Ja, ich dachte mir schon, dass ihr mir die logs um die Ohren haut. Aber einen Vergleich mit den libs sagt mir, dass da noch was fehlen muss, wie nwb bemerkt
    ok, ich gebe dann bescheid!
    Danke :)
     
  7. Benedict

    Benedict Member

    Also,
    es gibt da die Warnung, dass xcache.admin.user oder xcache.admin.pass nicht konfiguriert sind mit Verweis auf die korrekte php.ini ? Welche Zusammenhänge gibts da?
     
  8. nowayback

    nowayback Well-Known Member

    in der datei: /etc/php5/apache2/conf.d/20-xcache.ini
    die zeile: xcache.admin.enable_auth = off
    setzen oder
    xcache.admin.user = deinwunschusername
    xcache.admin.pass = deinwunschpasswort
    eintragen in der selben datei
     
  9. Benedict

    Benedict Member

    Das war's!
    Mh, ich nehm es erstmal so hin, verstanden habe ich es nicht. Nicht die Bedeutung von Xcache, aber warum das jetzt gesperrt hat?

    Dank Euch!
     
  10. Benedict

    Benedict Member

    Im onwCloud Administrators Manual kann man unter "Manual Installation" nachlesen:

    "You don’t need any WebDAV support of your webserver (i.e. apache’s mod_webdav) to access your ownCloud data via WebDAV, ownCloud has a WebDAV server built in. In fact, you should make sure that any built-in WebDAV module of your webserver is disabled (at least for the ownCloud directory), as it can interfere with ownCloud’s built-in WebDAV support"

    Nach dem oben gelösten xcache-Problem bekam ich nämlich eine Meldung, dass der Webserver noch nicht für die Datei-Synchronisation bereit ist mit dem Hinweis, die WebDAV-Schnittstelle sei vermutlich defekt.

    Till oder nwb könntet ihr bitte sagen ob dies mit den Zeilen im "Perfekt Server Setup", also bzgl. WebDAV mit "a2enmod dav_fs dav auth_digest" kollidiert oder stört? Wenn ja, wie umgeht man dies für ein Verzeichnis? Oder stellt dies eine grundlegende Entscheidung dar, sprich entweder oder?
     
  11. nowayback

    nowayback Well-Known Member

    hi,

    kannst du denn die Seite, die dir im Adminmenü angezeigt wird für Webdav im Browser aufrufen? (http://www.deinedomain.de/owncloud/remote.php/webdav/ oder sowas in der Art)

    Wenn nicht hast du warscheinlich beim Perfect Server Tutorial die Apache2 WebDav Unterstützungen mit aktiviert. Das stellt im Allgemeinen jedoch kein Problem da. Einfach im entsprechenden vhost (/etc/apache2/sites-enabled/100-deinedomain.vhost) folgenden Block mit einfügen

    Code:
    <Location /var/www/deinedomain.de/web/owncloud>
    Dav Off
    </Location>
    danach auch gleich noch checken ob mod_setenvif und mod_headers aktiv sind
    Code:
    a2enmod mod_setenvif
    a2enmod mod_headers
    Grüße
    nwb
     
  12. Benedict

    Benedict Member

    So, hallo!
    Also ob der Block jetzt da ist oder nicht: ein Aufruf im Browser klappt. Die von mir beschriebene Meldung taucht auch nur beim ersten Login auf. Nach einem Seitenwechsel wird das Adminpanel daraufhin normal angezeigt; Uploads gehn usw. Aber danke dafür, denn nach sowas hab ich ja gefragt und mod_headers war nicht aktiv.
    Jetzt teste ich einen Client (Windows) der auch nich will...
     

Diese Seite empfehlen