Passwortprobleme nach Clonen von ISPConfig

#1
Hi!

Ich habe ein ISP System (auf VM, OpenSUSE 11.2) geclont und habe ein paar Probleme.
Nach dem Clonen habe ich folgende Änderungen durchgeführt:
1. Hostname geändert (yast2)
2. root Passwort geändert (sys user root)
3. mysql root Passwort geändert
4. ipsconfig admin passwort geändert.

Soweit so gut, geht alles, kann mich in mysql als root einloggen, auch in ispconfig als admin(per Webinterface/8080).
Allerdings egal welche Datenbanken oder FTP User ich im ispconfig Admininterface anlege, ich kann mich nicht als diese per phpmyadmin bzw. FTP einloggen.
Der pureftp loggt sich in mysql ein (also DB Zugriff geht), allerdings sagt er, dass die authentication fehlschlägt (530). PhpMyadmin beschwert sich auch, dass das Passwort falsch ist, obwohl es in der Datenbank nach dem Anlegen in ispconfig vorhanden ist.

Werden da die Passworte evtl. mit einem falschen Schlüssel verschlüsselt?

Vielen Dank!
 
#2
Immer noch keine Lösung. Ich habe mal den pureftp log auf verbose gestellt, sieht perfekt aus:

Nov 12 11:36:44 sh-1 pure-ftpd: (?@xxx.xxx.xxx) [INFO] New connection from xxx.xxx.xxx
Nov 12 11:36:45 sh-1 pure-ftpd: (?@xxx.xxx.xxx) [DEBUG] Command [user] [user]
Nov 12 11:36:45 sh-1 pure-ftpd: (?@xxx.xxx.xxx) [DEBUG] Command [pass] [<*>]
Nov 12 11:36:50 sh-1 pure-ftpd: (?@xxx.xxx.xxx) [WARNING] Authentication failed for user [user]
Nov 12 11:36:50 sh-1 pure-ftpd: (?@xxx.xxx.xxx) [INFO] Logout.

Das einzige was er nicht frisst ist das Passwort. Ich hab dann mal das Passwort in der MYSQL Datenbank händisch geändert (update ftp_user set password=md5("password") where username="user";)

Dann hab ich die Cryption Method im pureftp auf md5 gesetzt und neu gestartet. Einloggen (Authentication) geht immer noch nicht, gleiches Ergebnis...
 
#3
Ich habe jetzt mal das verschlüsselte Passwort aus der MYSQL Datenbank genommen, in der pure-ftpd Config die Cryption Method auf cleartext gestellt und mich mit dem verschlüsselten Schlauch eingeloggt - geht 1A.

Also ich denke, das Problem liegt definitiv an einer Inkonsistenz in der Verschlüsselung. ISPConfig scheint anders zu verschlüsseln als der pure-ftpd, bzw. einen anderen Schlüssel herzunehmen.

Ich weiß allerdings nicht, wo ich da hingreifen muss...
 
#4
Irgendjemand ne Idee wegen der FTP Passwortverschlüsselung?

Hab mir inzwischen das Problem mit den Datenbanken näher angeschaut. Problem ist, dass ispconfig schlichtweg die Datenbanken nicht anlegt und auch den mysql user nicht. Der Eintrag in die Tabelle dbispconfig.web_database wird vorgenommen, daher sieht es vornerum ok aus.

Ich schätze, dass es u.U. an dem geänderten mysql root Passwort liegt, welches ich auch irgendwie ispconfog mitteilen müsste...
Aber wie???
 

Till

Administrator
#5
Irgendjemand ne Idee wegen der FTP Passwortverschlüsselung?
Alle Passworte sind nach dem Linux Standard crypt mit erweitertem salt verschlüsselt.

Also ich denke, das Problem liegt definitiv an einer Inkonsistenz in der Verschlüsselung. ISPConfig scheint anders zu verschlüsseln als der pure-ftpd, bzw. einen anderen Schlüssel herzunehmen.
das ist garantiert nicht der fall, es handelt sich wie gesagt um einen Standard und da es auf tausenden Servern geht, sollte es bei Dir auch gehen. Da wird also noch ein anderes Problem vorliegen oder die Datenbank wurde beim klonen beschädigt.

Ich schätze, dass es u.U. an dem geänderten mysql root Passwort liegt, welches ich auch irgendwie ispconfog mitteilen müsste...
Aber wie???
/usr/local/ispconfig/server/lib/mysql_clientdb.conf
 

Werbung

Top