Performance verbessern

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Patric, 12. Apr. 2012.

  1. Patric

    Patric New Member

    Ich betreibe Debian 6 nach dem Perfect Setup.

    Was kann man dort eventuell noch an der Performance verbessern?

    Also rein Bezogen auf MySQL und den Apache mit FastCGI. Also auf alle Webdomains!
     
    Zuletzt bearbeitet: 12. Apr. 2012
  2. Till

    Till Administrator

  3. Patric

    Patric New Member

    Macht es Sinn einen PHP Cache zu installieren wenn die Software (also die Webanwendung) selber schon Chached?
     
  4. Till

    Till Administrator

    Ja, macht Sinn. Denn durch den php cache entfällt das parsen der PHP Dateien wodurch die Ausführungsgeschwindigkeit steigt.
     
  5. Patric

    Patric New Member

    Sofern ich die Zeilen
    Code:
    tmp_table_sizee        = 64M
     max_heap_table_sizee        = 32M
    aus deiner Anleitung hinzufüge Startet der MySQL Server nicht mehr!
     
  6. Till

    Till Administrator

    Lies die Anleitung bitte nochmal durch, sie sagt dass Du ein Programm runter lädst und dann einen Befehl ausführst der Dir dann Empfehlungen für Deine individuelle mysql Konfiguration ausgibt. Die Anleitungen enthält keine Zeilen Die Du bei Dir einfügen sollst, es handelt sich dabei um ein Beispiel wie Du den mysqltuner.pl Befehl verwendest.
     
  7. Patric

    Patric New Member

    Code:
     >>  MySQLTuner 1.2.0 - Major Hayden <major@mhtx.net>
     >>  Bug reports, feature requests, and downloads at http://mysqltuner.com/
     >>  Run with '--help' for additional options and output filtering
    Please enter your MySQL administrative login: root
    Please enter your MySQL administrative password:
    
    -------- General Statistics --------------------------------------------------
    [--] Skipped version check for MySQLTuner script
    [OK] Currently running supported MySQL version 5.1.61-0+squeeze1
    [OK] Operating on 64-bit architecture
    
    -------- Storage Engine Statistics -------------------------------------------
    [--] Status: +Archive -BDB -Federated +InnoDB -ISAM -NDBCluster
    [--] Data in MyISAM tables: 1G (Tables: 1075)
    [--] Data in InnoDB tables: 48K (Tables: 3)
    [--] Data in MEMORY tables: 252K (Tables: 18)
    [!!] Total fragmented tables: 149
    
    -------- Security Recommendations  -------------------------------------------
    [OK] All database users have passwords assigned
    
    -------- Performance Metrics -------------------------------------------------
    [--] Up for: 1m 39s (8K q [81.111 qps], 1K conn, TX: 13M, RX: 7M)
    [--] Reads / Writes: 84% / 16%
    [--] Total buffers: 1.2G global + 2.7M per thread (151 max threads)
    [OK] Maximum possible memory usage: 1.5G (4% of installed RAM)
    [OK] Slow queries: 0% (0/8K)
    [OK] Highest usage of available connections: 3% (5/151)
    [OK] Key buffer size / total MyISAM indexes: 1.0G/577.0M
    [OK] Key buffer hit rate: 99.2% (148K cached / 1K reads)
    [OK] Query cache efficiency: 36.6% (2K cached / 5K selects)
    [OK] Query cache prunes per day: 0
    [OK] Sorts requiring temporary tables: 0% (0 temp sorts / 525 sorts)
    [!!] Temporary tables created on disk: 28% (229 on disk / 814 total)
    [OK] Thread cache hit rate: 99% (5 created / 1K connections)
    [OK] Table cache hit rate: 25% (1K open / 4K opened)
    [OK] Open file limit used: 10% (2K/20K)
    [OK] Table locks acquired immediately: 100% (4K immediate / 4K locks)
    [OK] InnoDB data size / buffer pool: 48.0K/8.0M
    
    -------- Recommendations -----------------------------------------------------
    General recommendations:
        Run OPTIMIZE TABLE to defragment tables for better performance
        MySQL started within last 24 hours - recommendations may be inaccurate
        Enable the slow query log to troubleshoot bad queries
        When making adjustments, make tmp_table_size/max_heap_table_size equal
        Reduce your SELECT DISTINCT queries without LIMIT clauses
    Variables to adjust:
        tmp_table_size (> 16M)
        max_heap_table_size (> 16M)
    
    Das bekomme ich ausgegeben.
    Nur wo passe ich
    HTML:
        tmp_table_size (> 16M)
        max_heap_table_size (> 16M)
    
    an. In der my.cnf gibt es diese einträge nicht
     
  8. Till

    Till Administrator

    Du fügst sie im [mysqld] Bereich der Konfigurationsdatei hinzu, wie im Tutorial beschrieben "....and increase or set the variables in the [mysqld] section of the file. Mine looks now like this....".
     

Diese Seite empfehlen