PHP läuft nicht...

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von s-8, 26. Apr. 2008.

  1. s-8

    s-8 New Member

    Hallo zusammen,
    ich habe nach der erfolgreichen Installation des ISPConfig festgestellt, dass PHP Dateien nicht zu funktionieren scheinen. Immer wenn ich eine PHP Datei öffnen will, wird mir der Download dieser angeboten.

    In den Logfiles kann ich keinen Fehler finden, der Apache ist mit PHP als Modul gestartet und PHP für die Webs natürlich aktiviert.

    Die Datei "Vhosts_ispconfig.conf":
    Code:
    ######################################
    # Vhost: www.your-domain.de:80
    ######################################
    #
    #
    <VirtualHost XX.XX.XX.XXX:80>
    ServerName www.your-domain.de
    ServerAdmin webmaster@your-domain.de
    DocumentRoot /srv/www/web11/web
    ServerAlias your-domain.de
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3
    ErrorLog /srv/www/web11/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    php_admin_flag safe_mode On
    php_admin_value open_basedir /srv/www/web11/
    php_admin_value file_uploads 1
    php_admin_value upload_tmp_dir /srv/www/web11/phptmp/
    php_admin_value session.save_path /srv/www/web11/phptmp/
    Alias /error/ "/srv/www/web11/web/error/"
    AliasMatch ^/~([^/]+)(/(.*))? /srv/www/web11/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /srv/www/web11/user/$1/web/$3
    </VirtualHost>
    
    Wo könnte ich noch ansetzen?
    Ich suche schon seit Stunden den Fehler... :-(

    Wenn ich PHP global aktiviere (also die ISP Deaktivierungen entferne), klappt alles.
    Also vermute ich mal dass es an den Einstellungen liegen wird ?!?
     
    Zuletzt bearbeitet: 26. Apr. 2008
  2. Till

    Till Administrator

    Welche Linuxdistribution verwendest Du?
     
  3. s-8

    s-8 New Member

    Meine aktuelle Linux Distribution ist SuSE 10.2
     
  4. Till

    Till Administrator

Diese Seite empfehlen