PHP5 mit Zend OPcache And APCu

#1

Till

Administrator
#2
Da muss irgend ein Fehler im make output vermerkt sein, habe das Tutorial auch schon verwendet, es sollte generell so funktionieren.
 
#3
make test sagt mir folgendes:

=====================================================================
FAILED TEST SUMMARY
---------------------------------------------------------------------
file_get_contents() test using offset parameter out of range [ext/standard/tests/file/file_get_contents_error001.phpt]
Test setlocale() function : usage variations - Setting all available locales in the platform [ext/standard/tests/strings/setlocale_variation2.phpt]
=====================================================================
 
#4
Habe es jetzt mehrmals versuch, allerdings immer das gleiche.
Hier habe ich einmal einen etwas längeren Output, sagt der dir was ?
Code:
.....
Build complete.
Don't forget to run 'make test'.

root@h01 /usr/local/src/php5-build/php-5.5.7 # make install
Installing shared extensions:     /usr/local/lib/php/extensions/no-debug-non-zts-20121212/
Installing PHP CLI binary:        /usr/local/bin/
Installing PHP CLI man page:      /usr/local/php/man/man1/
Installing PHP CGI binary:        /usr/local/bin/
Installing PHP CGI man page:      /usr/local/php/man/man1/
Installing build environment:     /usr/local/lib/php/build/
Installing header files:          /usr/local/include/php/
Installing helper programs:       /usr/local/bin/
  program: phpize
  program: php-config
Installing man pages:             /usr/local/php/man/man1/
  page: phpize.1
  page: php-config.1
Installing PEAR environment:      /usr/local/lib/php/
[PEAR] Archive_Tar    - already installed: 1.3.11
[PEAR] Console_Getopt - already installed: 1.3.1
[PEAR] PEAR           - already installed: 1.9.4
Wrote PEAR system config file at: /usr/local/etc/pear.conf
You may want to add: /usr/local/lib/php to your php.ini include_path
[PEAR] Structures_Graph- already installed: 1.0.4
[PEAR] XML_Util       - already installed: 1.2.1
/usr/local/src/php5-build/php-5.5.7/build/shtool install -c ext/phar/phar.phar /usr/local/bin
ln -s -f /usr/local/bin/phar.phar /usr/local/bin/phar
Installing PDO headers:          /usr/local/include/php/ext/pdo/
root@h01 /usr/local/src/php5-build/php-5.5.7 # cp /usr/local/src/php5-build/php-5.5.7/php.ini-production /opt/php-5.5.7/lib/php.ini
cp: cannot create regular file `/opt/php-5.5.7/lib/php.ini': No such file or directory
 

Till

Administrator
#5
Ich denke da stimmt schon was beim configure nicht. Make install kopiert nach /usr/local bei dir, er sollte aber nach /opt/.... Kopieren. Als ob der prefix nicht gesetzt ist.
 
#8
wenn ich es für php 5.5.10 machen will ersetze ich ja eigentlich nur die 7 oder?
weil er sucht dann trotzdem den ordner 5.5.7 um logs zu schreiben??
oder habe ich da einen denkfehler?
 

Werbung

Top