phpmyadmin wird nicht gefunden?

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von AndréS, 1. Juli 2009.

  1. AndréS

    AndréS New Member

    Hallo Till,

    ich habe da mal ein Problem. Ich habe mir auf einen neuen Server ISPConfig 3 installiert. Nun habe ich alles mögliche auch mit installiert, streng nach dem perfekten Setup und auch Ruby. Habe Debian.

    Nun wenn ich auf ein Link klicke http://188.40.58.142:8080/sites/database_phpmyadmin.php?id=1 , dann bekomme ich nur die Meldung, das gibt es nicht.
    Zumal dieser Link aus dem obrigen raus resultiert: http://www.debian-50-lenny-64-minimal.com/phpmyadmin

    Ich vermute mal ich habe irgendwas nicht richtig gemacht bzw. nicht eingestellt. Was kann das sein?

    Vielen lieben Dank schonmal

    AndréS
     
  2. planet_fox

    planet_fox Super-Moderator

    schau mal hier ob du das so beachtest hast bei phpmyadmin

    http://www.howtoforge.de/howto/der-perfekte-server-debian-lenny-debian-50-ispconfig-3/5/

    Du musst den teil auskommentieren
     
  3. AndréS

    AndréS New Member

    Jepp habe ich gemacht. War schon die ganze Zeit :(

    Vielen Dank trotzdem schonmal

    André
     
  4. AndréS

    AndréS New Member

    Ich habe nun auch mal den Host umgestellt auf meine IP adresse direkt. Leider hatte das kein Wirkung :(

    Was kann ich denn nun machen?

    Vielen Dank

    AndréS
     
  5. Till

    Till Administrator

    Lege eine Website wie phpmyadmin.deinedomain.de an und installier eine Kopie von phpmydmin in diese website.
     
  6. AndréS

    AndréS New Member

    HI,

    soll ich eine neue Webseite anlegen oder reicht eine Subdomain?
    Wie soll ich die Kopie installieren? Reicht es wenn ich einfach einen Ordner phpmyadmin rüber kopiere. Sorry, bin da nicht ganz so bewandert.

    Vielen Dank

    AndréS
     
  7. Till

    Till Administrator

    Du sollste eine neue Webseite anlegen. Dafür würde ich dann aber eine subdomain benutzen.
     
  8. AndréS

    AndréS New Member

    Hi Till,

    kann es sein, das ich nicht dahin geleitet werde, weil ich die Domain noch nicht auf die IP eingestellt habe?
    Das zum einen, denn ich habe auf den Server noch keine IP stehen.

    Ich wollte gerne zum phpmyadmin wie bei ISPConfig 2 wo ich mich als root anmelden kann. Denn dann kann ich meine Webseiten schon mal transferieren.

    Vielen Dank

    AndréS
     
  9. AndréS

    AndréS New Member

    Noch was, habe mal auf gut dünken diese Url eingetippt: 188.40.58.142:3306/phpmyadmin/index.php und da will er mir die index.php zum download anbieten. Ich glaube so sollte das nicht sein oder? Habe ich was bei der installation verkehrt gemacht? Weil wenn ja, dann installiere ich das alles nochmal neu.

    AndréS
     
  10. Burge

    Burge Member

    Das ist der Remote port der sql Datenbank was denkst du soll er dir da anzeigen? Auf diesen Port kann gar keine Apache lauschen.
     
  11. AndréS

    AndréS New Member

    Aha :(
    Sorry, dachte nur das ich irgendwie ja an die phpmyadmin kommen muss. Daher bin ich auf diesen port gegangen.

    Tja, dann warte ich erstmal auf Anweisung von Till oder hast du noch welche?

    Vielen Dank

    AndréS
     
  12. Burge

    Burge Member

    Zuletzt bearbeitet: 4. Juli 2009
  13. AndréS

    AndréS New Member

    Hi,

    bei den oberen beiden komme ich auf meine Login Seite vom ISPConfig. Da komme ich mit den MySQL Logn daten aber nicht weiter kann mich nur als admin oder aber auch als user anmelden.
    bei den anderen beiden bekomme ich einen Fehler das dies niocht vorhanden ist, aber nur sobald ich eingeloggt bin. Scheint bei allen zu passieren :(
     
  14. AndréS

    AndréS New Member

    Mal ne andere Frage. Auf welchen Ordner greift eigentlich ISPConfig 3 zu, dann schaue ich erstmal nach, ob es überhaupt da einen phpmyadmin Ordner gibt.

    Weil das kann ja auch sein.

    Danke

    AndréS
     
  15. Till

    Till Administrator

    ISPConfig greift auf keien Ordner mit phpmyadmin zu. Die phpmyadmin Installation ist von der Linux Distribution, ISPConfig ist da nicht involviert und konfiguriert da auch nichts. Du kannst einfach über die IP drauf zugreifen, solange Du sie nicht einer Website zugeordnet hast. Ansonsten siehe meine anderen Posts in diesem Thread.
     
  16. AndréS

    AndréS New Member

    gut okay.
    Ich habe das jetzt soweit verstanden. Wenn ich eine Seite angelegt habe, dann kann ich NUR über die Webseite und nicht mehr über die IP auf phpmyadmin zugreifen.

    Es sollte also so sein, wenn ich die Webseite lösche, dass ich dann wieder über meinIP/phpmyadmin/ drauf komme. Gehe ich da richtig in der Annahme.

    Ich habe ja auch wie du gesagt hast, eine neue Webseite eingerichtet und da auch eine subdomain mit phpmyadmin.bla.de gemacht.

    Problem, diese Domain existiert nicht auf meinem System. Wie schon gefragt, kann es sein, dass erst die Domains auf meine IP geschaltet sein müssen bevor was geht?

    Dann noch ne Frage, wie installiere ich eine Kopie von phpmyadmin?

    Vielen lieben Dank an dich.

    AndréS
     
  17. Till

    Till Administrator

    Ja natürlich. Wie bitte soll eine domain funktioneiern die nicht auf Dein System verweist.

    http://www.phpmyadmin.net/documentation/#quick_install
     
  18. AndréS

    AndréS New Member

    Hi,

    nach einer Neuinstallation ging alles auch ohne das ne Domain drauf registriert war.

    Wollte das nur schnell sagen, damit das Thema von Tisch ist :)
     
  19. AndréS

    AndréS New Member

    Hi till

    nochmal, habe das Selbe Problem wieder, dafür alle anderen behoben :)

    Nun wenn ich auf den Button klicke komme ich zu einem link.

    HOSTNAME/phpmyadmin <----- funktioniert aber nicht :(

    nun ich habe gelesen ich soll eine webseite erstellen.
    Das muss ich jetzt aber ganz genau wissen :)

    Also ich erstelle im ISPConfig eine Webseite wie phpmyadmin.HOSTNAME
    mein HOSTNAME ist server1.webby24.de

    soll ich dann einfach den Ordner /etc/phpmyadmin in den Order der Webseite rein kopieren??? Oder irgendwie anders???

    Hast du vielleicht auch noch exakte Anweisungen für mich?

    Ach ja, Zugriff funktioniert sonst einwandfrei, einfach nur nicht über die Webseite.

    Vielen Dank

    AndréS
     
  20. AndréS

    AndréS New Member

    Ich habe ja nochmal nachgelesen soll ich das nun hier einfach direkt machen:

    Code:
    cd phpMyAdmin
    mkdir config                        # create directory for saving
    chmod o+rw config                   # give it world writable permissions
    cp config.inc.php config/           # copy current configuration for editing
    chmod o+w config/config.inc.php     # give it world writable permissions
    mv config/config.inc.php .         # move file to current directory
    chmod o-rw config.inc.php          # remove world read and write permissions
    rm -rf config                      # remove not needed directory
    Und das direkt auf den Ordner den ich neu angelegt habe????? Oder??????

    Und wenn ja, wie mache ich den link so, dass ich den Button einfahc wieder betätigen kann???

    Vielen Dank

    André
     

Diese Seite empfehlen