postfix php und mysql nach dist-upgrad und ISP update fehlerhaft

Dieses Thema im Forum "Server Administration" wurde erstellt von pagaty, 26. Sep. 2015.

  1. pagaty

    pagaty Member

    Hallo Forum,

    lange habe ich mich vor einem dist-upgrade gedrückt.

    Da der security-support von debian squeeze ausgelaufen ist, habe ich jetzt doch mal damit angefangen.

    Leider habe ich scheinbar damit mein System beschädigt, und komme alleine damit gerade nicht weiter.

    Probleme sind:

    Webseiten mit msyql und php gehen nicht mehr: Internal Server Error.
    Postfix startet mit vielen Warnmeldungen unf sendet keine Mails mehr.

    Code:
    /usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_maps=proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
    /usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_override=yes
    /usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_maildir_extended=yes
    /usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_overquota_bounce=yes
    /usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_create_maildirsize=yes
    /usr/sbin/postconf: warning: /etc/postfix/master.cf: unused parameter: smtpd_bind_address=127.0.0.1
    /usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_maildir_limit_message="The user you are trying to reach is over quota."
    
    Mehrfach wurde im Forum erwähnt, das sich das Porblem mit den Diensten über ein mauelles Update
    Code:
    cd /tmp
    wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
    tar xvfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install
    php -q update.php
    lösen lässt,

    Allerdings bei mir ohne Erfolg.

    Ich hatte geplant erst auf wheezy up-zu-graden, wenn dann alles läuft auf jessy zu wechseln.

    Haltet Ihr es für sinnvoll jetzt schon zu wechseln um damit evtl. die Probleme zu beheben, oder ist es sinnvoller erst die Probleme zu beheben?

    Über Denkanstöße die mich zu einer Lösung führen bin ich dankbar.

    MfG
    Pagaty
     
  2. florian030

    florian030 Member

    Die Warnungen kannst Du ignorieren. Du hast schlicht keinen Postfix-Patch für Quota (brauchst Du m.E. aber auch nicht).
    Wenn Du update.php aufrufst, musst dann auch "reconfigure services" aufrufen, damit die Configs neu geschrieben werden.
    Warum keine Mails gesendet werden, kannst Du im mail.log sehen. Läuft vielleicht nur amavis nicht?
    Bei Probleme mit den Webseiten solltest Du Dir das error.log der jeweiligen Seite ansehen. Wenn das ein generelles Problem ist, sollte es reichen, wenn Du Dir eine Seite näher ansiehst.
     
  3. pagaty

    pagaty Member

    Hallo,
    danke für die schnelle Reaktion.

    Dienste habe ich rekonfiguriern lassen.
    Ich denke, das auch alle laufen
    Code:
    Starting Postfix Mail Transport Agent: postfix.
    Stopping amavisd: amavisd-new.
    Starting amavisd: amavisd-new.
    Stopping ClamAV daemon: clamd.
    Starting ClamAV daemon: clamd .
    Stopping Courier authentication services: authdaemond.
    Starting Courier authentication services: authdaemond.
    Stopping Courier IMAP server: imapd.
    Starting Courier IMAP server: imapd.
    Stopping Courier IMAP-SSL server: imapd-ssl.
    Starting Courier IMAP-SSL server: imapd-ssl.
    Stopping Courier POP3 server: pop3d.
    Starting Courier POP3 server: pop3d.
    Stopping Courier POP3-SSL server: pop3d-ssl.
    Starting Courier POP3-SSL server: pop3d-ssl.
    Update finished.
    
    mail.log
    Code:
    Sep 26 13:12:45 server1 postfix/smtpd[1779]: connect from p579CA5C4.dip0.t-ipconnect.de[xxx.xxx.xxx.xxx]
    Sep 26 13:12:45 server1 postfix/smtpd[1779]: warning: p579CA5C4.dip0.t-ipconnect.de[xxx.xxx.xxx.xxx]: SASL PLAIN authentication failed: no mechanism available
    Sep 26 13:12:45 server1 postfix/smtpd[1779]: warning: p579CA5C4.dip0.t-ipconnect.de[xxx.xxx.xxx.xxx]: SASL LOGIN authentication failed: no mechanism available
    
    Ich dachte, das das mit dem rekonfiguriren gelöst würde.

    im error.log ist
    Code:
    em.source_index called from /var/lib/gems/1.9.1/gems/rails-2.3.11/lib/rails/gem_dependency.rb:21.
    NOTE: Gem::SourceIndex#refresh! is deprecated with no replacement. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#refresh! called from /var/lib/gems/1.9.1/gems/rails-2.3.11/lib/rails/vendor_gem_source_index.rb:34.
    NOTE: Gem::SourceIndex#load_gems_in is deprecated with no replacement. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#load_gems_in called from /usr/lib/ruby/1.9.1/rubygems/source_index.rb:322.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/1.9.1/rubygems/source_index.rb:127.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/1.9.1/rubygems/source_index.rb:127.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/1.9.1/rubygems/source_index.rb:127.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/1.9.1/rubygems/source_index.rb:127.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/1.9.1/rubygems/source_index.rb:127.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/1.9.1/rubygems/source_index.rb:127.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/1.9.1/rubygems/source_index.rb:127.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/1.9.1/rubygems/source_index.rb:127.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/1.9.1/rubygems/source_index.rb:127.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/1.9.1/rubygems/source_index.rb:127.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/1.9.1/rubygems/source_index.rb:127.
    NOTE: Gem::SourceIndex#initialize is deprecated with no replacement. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#initialize called from /var/lib/gems/1.9.1/gems/rails-2.3.11/lib/rails/vendor_gem_source_index.rb:100.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    /var/lib/gems/1.9.1/gems/rails-2.3.11/lib/rails/gem_dependency.rb:277:in `==': undefined method `name' for "actionmailer":String (NoMethodError)
        from /usr/lib/ruby/1.9.1/rubygems/dependency.rb:217:in `==='
        from /usr/lib/ruby/1.9.1/rubygems/dependency.rb:217:in `block in matching_specs'
        from /usr/lib/ruby/1.9.1/rubygems/specification.rb:411:in `block in each'
        from /usr/lib/ruby/1.9.1/rubygems/specification.rb:410:in `each'
        from /usr/lib/ruby/1.9.1/rubygems/specification.rb:410:in `each'
        from /usr/lib/ruby/1.9.1/rubygems/dependency.rb:216:in `find_all'
        from /usr/lib/ruby/1.9.1/rubygems/dependency.rb:216:in `matching_specs'
        from /usr/lib/ruby/1.9.1/rubygems/dependency.rb:238:in `to_specs'
        from /usr/lib/ruby/1.9.1/rubygems/dependency.rb:256:in `to_spec'
        from /usr/lib/ruby/1.9.1/rubygems.rb:1231:in `gem'
        from /var/lib/gems/1.9.1/gems/rails-2.3.11/lib/rails/gem_dependency.rb:75:in `add_load_paths'
        from /var/lib/gems/1.9.1/gems/rails-2.3.11/lib/initializer.rb:301:in `block in add_gem_load_paths'
        from /var/lib/gems/1.9.1/gems/rails-2.3.11/lib/initializer.rb:301:in `each'
        from /var/lib/gems/1.9.1/gems/rails-2.3.11/lib/initializer.rb:301:in `add_gem_load_paths'
        from /var/lib/gems/1.9.1/gems/rails-2.3.11/lib/initializer.rb:132:in `process'
        from /var/lib/gems/1.9.1/gems/rails-2.3.11/lib/initializer.rb:113:in `run'
        from /var/www/redmine-1.2/config/environment.rb:20:in `<top (required)>'
        from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from /var/www/redmine-1.2/public/dispatch.fcgi:21:in `<main>'
    /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': iconv will be deprecated in the future, use String#encode instead.
    
    
    Hätten diese abhängigkeiten denn nicht auch mit dem update/reconfigure behoben sein sollen?

    Danke im Voraus

    Pagaty
     
  4. florian030

    florian030 Member

    Das Problem mit den Mails liegt an Courier / Authdaemon. Durch das Update auf Wheezy passt an der authdaemon.rc (oder wie sich die Config nennt) etwas nicht mehr. Ich kann Dir aus dem Kopf nicht sagen, was das genau war. Da müsstest Du einfach Googel nutzen oder den Loglevel hochsetzen.

    Ruby nutze ich bei mir nicht. Ist nach apt-get upgrade && apt-get update alles installiert?
     

Diese Seite empfehlen