postfix ping pong

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von paepke, 10. Jan. 2008.

  1. paepke

    paepke New Member

    Hallo und Frohes Neues...

    hab derzeit ein Problem mit meinem Postfix, in dem eine mail mit return to sender pingpong spielt. Es sind schon über 12000 mails gespeichert. wie schalte ich das ab bzw. komme an diese Mail-Sendung ran?

    Danke und Grüße Mikel
     
  2. paepke

    paepke New Member

    weis keiner rat?

    bin nun bei >100000

    Code:
    Return-Path: <>
    X-Original-To: [email]mp_admin@mein-server.de[/email]
    Delivered-To: [email]mp_admin@mein-server.de[/email]
    Received: by mein-server.de (Postfimeinx)
            id BAE0858841A; Thu, 10 Jan 2008 12:41:02 +0100 (CET)
    Date: Thu, 10 Jan 2008 12:41:02 +0100 (CET)
    From: [email]MAILER-DAEMON@mein-server.de[/email] (Mail Delivery System)
    Subject: Undelivered Mail Returned to Sender
    To: [email]mp_admin@mein-server.de[/email]
    Auto-Submitted: auto-replied
    MIME-Version: 1.0
    Content-Type: multipart/report; report-type=delivery-status;
            boundary="AE1E158841C.1199965262/mein-server.de"
    Message-Id: <20080110114102.BAE0858841A@mein-server.de>
    
    This is a MIME-encapsulated message.
    
    --AE1E158841C.1199965262/mein-server.de
    Content-Description: Notification
    Content-Type: text/plain; charset=us-ascii
    
    This is the mail system at host mein-server.de.
    
    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.
    
    For further assistance, please send mail to postmaster.
    
    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.
    
                       The mail system
    
    <admispconfig@localhost.localdomain>: Host or domain name not found. Name
        service error for name=localhost.localdomain type=AAAA: Host not found
    
    --AE1E158841C.1199965262/mein-server.de
    Content-Description: Delivery report
    Content-Type: message/delivery-status
    
    Reporting-MTA: dns; mein-server.de
    X-Postfix-Queue-ID: AE1E158841C
    X-Postfix-Sender: rfc822; [email]mp_admin@mein-server.de[/email]
    Arrival-Date: Thu, 10 Jan 2008 12:41:02 +0100 (CET)
    
    Final-Recipient: rfc822; [email]admispconfig@localhost.loca[/email]ldomain
    Action: failed
    Status: 5.4.4
    Diagnostic-Code: X-Postfix; Host or domain name not found. Name service error
        for name=localhost.localdomain type=AAAA: Host not found
    
    --AE1E158841C.1199965262/mein-server.de
    Content-Description: Undelivered Message
    Content-Type: message/rfc822
    
    Received: by mein-server.de (Postfix, from userid 10091)
            id AE1E158841C; Thu, 10 Jan 2008 12:41:02 +0100 (CET)
     
    Zuletzt bearbeitet: 10. Jan. 2008
  3. Till

    Till Administrator

    Solche Loops werden eigentlich von Postfix erkannt, keine Ahnung warum das bei Dir neicht geht. Dann stopp mal postfix und leere die mailqueue. das geht z.B. mit folgendem kleinen shell script:

    Code:
    mailq | tail +2 | awk 'BEGIN { RS = "" }
    # $7=sender, $8=recipient1, $9=recipient2
    { if ($7 == "MAILER-DAEMON")
    print $1 }
    ' | tr -d '*!' | postsuper -d -
    Du musst das Wort MAILER-DAEMON durch den Absender ersetzen oder statt $7 == "MAILER-DAEMON" z.B. $8 == "EMPFÄNFGERADRESSE" verwenden.
     
  4. paepke

    paepke New Member

    leider nicht beseitigt

    leider macht der nach dem löschen weiter!

    und ich habe festgestellt, wenn ein mail empfangen wird (egal welche mailadresse) der server sofort wieder los legt und unzählige mail an die adresse <admispconfig@localhost.localdomain> sendet... -> die es garnicht gibt bzw. mal gab

    das macht den server richtig fertig - ist das evtl ein wurm?
     
  5. Till

    Till Administrator

    Das was Du da beschreibst ist Keine Nachricht, die hin und Her geschickt wird. Die Adresse admispconfig@localhost.localdomain gibt es auf jedem ISPConfig server. Stell bitte sicher, dass es eine Zeile localhost.localdomain in /etc/postfix/local-host-names gibt. Ist die Zeile nicht da, füge sie am Ende ein.
     
  6. paepke

    paepke New Member

    Hallo Till,

    Danke - die Adresse ist dort ordentlich gelistet...
    und hab damit auch festgestellt das dies kein PingPong-Spiel sein kann

    Jetzt hab ich aber etwas anderes gemacht: im Dezember hast Du mir den Vorschlag gemacht $go_info["server"]["postfix_config"] = 1; auf 2 zu setzen. Ich hab das Ganze nun zurück gesetzt auf SENDMAIL-STYLE

    bis jetzt macht der server wieder seine normalen Dienste...
    gib es da einen Zusammenhang?

    hoffentlich bleibt das so....
     
  7. Till

    Till Administrator

    Ja, das ist möglich, dass es daran lag. War der Fehler denn gleich nach der Umstellung da?
     
  8. paepke

    paepke New Member

    ja im Prinzip -> aber da der Server noch nicht öffentlich war kamen jetzt im Januar erst die ersten mails


    nach der umstellung läuft allerdings mein webmailer (roundcube) nicht mehr -> läßt kein einloggen zu
     

Diese Seite empfehlen