Postfix-Problem (Empfang wird verweigert) und Quota-Problem (Fehler beim Starten)

#1
Guten Morgen zusammen,

seit 2 Tagen hänge ich an zwei Problemchen und ich hoffe, ihr könnt mir helfen.

Vorgestern habe ich einen Root-Server mit vorinstalliertem Debian etch bekommen. Habe zahlreiche Pakete (nach "der perfekte Server - Debian etch") installiert und dann natürlich auch ISPConfig. Ich hatte aber die Pakete Quota und Postfix übersehen. Also, die dann gleich mal hinterher und prompt scheint es Probleme zu geben.

Postfix:
Man kann Emails verschicken, doch beim Empfang werden die verweigert. Der Absender bekommt die Returnemail mit folgender Meldung:
<web1_test@test-web.de>: host test-web.de[62.75.219.150] said:
554 5.7.1 <web1_test@test-web.de>: Relay access denied (in reply to
RCPT TO command)
Im Logfile vom test-web.de findet man dazu die folgenden fünf Zeilen:

Sep 12 02:10:52 servername postfix/smtpd[32218]: connect from sender.de[62.75.224.243]
Sep 12 02:10:52 servername postfix/smtpd[32218]: setting up TLS connection from sender.de[62.75.224.243]
Sep 12 02:10:52 servername postfix/smtpd[32218]: TLS connection established from sender.de[62.75.224.243]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
Sep 12 02:10:52 servername postfix/smtpd[32218]: NOQUEUE: reject: RCPT from sender.de[62.75.224.243]: 554 5.7.1 <web1_test@test-web.de>: Relay access denied; from=<absender@absender.com> to=<web1_test@test-web.de> proto=ESMTP helo=<prag249.server4you.de>
Sep 12 02:10:52 servername postfix/smtpd[32218]: disconnect from sender.de[62.75.224.243]
Seltsam war bei der Installation von Postfix die Generierung vom SSL, da er mich plötzlich nach einem Passwort für smtpd.key fragte. Davon stand nämlich in der Installation nämlich nichts. Habe dann aber immer das gleiche Passwort angegeben.


Quota:
Eigentlich schien alles normal zu sein, bis auf die letzten beiden Befehle, die mit Fehlermeldungen quittiert wurden:
# quotacheck -avugm:
quotacheck: Quota for users is enabled on mountpoint / so quotacheck might damage the file
Please turn quotas off or use -f for force checking

# quotaon -avug
quotaon: using //quota.group on /dev/md1 [/]: Das Gerät oder die Ressouce ist belegt.
quotaon: using //aquota.user on /dev/md1 [/]: Das Gerät oder die Ressouce ist belegt.
Ich hoffe, ihr habt zu meinen Problemen die dazugehörigen Lösungen, denn ansonsten läuft alles andere.

Gruß
 
#2
Mmh, entweder sind meine Fragen zu einfach oder zu schwierig. Meine Finger sind schon ganz wund vom googlen, aber ich finde nichts passendes.

Was mir noch aufgefallen ist, nachdem ich nun zum zehnten Mal das Howto zu "der perfekte Server - Debian etch" gelesen habe, dass er bei der Installation von courier die beiden Fragen:

Create directories for web-based administration ? <– No
SSL certificate required <– Ok


nicht gestellt wurden. Wo kann ich nachsehen, ob diese beiden Einstellungen richtig gesetzt sind?


Wenn ich versuche
saslauthd -c -m /var/spool/postfix/var/run/saslauthd -r
aufzurufen, kommt die Meldung:
saslauthd[4039] :main : no authentication mechanism specified
und dann folgen die ganzen option informationen. Das ist doch auch nicht normal. Das angegebene Verzeichnis beinhaltet folgende Dateien:

saslauthd.pid (6 Bytes)
mux.accept (0 Byte)
mux (0 Byte)
cache.mmap (945.154 Bytes)
cache.flock (0 Byte)

Sind diese so in Ordnung?

Gruß
 

Till

Administrator
#3
Poste mal den Inhalt der Dateien (ohne Kommentare):

/etc/postfix/main.cf
/etc/postfix/virtusertable
/etc/postfix/local-host-names

nicht gestellt wurden. Wo kann ich nachsehen, ob diese beiden Einstellungen richtig gesetzt sind?
Dass kann anders sein, wenn das Debian mit anderen Defaulst von Deinem Hoster installiert wurde. ist aber nicht weiter schlimm, da courier auch funktioniert, wenn Du dort was anderes auswählst.
 
#4
Hallo Till,

die Inhalte sind wie folgt:

/etc/postfix/main.cf
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no
append_dot_mydomain = no
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
myhostname = fulda014.server4you.de
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = fulda014.server4you.de, localhost, localhost.localdomain, localhost.fulda014.server4you.de
relayhost =
mynetworks = 127.0.0.0/8
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = ipv4
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
Die Dateien /etc/postfix/virtusertable und /etc/postfix/local-host-names gibt es bei mir nicht, virtusertable und local-host-names liegen im Verzeichnis /etc/mail:

virtusertable:
local-host-names:

localhost
fulda014.server4you.de
localhost.fulda014.server4you.de
localhost.server4you.de
localhost.localdomain
www.empfaenger.de
empfaenger.de
Gruß
 

Till

Administrator
#5
Hast Du während der ISPConfig Installation postfix oder Sendmail als mail daemon ausgewählt? Scheint so. als ob Du sendmail und Postfix installiert hast und dann sendmail in ISPConfig ausgewählt ist während in Deinem setup postfix gestartet ist.
 
#6
Was ich bei der Installation von ispconfig ausgewählt habe, weiß nun nicht mehr. In der Administration -> Server -> Eigenschaften -> Email findet man beim MTA-Typ beide Angaben, Sendmail und Postfix (postfix ist ausgewählt)
weitere Angaben:
Virtuser Datei: /etc/mail/virtusertable
Sendmail CW: /etc/mail/local-host-names
Mail Log: /var/log/mail.log
Maildir ist auch angeklickt.

Wenn ich die beiden Dateien /etc/mail/virtusertable und /etc/mail/local-host-names in /etc/postfix verschiebe und die neuen Pfade in der Administration angebe, korrigiere ich damit das Problem oder verschlimmere ich es dadurch?
 

Till

Administrator
#7
Wenn ich die beiden Dateien /etc/mail/virtusertable und /etc/mail/local-host-names in /etc/postfix verschiebe und die neuen Pfade in der Administration angebe, korrigiere ich damit das Problem oder verschlimmere ich es dadurch?
Lass die Dateien mal wo sie sind und füge sattdessen die Folgenden Zeilen in der postfix main.cf ein:

virtual_maps = hash:/etc/mail/virtusertable
mydestination = /etc/mail/local-host-names

und starte postfix neu.
 
#8
Jo, das war es. Email kommen nun an. Ich nehme mal an, dass in der Administration zunächst sendmail gestanden hat und ISPConfig die beiden Dateien daher im üblichen Verzeichnis für sendmail angelegt und in der conf von Sendmail eingetragen hat. Ein späteres Ändern in postfix bewirkte dabei keine Korrektur.

Mir fällt schon einmal ein Stein von der Schulter. Mal sehen, ob es noch ohne Probleme weiter geht. Danke und schönes Wochenende.

Gruß
 

Werbung

Top