postfix problem

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Sigix, 5. Feb. 2014.

  1. Sigix

    Sigix Member

    Hi Leute,

    ich habe ein Problem und komme nicht dahinter!

    ich habe einen Debian GNU/Linux 7.3 (wheezy) Server mit
    dovecot, postfix, mailscanner, amavis ,.. am laufen!

    postfix version = 2.9.6

    Wenn dieser Mailserver eine Mail von extern mit ca. 100 oder mehr recipients (alle recipients werden auf diesem Server gehostet) erhält, bricht dieser den Empfang ab!

    Hier das log von dem Sendeserver:
    2014-01-28T12:08:53.159Z,Default,08D08FDCF609CA51,0,,195.xxx.xxx.19:25,*,,attempting to connect
    2014-01-28T12:08:53.159Z,Default,08D08FDCF609CA51,1,144.xxx.xxx.83:55541,195.xxx.xxx.19:25,+,,
    2014-01-28T12:08:54.781Z,Default,08D08FDCF609CA51,2,144.xxx.xxx.83:55541,195.xxx.xxx.19:25,<,220 *********************************************,
    2014-01-28T12:08:54.781Z,Default,08D08FDCF609CA51,3,144.xxx.xxx.83:55541,195.xxx.xxx.19:25,>,EHLO sv2exch3.example.or.de,
    2014-01-28T12:08:54.781Z,Default,08D08FDCF609CA51,4,144.xxx.xxx.83:55541,195.xxx.xxx.19:25,<,250-example.com,
    2014-01-28T12:08:54.781Z,Default,08D08FDCF609CA51,5,144.xxx.xxx.83:55541,195.xxx.xxx.19:25,<,250-PIPELINING,
    2014-01-28T12:08:54.781Z,Default,08D08FDCF609CA51,6,144.xxx.xxx.83:55541,195.xxx.xxx.19:25,<,250-SIZE 50240000,
    2014-01-28T12:08:54.781Z,Default,08D08FDCF609CA51,7,144.xxx.xxx.83:55541,195.xxx.xxx.19:25,<,250-ETRN,
    2014-01-28T12:08:54.781Z,Default,08D08FDCF609CA51,8,144.xxx.xxx.83:55541,195.xxx.xxx.19:25,<,250-XXXXXXXA,
    2014-01-28T12:08:54.781Z,Default,08D08FDCF609CA51,9,144.xxx.xxx.83:55541,195.xxx.xxx.19:25,<,250-AUTH PLAIN LOGIN,
    2014-01-28T12:08:54.781Z,Default,08D08FDCF609CA51,10,144.xxx.xxx.83:55541,195.xxx.xxx.19:25,<,250-AUTH=PLAIN LOGIN,
    2014-01-28T12:08:54.781Z,Default,08D08FDCF609CA51,11,144.xxx.xxx.83:55541,195.xxx.xxx.19:25,<,250-ENHANCEDSTATUSCODES,
    2014-01-28T12:08:54.781Z,Default,08D08FDCF609CA51,12,144.xxx.xxx.83:55541,195.xxx.xxx.19:25,<,250-8BITMIME,
    2014-01-28T12:08:54.781Z,Default,08D08FDCF609CA51,13,144.xxx.xxx.83:55541,195.xxx.xxx.19:25,<,250 DSN,
    2014-01-28T12:08:54.781Z,Default,08D08FDCF609CA51,14,144.xxx.xxx.83:55541,195.xxx.xxx.19:25,*,889461,sending message
    2014-01-28T12:08:54.781Z,Default,08D08FDCF609CA51,15,144.xxx.xxx.83:55541,195.xxx.xxx.19:25,>,MAIL FROM:<Sender@sendmail.com> SIZE=743355,
    2014-01-28T12:08:54.781Z,Default,08D08FDCF609CA51,16,144.xxx.xxx.83:55541,195.xxx.xxx.19:25,>,RCPT TO:<email2@example.com>,
    2014-01-28T12:08:54.781Z,Default,08D08FDCF609CA51,17,144.xxxx.xxx.83:55541,195.xxx.xxx.19:25,>,RCPT TO:<email3@example.com>,
    2014-01-28T12:08:54.781Z,Default,08D08FDCF609CA51,18,144.xxx.xxx.83:55541,195.xxx.xxx.19:25,>,RCPT TO:<email4@example.com>,
    2014-01-28T12:08:54.781Z,Default,08D08FDCF609CA51,19,144.xxx.xxx.83:55541,195.xxx.xxx.19:25,>,RCPT TO:<email1@example.com>,

    und dann ist einfach aus!

    Leider habe ich kein aussagekräftiges Log da ich verbose Login erst danach eingeschalten habe!

    hier meine postfix config:

    postconf -n
    alias_database = hash:/etc/aliases
    alias_maps = hash:/etc/aliases
    append_dot_mydomain = no
    biff = no
    bounce_queue_lifetime = 1d
    broken_sasl_auth_clients = yes
    config_directory = /etc/postfix
    default_destination_recipient_limit = 500
    default_recipient_limit = 10000
    disable_vrfy_command = yes
    dovecot_destination_recipient_limit = 1
    header_checks = regexp:/etc/postfix/header_checks
    inet_interfaces = all
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    maximal_queue_lifetime = 1d
    message_size_limit = 50240000
    mydestination = mail.mailserver.com, mail.mailserver.at, localhost, localhost.localdomain
    myhostname = mailserver.com
    mynetworks = 127.0.0.0/8
    myorigin = /etc/mailname
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $smtpd_sender_login_maps
    readme_directory = /usr/share/doc/postfix
    recipient_delimiter = +
    relayhost =
    smtp_data_done_timeout = 1200s
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    smtpd_client_restrictions = check_client_access hash:/etc/postfix/access permit_mynetworks permit_sasl_authenticated reject_unauth_pipelining reject_rbl_client bl.spamcop.net reject_rbl_client dnsbl.dronebl.org reject_rbl_client cbl.abuseat.org reject_rbl_client ix.dnsbl.manitu.net reject_rbl_client combined.njabl.org reject_rbl_client zen.spamhaus.org reject_rbl_client t1.dnsbl.net.au
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_recipient_access hash:/etc/postfix/access,reject_unauth_destination
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_sasl_local_domain = $myhostname
    smtpd_sasl_path = private/auth_dovecot
    smtpd_sasl_security_options = noanonymous
    smtpd_sasl_tls_security_options = noanonymous
    smtpd_sasl_type = dovecot
    smtpd_sender_login_maps = proxy:mysql:/etc/postfix/mysql_sender_login_maps.cf
    smtpd_sender_restrictions = check_sender_access hash:/etc/postfix/access, reject_unknown_address, reject_non_fqdn_sender
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtpd_tls_session_cache_timeout = 3600s
    smtpd_use_tls = yes
    virtual_alias_maps = mysql:/etc/postfix/mysql_virtual_alias_maps.cf,mysql:/etc/postfix/mysql_virtual_email2email.cf
    virtual_gid_maps = static:5000
    virtual_mailbox_base = /home/vmail/
    virtual_mailbox_domains = mysql:/etc/postfix/mysql_virtual_domains_maps.cf
    virtual_mailbox_limit = 112400000
    virtual_mailbox_maps = mysql:/etc/postfix/mysql_virtual_mailbox_maps.cf
    virtual_minimum_uid = 104
    virtual_transport = dovecot
    virtual_uid_maps = static:5000
    postconf: warning: /etc/postfix/master.cf: unused parameter: smtpd_bind_address=127.0.0.1


    Kann mir da wer helfen ????

    Danke im Voraus!
    :)
     
    Zuletzt bearbeitet: 5. Feb. 2014
  2. Till

    Till Administrator

    versuch mal:

    postconf -e 'smtpd_recipient_limit = 1000'

    und dann postfix neu starten.
     
  3. Sigix

    Sigix Member

    danke für die Info,

    habe ich jetzt mal eingetragen!
    Ich werde das heute Nacht mal testen!

    Gibt es für SMTP ein default recipients ????
    Das Einlesen der Recipients hört bei 126 ohne jegliche Meldung auf!?!?

    Danke
     
  4. Till

    Till Administrator

    Versuch mal:

    postconf -d | grep smtpd_recipient_limit
     
  5. Till

    Till Administrator

    Versuch mal:

    postconf -d | grep smtpd_recipient_limit
     
  6. Sigix

    Sigix Member

    postconf -d | grep smtpd_recipient_limit
    smtpd_recipient_limit = 1000

    war schon 1000 also das kann es nicht sein.... was könne es noch sein dass der Mailserver einfach aufhört ???
     

Diese Seite empfehlen