Postfix/SMTPD nicht ansprechbar

Dieses Thema im Forum "Server Administration" wurde erstellt von bts_freak, 8. Juni 2011.

  1. bts_freak

    bts_freak New Member

    Hi!

    Ich habe ein KonfigProblem des Postfix unter Opensuse 11.2
    Pop/Mail abholen geht super.
    Mail senden nicht.
    In Outlook funktioniert zwar das Verbinden mit dem Postausgangsserver, aber beim Senden kommt ein Fehler:
    "Outlook could not connect to the outgoing mail server (SMTP). The problem could be your SSL or port settings for the outgoing server. Verfify your port and SSL setting sunder the More settings tab."

    SSL ist deaktiviert.
    Port in Outlook hab ich auf 10025 gestellt, mit 25 gibt es zwei Fehlermeldungen (Testmail UND Verbindung (Verbindung geht mit Port 10025))

    Was mit aufgefallen ist, ist dass netstat -tap mir nur "smtp" anzeigt, nicht "smtpd", wobei glaub ich in den Configs immer nur smtpd konfiguriert wird.

    Im Log wird aber alle 5 Minuten mit dem smtpd verbunden:
    Jun 8 06:20:01 sh3 postfix/smtpd[6843]: connect from localhost[::1]
    Jun 8 06:20:01 sh3 postfix/smtpd[6843]: lost connection after CONNECT from localhost[::1]
    Jun 8 06:20:01 sh3 postfix/smtpd[6843]: disconnect from localhost[::1]


    ------------------------------------------------------
    ******************************************
    ------------------------------------------------------
    master.cf:
    # Postfix master process configuration file. For details on the format
    # of the file, see the Postfix master(5) manual page.
    #
    # ==========================================================================
    # service type private unpriv chroot wakeup maxproc command + args
    # (yes) (yes) (yes) (never) (100)
    # ==========================================================================
    smtp inet n - n - - smtpd
    #amavis unix - - n - 4 smtp
    # -o smtp_data_done_timeout=1200
    # -o smtp_send_xforward_command=yes
    # -o disable_dns_lookups=yes
    # -o max_use=20
    #submission inet n - n - - smtpd
    # -o smtpd_etrn_restrictions=reject
    # -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    #smtps inet n - n - - smtpd -o smtpd_tls_wrappermode=yes
    # -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
    #submission inet n - n - - smtpd
    # -o smtpd_etrn_restrictions=reject
    # -o smtpd_enforce_tls=yes -o smtpd_sasl_auth_enable=yes
    #628 inet n - n - - qmqpd
    pickup fifo n - n 60 1 pickup
    cleanup unix n - n - 0 cleanup
    qmgr fifo n - n 300 1 qmgr
    #qmgr fifo n - n 300 1 oqmgr
    tlsmgr unix - - n 1000? 1 tlsmgr
    rewrite unix - - n - - trivial-rewrite
    bounce unix - - n - 0 bounce
    defer unix - - n - 0 bounce
    trace unix - - n - 0 bounce
    verify unix - - n - 1 verify
    flush unix n - n 1000? 0 flush
    proxymap unix - - n - - proxymap
    smtp unix - - n - - smtp
    # When relaying mail as backup MX, disable fallback_relay to avoid MX loops
    relay unix - - n - - smtp
    -o fallback_relay=
    # -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
    showq unix n - n - - showq
    error unix - - n - - error
    discard unix - - n - - discard
    local unix - n n - - local
    virtual unix - n n - - virtual
    lmtp unix - - n - - lmtp
    anvil unix - - n - 1 anvil
    #localhost:10025 inet n - n - - smtpd
    # -o content_filter=
    # -o smtpd_delay_reject=no
    # -o smtpd_client_restrictions=permit_mynetworks,reject
    # -o smtpd_helo_restrictions=
    # -o smtpd_sender_restrictions=
    # -o smtpd_recipient_restrictions=permit_mynetworks,reject
    # -o smtpd_data_restrictions=reject_unauth_pipelining
    # -o smtpd_end_of_data_restrictions=
    # -o smtpd_restriction_classes=
    # -o mynetworks=127.0.0.0/8
    # -o smtpd_error_sleep_time=0
    # -o smtpd_soft_error_limit=1001
    # -o smtpd_hard_error_limit=1000
    # -o smtpd_client_connection_count_limit=0
    # -o smtpd_client_connection_rate_limit=0
    # -o receive_override_options=no_header_body_checks,no_unknown_recipient_checks,no_address_mappings
    # -o local_header_rewrite_clients=
    # -o local_recipient_maps=
    # -o relay_recipient_maps=
    scache unix - - n - 1 scache

    maildrop unix - n n - - pipe
    flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient} ${extension} ${recipient} ${user} ${nexthop} ${sender}
    cyrus unix - n n - - pipe
    user=cyrus argv=/usr/lib/cyrus/bin/deliver -e -r ${sender} -m ${extension} ${user}
    uucp unix - n n - - pipe
    flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
    ifmail unix - n n - - pipe
    flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
    bsmtp unix - n n - - pipe
    flags=Fq. user=foo argv=/usr/local/sbin/bsmtp -f $sender $nexthop $recipient
    # do not filter locally delivered mail when USE_AMAVIS=yes
    # (don't set content_filter=vscan in main.cf)
    #vscan unix - n n - 10 pipe
    # user=vscan argv=/usr/sbin/amavis ${sender} ${recipient}
    procmail unix - n n - - pipe
    flags=R user=nobody argv=/usr/bin/procmail -t -m /etc/procmailrc ${sender} ${recipient}
    retry unix - - n - - error
    proxywrite unix - - n - 1 proxymap

    amavis unix - - - - 2 smtp
    -o smtp_data_done_timeout=1200
    -o smtp_send_xforward_command=yes
    127.0.0.1:10025 inet n - - - - smtpd
    -o content_filter=
    -o local_recipient_maps=
    -o relay_recipient_maps=
    -o smtpd_restriction_classes=
    -o smtpd_client_restrictions=
    -o smtpd_helo_restrictions=
    -o smtpd_sender_restrictions=
    -o smtpd_recipient_restrictions=permit_mynetworks,reject
    -o mynetworks=127.0.0.0/8
    -o strict_rfc821_envelopes=yes
    -o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
    -o smtpd_bind_address=127.0.0.1
    ------------------------------------------------------
    ******************************************
    ------------------------------------------------------


    Irgendwelche Ideen, wo ich noch gucken kann?

    Danke!
     
  2. Till

    Till Administrator

    Der outgoing port für smtp ist 25 und nicht 10025. Ändere bitte mal in outlook den Port auf 25 und stell sicher dass smtp authentifizierung beim senden in outlook für das Konto aktiviert ist.

    Das ist ok, es ist der system monitor der checkt ob postfix läuft.
     
  3. bts_freak

    bts_freak New Member

    Hi Till,

    thanks a lot for the answer.
    If I change to port 25, then I get two errors. Not only does the test send message fail (which it also did on port 10025), but also I get an error for the "Find outgoing server" (which was successfull with port 10025).

    The new err message is similar:
    "Outlook could not connect to the outgoing mail server (SMTP). The problem could be the server name or port, or your server may not support SSL. Verify your port and SSL settings in "More Settings"...."
     
  4. bts_freak

    bts_freak New Member

    Arrg.. sorry, noch im english-Modus....

    Hi Till,
    Vielen Dank für die Antwort.
    Wenn ich auf Port 25 umschalte, dann bekomme ich 2 Fehler. Neben dem "Send Test Message" bekomme ich nun auch noch einen "Find outgoing server" Error (dieser kommt nicht bei Einstellung auf Port 10025).

    Die neue Fehlermeldung ist ähnlich:
    "Outlook could not connect to the outgoing mail server (SMTP). The problem could be the server name or port, or your server may not support SSL. Verify your port and SSL settings in "More Settings"...."
     
  5. Till

    Till Administrator

    poste mal die Ausgabe von:

    netstat -tap

    und

    iptables -L

    und die Fehlermedlungen aus dem mail.log des Servers.
     
  6. bts_freak

    bts_freak New Member

    Vielen Dank Till!

    netstat:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost:imap *:* LISTEN 1743/couriertcpd
    tcp 0 0 *:sunrpc *:* LISTEN 1659/rpcbind
    tcp 0 0 *:ftp *:* LISTEN 2368/pure-ftpd (SER
    tcp 0 0 *:ssh *:* LISTEN 2462/sshd
    tcp 0 0 *:smtp *:* LISTEN 6288/master
    tcp 0 0 localhost:npmp-local *:* LISTEN 1706/famd
    tcp 0 0 localhost:10024 *:* LISTEN 2226/amavisd (maste
    tcp 0 0 localhost:10025 *:* LISTEN 6288/master
    tcp 0 0 *:mysql *:* LISTEN 2210/mysqld
    tcp 0 0 localhost:dyna-access *:* LISTEN 1790/clamd
    tcp 0 0 localhost:39212 localhost:mysql ESTABLISHED 2257/amavisd (ch6-a
    tcp 0 0 localhost:32831 localhost:mysql ESTABLISHED 2256/amavisd (ch7-a
    tcp 0 248 h1832697.stratoserv:ssh xxx.xxx.xxx.xxx:14293 ESTABLISHED 27241/0
    tcp 0 0 localhost:mysql localhost:32831 ESTABLISHED 2210/mysqld
    tcp 0 0 localhost:mysql localhost:39212 ESTABLISHED 2210/mysqld
    tcp 0 0 *:sunrpc *:* LISTEN 1659/rpcbind
    tcp 0 0 *:http-alt *:* LISTEN 2260/httpd2-prefork
    tcp 0 0 *:www-http *:* LISTEN 2260/httpd2-prefork
    tcp 0 0 *:sunproxyadmin *:* LISTEN 2260/httpd2-prefork
    tcp 0 0 *:ftp *:* LISTEN 2368/pure-ftpd (SER
    tcp 0 0 *:ssh *:* LISTEN 2462/sshd
    tcp 0 0 *:smtp *:* LISTEN 6288/master
    tcp 0 0 *:imaps *:* LISTEN 1739/couriertcpd
    tcp 0 0 *:pop3s *:* LISTEN 1786/couriertcpd
    tcp 0 0 *:pop3 *:* LISTEN 1779/couriertcpd
    tcp 0 0 h1832697.strat:www-http b3091212.cra:filenet-re TIME_WAIT -
    tcp 0 0 h1832697.strat:www-http b3091212.crawl.ya:32940 TIME_WAIT -

    ------------------------------
    iptables:

    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    -----------------------------
    /var/log/mail.err:
    Jun 9 02:28:52 sh3 amavis[2256]: (02256-07) (!!)ClamAV-clamd av-scanner FAILED: run_av error: Too many retries to talk to /var/run$
    Jun 9 02:28:52 sh3 amavis[2256]: (02256-07) (!!)WARN: all primary virus scanners failed, considering backups

    sonst nichts seit Tagen.
    --------------------------


    Bis dann!
     
  7. Till

    Till Administrator

    Postfix läuft auf Port 25:

    tcp 0 0 *:smtp *:* LISTEN 6288/master

    und laut iptables ist port 25 auch nicht blockiert. An sich sollte daher Outlook funktionieren. Versuch bitte mal einen anderen mail client, der aussagekräftigere Fehlermeldungen macht wie z.B. Thunderbird portable. Den kannst Du nutzen ohne ihn installieren zu müssen.
     
  8. bts_freak

    bts_freak New Member

    Hi TIm,

    ok, hab thunderbird Portable installiert.
    Der schnappt sich auch eine richtig aufgelöste URL als SMTP Server. Beim Senden kommt aber:
    "
    Senden der Nachricht fehlgeschlagen.
    Die Nachricht konnte nicht gesendet werden, weil der Verbindungsaufbau mit dem SMTP-Server "" fehlgeschlagen ist. Der Server is..." ?? Gibts da irgendwas aussagekräftigeres?
     
  9. Till

    Till Administrator

    Steht der Server in einem Rechenzentrum, oder ist er auf einer DSL leitung gehostet?
     
  10. bts_freak

    bts_freak New Member

    Hi Till,

    ist ein virtueller Server in Rechenzentrum (Strato Multiserver). Ich habe allerdings auf anderen virtuellen Servern dieser Art diese Probleme nicht.

    Hmm... vielleicht einfach nochmal aufsetzen...?
     
  11. mare

    mare Member

    Hallo,

    Kann es sein, das du mal eine Virus in deinem Netz gehabt hast und dein Provider dir PORT 25 dicht gemacht hat :rolleyes:

    Kannst du ganz einfach mal mit
    telnet mail.gmx.de 25
    testen. Wenn da auch ein Timeout kommt ist es wohl so.
    Dann teste mal telnet mail.gmx.de 587
    Wenn das geht dann ändert deine main.cf so
    smtp inet n - - - - smtpd
    submission inet n - - - - smtpd
    und trage die 587 als Port im Outlook ein.

    Mehr: Simple Mail Transfer Protocol
     
  12. bts_freak

    bts_freak New Member

    Hab jetzt von nem anderen Server (anderes Netz) auf Port 25 versucht mit telnet [ServerURL] 25 - geht ohne Probleme.

    Im Mail Client ist auch 25 eingestellt als SMTP Port.

    Wo wird eigentlich das SMTP Passwort in ISPConfig eingestellt? Das in den Mailboxen?
     
  13. Till

    Till Administrator

    Ja. Der smtp Username ist die vollständige Emailadresse und das Passwort ist das Passwort der Mailbox.
     
  14. bts_freak

    bts_freak New Member

    Na das passt dann schon...
    Habs jetzt auch nochmal vom Desktop (Win7/cmd/telnet probiert, Verbidnung geht einwandfrei (wobei er nicht nach einem Passwort fragt).

    Seufz.. Noch irgendeine Idee...?
     
  15. Till

    Till Administrator

    Ein Passwort ist ja nur dann notwendig, wenn Du eine Email zu einem externen Server evrschickst, also z.B. zu gmail.com. Wenn Du als empfänger eine lokale Adresse angibst, ist natürlich kein passwort notwendig, da ja der server selbst für die Zustellung notwendig ist und es sich somit nicht um ein mail relaying handelt. Würde der lokale Server auch für lokale Empfänger ein Passwort abfragen, könnte Dir ja nirmand emails senden.
     
  16. Doc.B

    Doc.B New Member

    Muß mich mal hier einklinken.....

    ...habe beim Versand genau das gleiche Problem, allerdings mit Thunderbird (aktuelle Version von heute) unter Windoze Vista: Stelle ich SSL/TLS und Port 25 ein kommt obige Fehlermeldung (Server nicht erreichbar, bla...)
    Versuche ich das ganze von meinem PC (openSUSE 11.3, KMail) mit den gleichen Einstellungen, klappt das ganze problemlos.
    Ist Thunderbird evtl etwas buggy?
     
  17. Till

    Till Administrator

    Thunderbird ist da an sich nicht buggy, es geht nur leider davon aus dass der username nicht die Emailadresse ist. Schau mal in die thunderbird smtp einstellungen nachdem Du das Konto angelegt hast und kontrollier, ob dort als Username wirklich die ganze Emailadresse drin steht und nicht nur der Teil vor dem @
     

Diese Seite empfehlen