Problem mit der Datei /etc/hosts Datei

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Falcon37, 1. Apr. 2009.

  1. Falcon37

    Falcon37 New Member

    Ich möchte ISPConfig 3 auf Debian Lenny installieren (was ich ja bekanntlich desöfteren tu :D) nur irgendwie gibts ein Problem mit der Datei /etc/hosts. Ich komme gleich auf den Punkt - ist dieser Eintrag korrekt?
    Code:
    127.0.0.1       localhost.localdomain   localhost
    Meine.ip   server1.meine.domain.asia   ispconfig
    die ausgabe von (root@Z035E)-(~) $ /bin/hostname ergibt aber:
    Code:
    Z035E
    Blick da leider nicht mehr ganz durchh. Gehe immer nach diesem HowTo vor.

    Danke :)

    Nachtrag:
    Habe jetzt mit der eben geposteten host datei versucht zu installiere, klappt nicht bekomme wieder diese meldung:
    http://www.howtoforge.de/forum/showpost.php?p=9496&postcount=25
     
    Zuletzt bearbeitet: 1. Apr. 2009
  2. Till

    Till Administrator

    Schreibe bitte mal den vollen Hostnamen in die datei /etc/hostname und ruf dann auf:

    /etc/init.d/hostname.sh

    Der Fehler den Du erhältst bedeutet dass entweder Deine DB leer ist oder aber einige wichtige Dateien Deiner ISPConfig installation feheln und daher keun Update ausgeführt werden kann.

    Die fehlende Datei ist halt dummerweise auch noch die config.inc.php welche alle Informationen enthält die ISPConfig für das Server script aber auch für das Update braucht.

    Poste doch mal:

    ls -la /usr/local/ispconfig/server/lib/
     
  3. Falcon37

    Falcon37 New Member

    Habe in der /etc/hostname Datei das stehen:
    Code:
    server1.meine-domain.asia
    Und dier Datei /etc/init.d/hostname.sh in der shell aufgerufen.

    Die Ausgabe von ls -la /usr/local/ispconfig/server/lib/ lautet:
    Code:
    (root@server1)-(~) $ ls -la /usr/local/ispconfig/server/lib/
    ls: cannot access /usr/local/ispconfig/server/lib/: No such file or directory
    
    Führe ich das ganze vielleicht mit falschen rechten aus? Es existiert ja ein Unterschied zwischen su und sudo soweit ich weiß...
    Danke.
     
  4. Till

    Till Administrator

    Du kannst den installer nicht mit su oder sudo ausführen, Du musst root User sein wie für alle sysadmin Sachen. Ruf also auf:

    sudo su -

    dann gib das Passwort ein damit Du root User bist. Und danach kannst Du erst das update script aufrufen.
     
  5. Falcon37

    Falcon37 New Member

    Ich weiß, ist ja logisch - bin ja als root, das war nur eine Vermutung da dieses dollar $ bei anderen System nicht da ist bzw. mir noch nicht so aufgefallen ist:
    Code:
    (root@server1)-(~) $ sudo su -
    bash: sudo: command not found
    (root@server1)-(~) $ sudo su
    bash: sudo: command not found
    (root@server1)-(~) $ sudo su
    bash: sudo: command not found
    (root@server1)-(~) $ sudo
    bash: sudo: command not found
    (root@server1)-(~) $ sudo
    bash: sudo: command not found
    (root@server1)-(~) $ su -
    (root@server1)-(~) $ su
    (root@server1)-(~) $
    die Befehle bringen nix, denke daher das ich wie immer als root angemeldet bin...
     
    Zuletzt bearbeitet: 1. Apr. 2009
  6. Till

    Till Administrator

    Ok. dann poste mal die Ausgabe von:

    ls -la /usr/local/ispconfig/
     
  7. Falcon37

    Falcon37 New Member

    Okay
    Code:
    $ ls -la /usr/local/ispconfig/
    ls: cannot access /usr/local/ispconfig/: No such file or directory
    
     
  8. Falcon37

    Falcon37 New Member

    Super, es geht!! Danke für den mal wieder excellenten Support, Till! :D
    Lag an dem Hostname, ist aber eine etwas längere Geschichte..

    Nun habe ich aber wieder ein .htaccess Problem, läuft nicht, auch nicht die von "Grundauf" drauf sind wie z.B. die für /stats bekommen immer Fehler 500 zurück, der Trick das ganze einfach auf 755 zu stellen wie in diesem Post von dir beschrieben geht leider nicht....
     
  9. Till

    Till Administrator

    Schau bitte ins error log der webseite, da steht der exakte Fehler.
     
  10. Falcon37

    Falcon37 New Member

    Ok. In der error.log steht dies andauern:
    Code:
    [Thu Apr 02 06:33:17 2009] [crit] [client XX.XXX.XX.XXX] (13)Permission denied: /var/www/clients/client0/web2/web/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer:
    Irgendwie hat sich bei ISPConfig 3 wieder was geändert, "früher" in der ersten RC2 Version ging das - kann es sein das ich das wieder erst in die Apache Derektive kopieren muss? Blick da annehmlich leider nicht ganz durch. Eigentlich ist mein Vorhaben nur ein vBulletin mit vBSEO zu installieren, das klappt auch alles aber bei der .htaccess gibts eben Probleme, exakt das gleiche ging in RC2 aber ohne Probleme. So sieht die .htaccess aus:
    Code:
    # Comment the following line (add '#' at the beginning)
    # to disable mod_rewrite functions.
    # Please note: you still need to disable the hack in
    # the vBSEO control panel to stop url rewrites.
    RewriteEngine On
    
    # Some servers require the Rewritebase directive to be
    # enabled (remove '#' at the beginning to activate)
    # Please note: when enabled, you must include the path
    # to your root vB folder (i.e. RewriteBase /forums/)
    #RewriteBase /
    
    #RewriteCond %{HTTP_HOST} !^www\.yourdomain\.com
    #RewriteRule (.*) http://www.yourdomain.com/forums/$1 [L,R=301]
    
    RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]
    
    RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron)
    RewriteRule ^((archive/)?(.*\.php(/.*)?)?)$ vbseo.php [L,QSA]
    
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !^(admincp|modcp|clientscript|cpstyles|images)/
    RewriteRule ^(.+)$ vbseo.php [L,QSA]
    
    Wenn ich das ins direktiven feld kopiere läuft's leider auch nicht.
     
  11. Till

    Till Administrator

    Laut Fehlermeldung ist im Moment nicht der Inhalt der datei das Problem sondern die Rechte. Apache sagt dass er die datei nicht lesen kann.
     
  12. Falcon37

    Falcon37 New Member

    Die Rechte sind 644, habe einen Verzeichnischutz erstellt, da kann er lesen und es klappt. Muss irgendwas beachtet werden bei der Anwendung von vBSEO? Liegt es an den Apache Derektive? Warum hat das in der RC2 geklappt? :(

    thx

    Edit:


    So vielen dank habe es :=)
    Einfach den kompletten inhalt in die apache derektiven machen und .htacces komplett löschen und nicht aufm server lassen. wahrscheinlich gab's das einfach so noch nicht in RC2, aber in ISPConfig 2 natürlich.
     
    Zuletzt bearbeitet: 2. Apr. 2009
  13. Till

    Till Administrator

    Ich denke dass eine Rechteänderung auf 755 auch gereicht hätte.
     
  14. Falcon37

    Falcon37 New Member

    Leider nicht, habe es versucht, geht anscheinend nicht bei jedem.
    Bei vBSEO geht es so ohne Problem sehr gut, bei Word Press ist die Sache leider wieder etwas anders. Wenn man aus ?p=123 das 2009/04/02/sample-post/ machen will und die von mir oben beschriebenen Methode verwendet geht es nur zum kleinen Teil, die main lässt sich aufrufen mehr aber nicht :(
    755 geht leider nicht. Wer eine Lösung bzw. Vorschlag hat, wäre recht wichtig...
     
    Zuletzt bearbeitet: 2. Apr. 2009
  15. Falcon37

    Falcon37 New Member

    Möchte nur kurz die Lösung des Problems linken für alle die ggf. das gleiche bzw. ein ähnliches Problem haben: http://www.howtoforge.de/forum/showpost.php?p=10022&postcount=8

    Worans genau lag siehe auch den gelinkten Thread.
     

Diese Seite empfehlen