Problem mit Firewall-Settings

#1
Hallo,

ich habe mit dem ISPConfig (2.2.18) Userinterface entsprechend Dokumentation eine neue Firewall-Regel angelegt (UDP) und wollte dabei einen Portbereich angeben. Bei 4-stelligen Ports (Bsp: 2433:2438) klappt das auch hervorragend. Bei 5-stelligen Ports (Bsp 23100:23120 ) wird die letzte Zigger abgeschnitten und damit die Firewall nicht korrekt konfiguriert. Auch /etc/init.d/bastille-firewall status zeigt dann den falschen Wert an.

Bin ich mit dem Doppelpunkt als Bereichskennzeichnen auf dem falschen Dampfer? Oder gibt es da irgendein Längen-Problem mit den Skripten?

Grüße
Frank
 

Till

Administrator
#2
Setz mal bitte den Feldtyp von vharchar(10) auf z.B. varchar(20) des Feldes dienst_port in der Tabelle isp_firewall der ISPConfig Datenbank.
 
#3
Firewall-Settings - gelöst

Hallo Till,

klasse, das hat sofort funktioniert. Vielen Dank.

Packst Du den Patch auch in die Quellen oder ist er bereits drin?

Grüße
Frank
 

Werbung

Top