Probleme bei der Installation

#1
Hallo, ich wechsel gerade von Froxlor auf ispconfig und habe leider Probleme bei der Installation.
Ich nutze einen vServer mit Debian 7.9.
Folgende Anleitung nutze ich:
Code:
https://www.howtoforge.com/tutorial/ispconfig-install-script-debian/
Leider werden einige Fehler bei der Installation angezeigt … und nun hängt er bei der SQL Installation fest … es fehlt etwas und ich bin überfragt wie ich diese behebe!?
Code:
root@web:/tmp/ispconfig_setup-master# ./install.sh
Checking your system, please wait...
./install.sh: line 48: /tmp/ispconfig_setup-master/distros/debian7/askquestions_multiserver.sh: No such file or directory
Welcome to ISPConfig Setup Script v.2.0.2
This software is developed by Temporini Matteo
with the support of the community.
You can visit my website at the followings URLS
http://www.servisys.it http://www.temporini.net
and contact me with the following information
contact email/hangout: temporini.matteo@gmail.com
skype: matteo.temporini
=========================================
ISPConfig 3 System installer
=========================================
This script will do a nearly unattended intallation of
all software needed to run ISPConfig 3.
When this script starts running, it'll keep going all the way
So before you continue, please make sure the following checklist is ok:
- This is a clean standard clean installation for supported systems
- Internet connection is working properly
The detected Linux Distribution is:  Debian GNU/Linux 7 (wheezy)
Is this correct? (y/n)y
Checking internet connection...
OK
./install.sh: line 119: [: ==: unary operator expected
./install.sh: line 122: AskQuestionsMultiserver: command not found
Updating apt and upgrading currently installed packages... done
Installing basic packages... Reconfigure dash done
Installing mysql...
Nun habe ich den Debian Server noch einmal frisch aufgesetzt.

Am Einfachsten und schnellsten wäre es wenn mir jemand von den ispconfig Profis ispconfig via ssh installiert!?
 
#3
Vielen Dank für den Link mit der Anleitung

bis 12 lief alles nach Plan, dann die erste Meldung:

Code:
root@web:/# apt-get install apache2 apache2.2-common apache2-doc apache2-mpm-prefork apache2-utils libexpat1 ssl-cert libapache2-mod-php5 php5 php5-common php5-gd php5-mysql php5-imap phpmyadmin php5-cli php5-cgi libapache2-mod-fcgid apache2-suexec php-pear php-auth php5-mcrypt mcrypt php5-imagick imagemagick libapache2-mod-suphp libruby libapache2-mod-ruby libapache2-mod-python php5-curl php5-intl php5-memcache php5-memcached php5-ming php5-ps php5-pspell php5-recode php5-snmp php5-sqlite php5-tidy php5-xmlrpc php5-xsl memcached
Reading package lists... Done
Building dependency tree      
Reading state information... Done
libapache2-mod-php5 is already the newest version.
libapache2-mod-php5 set to manually installed.
php5 is already the newest version.
php5-cli is already the newest version.
php5-cli set to manually installed.
php5-common is already the newest version.
php5-common set to manually installed.
apache2-mpm-prefork is already the newest version.
apache2-mpm-prefork set to manually installed.
apache2-utils is already the newest version.
apache2-utils set to manually installed.
apache2.2-common is already the newest version.
apache2.2-common set to manually installed.
libexpat1 is already the newest version.
libexpat1 set to manually installed.
ssl-cert is already the newest version.
ssl-cert set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
php5-memcached : Depends: libmemcached11 but it is not installable
php5-ming : Depends: phpapi-20100525
php5-ps : Depends: phpapi-20100525
E: Unable to correct problems, you have held broken packages.
 

Till

Administrator
#4
Ruf mal auf:

apt-get update

und dann nochmal:

apt-get install apache2 apache2.2-common apache2-doc apache2-mpm-prefork apache2-utils libexpat1 ssl-cert libapache2-mod-php5 php5 php5-common php5-gd php5-mysql php5-imap phpmyadmin php5-cli php5-cgi libapache2-mod-fcgid apache2-suexec php-pear php-auth php5-mcrypt mcrypt php5-imagick imagemagick libapache2-mod-suphp libruby libapache2-mod-ruby libapache2-mod-python php5-curl php5-intl php5-memcache php5-memcached php5-ming php5-ps php5-pspell php5-recode php5-snmp php5-sqlite php5-tidy php5-xmlrpc php5-xsl memcached
 

Till

Administrator
#5
Ersetz mal die /etc/apt/sources.list Datei Deines Servers mit der aus dem tutorial (schritt 7), dann apt-get update und nochmal versuchen die Pakete zu installieren. Es kann sein dass Dein Server anbieter keine vollständige sources.list die auch contrib pakete enthält vorinstalliert hat.
 
#6
Ok ... das werde ich machen
ich habe gerade entdeckt das meine
/etc/network/interfaces
ganz anders aussieht!?

Code:
# This configuration file is auto-generated.
#
# WARNING: Do not edit this file, your changes will be lost.
# Please create/edit /etc/network/interfaces.head and
# /etc/network/interfaces.tail instead, their contents will be
# inserted at the beginning and at the end of this file, respectively.
#
# NOTE: it is NOT guaranteed that the contents of /etc/network/interfaces.tail
# will be at the very end of this file.
#

# Auto generated lo interface
auto lo
iface lo inet loopback

# Auto generated venet0 interface
auto venet0
iface venet0 inet manual
        up ifconfig venet0 up
        up ifconfig venet0 127.0.0.2
        up route add default dev venet0
        down route del default dev venet0
        down ifconfig venet0 down


iface venet0 inet6 manual
        up route -A inet6 add default dev venet0
        down route -A inet6 del default dev venet0

auto venet0:0
iface venet0:0 inet static
        address 62.108.41.179
        netmask 255.255.255.255
 

Till

Administrator
#8
Das liegt daran dass Du einen vserver hast und das Tutorial auf einem root server geschrieben wurde. Deine interfaces Datei ist aber so ok, da brauchst Du nichts ändern. venet interfaces sind von der Virtualisierungssoftware virtuozzo bzw. openvz.
 
#10
So ich habe die source.list ausgetauscht

Nun sieht es so aus!?

Code:
root@web:/# apt-get install apache2 apache2.2-common apache2-doc apache2-mpm-prefork apache2-utils libexpat1 ssl-cert libapache2-mod-php5 php5 php5-common php5-gd php5-mysql php5-imap phpmyadmin php5-cli php5-cgi libapache2-mod-fcgid apache2-suexec php-pear php-auth php5-mcrypt mcrypt php5-imagick imagemagick libapache2-mod-suphp libruby libapache2-mod-ruby libapache2-mod-python php5-curl php5-intl php5-memcache php5-memcached php5-ming php5-ps php5-pspell php5-recode php5-snmp php5-sqlite php5-tidy php5-xmlrpc php5-xsl memcached
Reading package lists... Done
Building dependency tree      
Reading state information... Done
apache2-mpm-prefork is already the newest version.
apache2-mpm-prefork set to manually installed.
apache2-utils is already the newest version.
apache2-utils set to manually installed.
apache2.2-common is already the newest version.
apache2.2-common set to manually installed.
libexpat1 is already the newest version.
libexpat1 set to manually installed.
ssl-cert is already the newest version.
ssl-cert set to manually installed.
php5-common is already the newest version.
php5-common set to manually installed.
php5-cli is already the newest version.
php5-cli set to manually installed.
libapache2-mod-php5 is already the newest version.
libapache2-mod-php5 set to manually installed.
php5 is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
php5-cgi : Depends: php5-common (= 5.4.45-0+deb7u2) but 5.6.19-1~dotdeb+7.1 is to be installed
php5-curl : Depends: php5-common (= 5.4.45-0+deb7u2) but 5.6.19-1~dotdeb+7.1 is to be installed
php5-gd : Depends: php5-common (= 5.4.45-0+deb7u2) but 5.6.19-1~dotdeb+7.1 is to be installed
php5-imap : Depends: php5-common (= 5.4.45-0+deb7u2) but 5.6.19-1~dotdeb+7.1 is to be installed
php5-intl : Depends: php5-common (= 5.4.45-0+deb7u2) but 5.6.19-1~dotdeb+7.1 is to be installed
php5-mcrypt : Depends: php5-common (= 5.4.45-0+deb7u2) but 5.6.19-1~dotdeb+7.1 is to be installed
php5-mysql : Depends: php5-common (= 5.4.45-0+deb7u2) but 5.6.19-1~dotdeb+7.1 is to be installed
php5-pspell : Depends: php5-common (= 5.4.45-0+deb7u2) but 5.6.19-1~dotdeb+7.1 is to be installed
php5-recode : Depends: php5-common (= 5.4.45-0+deb7u2) but 5.6.19-1~dotdeb+7.1 is to be installed
php5-snmp : Depends: php5-common (= 5.4.45-0+deb7u2) but 5.6.19-1~dotdeb+7.1 is to be installed
php5-sqlite : Depends: php5-common (= 5.4.45-0+deb7u2) but 5.6.19-1~dotdeb+7.1 is to be installed
php5-tidy : Depends: php5-common (= 5.4.45-0+deb7u2) but 5.6.19-1~dotdeb+7.1 is to be installed
php5-xmlrpc : Depends: php5-common (= 5.4.45-0+deb7u2) but 5.6.19-1~dotdeb+7.1 is to be installed
php5-xsl : Depends: php5-common (= 5.4.45-0+deb7u2) but 5.6.19-1~dotdeb+7.1 is to be installed
E: Unable to correct problems, you have held broken packages.
 

Till

Administrator
#11
Wie kommt denn da dotdeb rein, das ist kein standed debian repository und auch nicht bestandteil der sources.list des tutorials. Hast Du da dotdeb selbst eingebunden oder liefert Dein ISP so ein non standrad basis system aus?
 
#13
Bei quotacheck -avugm kommt folgendes

Code:
root@web:/# quotacheck -avugm
quotacheck: Cannot find filesystem to check or filesystem not mounted with quota option.
 
#15
Und das nächste problem beim Jailkit

Code:
root@web:/tmp# cd jailkit-2.17
root@web:/tmp/jailkit-2.17# ./debian/rules binarycd ..
make: *** No rule to make target `binarycd'.  Stop.
root@web:/tmp/jailkit-2.17# dpkg -i jailkit_2.17-1_*.deb
dpkg: error processing jailkit_2.17-1_*.deb (--install):
cannot access archive: No such file or directory
Errors were encountered while processing:
jailkit_2.17-1_*.deb
root@web:/tmp/jailkit-2.17# rm -rf jailkit-2.17*
root@web:/tmp/jailkit-2.17#
 
#19
Noch ein Nachtrag zum Problem mit den Mails ...

bei SquirrelMail kann ich mich auch mit keiner E-Mail Adresse einloggen ... also Benutzer: xxx@xxx.de und Pass: das vergebe bei der Einrichtung der E-Mail Adresse

Oder bin ich jetzt komplett verkehrt?
 

Werbung

Top