Probleme mit Let´s Encrypt Zertifikat

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von jmzbeki, 19. Apr. 2016.

  1. jmzbeki

    jmzbeki Member

    Moin,
    ich habe erfolgreich 4 Domains mit Let´s Encrypt Zertifikat erstellt. Alles soweit gut, als ich aber die 5. Domain genauso erstellt habe wie die vorigen 4., wurde kein zertifikat mehr ausgestellt und es ist auch keine verlinkung in dem ssl ordner vorhanden, bei den anderen schon.
    Ich habe im Grunde nix anderen gemacht bei dem erstellen eines Websiten-Ordners.

    Nun meine Frage, wie kann ich dieses Problem lösen? Hat jmd evtl. einen ähnlichen Fehler(wenn das überhaupt einer ist)??

    VG Janek
     
  2. Till

    Till Administrator

    Wie hast Du denn die Zertifikate erstellt? ISPConfig stable unterstützt noch kein letsencrypt, erst die nächste version 3.1 die noch nicht released ist hat letsencrypt support.
     
  3. jmzbeki

    jmzbeki Member

  4. robotto7831a

    robotto7831a Member

    Ich meine gelesen zu haben, dass man von einer IP nur eine bestimmte Anzahl an Zertifikaten in einem bestimmten Zeitraum anfordern kann.
     
  5. jmzbeki

    jmzbeki Member

    ein guter hinweis! ich werde dies gleich mal ausprobieren, danke.
    aber die frage die sich mir stellt ist, wenn ich mehrere private webseiten habe die nur auf einer ip laufen, dann ist das irgendwie kontraproduktiv, oder??
     
  6. jmzbeki

    jmzbeki Member

    Okey habe 2 weitere ip´s hinzugefügt und eine ip auf die domain hinzugefügt, irgendwie bekomme ich nur den apache bildschirm zu sehen.
    Habe unter ISPconfig Server IP Adressen die 2 IP´s hinzugefügt und dann noch einmal eine neue Webseite erstellt, hat leider nicht ganz so geklappt.
    Reicht es nicht die IP wie oben beschrieben zu ISPconfig hinzuzufügen?? Habe das früher so gemacht und hat eigtl funktioniert.

    nachtrag#. die ip ist wenn ich sie anpinge "Destination Host Unreachable"?
     
    Zuletzt bearbeitet: 19. Apr. 2016
  7. Till

    Till Administrator

    Du musst Die IP auch in der Netwerkkarten Konfigurationsdatei hinzufügen.
     
  8. robotto7831a

    robotto7831a Member

    Nein, Du hast mich falsch verstanden. Es geht nicht um die IP der Webseite sondern vom Server.

    Um Missbrauch der Zertifikate für Spam und Co zu vermeiden, kann man innerhalb eines bestimmten Zeitraumes nur x Zertifikate ausstellen lassen. Danach muss man warten und kann wieder x Zertifikate ausstellen lassen.

    https://community.letsencrypt.org/t/rate-limits-for-lets-encrypt/6769
     
  9. jmzbeki

    jmzbeki Member

    stimmt, in /etc/network/interfaces....
    so sieht es grad bei mir aus

    # The loopback network interface
    auto lo
    iface lo inet loopback

    # The primary network interface
    allow-hotplug eth0
    iface eth0 inet static
    address 8x.xxx.xxx.xx1
    netmask 255.255.255.0
    network 8x.xxx.xxx.0
    broadcast 8x.xxx.xxx.255
    gateway 8x.xx.xxx.1
    # dns-* options are implemented by the resolvconf package, if installed
    dns-nameservers 208.67.222.222
    dns-search xx101.de

    Also muss dann

    iface eht0:0 inet static
    address 8x.xxx.xxx.xx2
    usw.....???

    nachtrag: alles so eingetragen der ping funktioniert, heißt ich bekomme was zurück, aber ich habe immer noch das problem das die webseite, der ich die ip zugeordnet habe immer noch die default page anzeigt. kann es an der dns liegen die sich bis zu 48h im cache befindet??
     
    Zuletzt bearbeitet: 19. Apr. 2016
  10. jmzbeki

    jmzbeki Member

    ahhh sooooo....... na klasse, muss ich wohl bis nächste woche warten :(:D
     
  11. jmzbeki

    jmzbeki Member

    Soo, hat sich alles aufgelöst.
    Folgendes gemacht, habe zusätzliche IP´s zu ISPconfig hinzugefügt, Webseiten auf die hinzugefügten IP´s verwiesen und schon hat Let´s Encrypt neue Zertifikate erstellt.
    Leider muss man einige stunden warten bis der DNS cache neu geladen wurde, aber dann würden die Webseiten korrekt angezeigt.
    Vielen Dank für Eure Tips
     

Diese Seite empfehlen