Proftp reagiert sehr langsam.

Dieses Thema im Forum "Server Administration" wurde erstellt von PierreR32, 2. Nov. 2007.

  1. PierreR32

    PierreR32 Member

    Hallo Leute,

    leider habe ich auf verschiedenen Servern das problem das der Proftp teilweise sehr lange braucht bis er eine Verbindung zulässt.
    Das zeigt sich auch im DirectoryListing was schonmal 10sek dauern kann bis da was erscheint.

    Woran könnte das liegen ?

    gruß
    Pierre
     
  2. planet_fox

    planet_fox Super-Moderator

    Hi Pierre,

    Ich hab das auch schon gehabt aber weiss nicht mehr wie ich das gelösst hab. Versuch mal hier das in deine Proftpd confrig einzu fügen

    Code:
    UseReverseDNS off 
    wenn till ned schneller is schau ich heute abend noch in meine config was ich da rein geschrieben hab ansonsten schau mal auf http://www.proftpd.de/Standard-Deluxe.57.0.html

    Ich mein das das ein bekanntes Problem ist
     
  3. redi78

    redi78 Member

    und

    Code:
    IdentLookups off
     
  4. Cybertec

    Cybertec New Member

    Hallo!

    Sorry das ich den etwas älteren Thread wieder ausgrabe. Wusste nicht ob ich einen neuen dafür aufmachen soll.

    Also, das Problem ist eigentlich das gleiche wie das vom Threadstarter.

    Habe anfangs gar keine Verbindung zum per FTP bekommen, und wenn, dann nur nach ewig langer Ladezeit.

    Ich habe dann im ISP den FTP Server neu gestartet, was allerdings keine Auswirkungen hatte.
    Also habe ich den FTP Server dann per SSH neu gestartet.

    Mittlerweile geht es etwas schneller, aber das einwählen auf den Webspace dauert immer so zwischen 5-10 Sekunden.

    Weiß da jemand einen Rat was ich da machen kann?

    Vorher ging es die ganze Zeit ohne Probleme.

    Und letztens ist der FTP Server ohne Vorwarnung einfach abgestürzt.

    Ich hoffe es kann mir jemand helfen. ;)

    Gruß
     
  5. Till

    Till Administrator

    Füge bitte die beiden Konfigurationsdirektiven in der proftpd.ciónf hinzu, die in diesem Thread genannt sind und starte dann proftpd neu.
     
  6. Cybertec

    Cybertec New Member

    Die Datei proftp.conf liegt doch hier:

    /etc/proftp.conf


    Oder etwa nicht?

    Wenn ja, ist es normal das die Datei leer ist?
     
  7. Till

    Till Administrator

    Die proftpd.conf Datei liegt entweder in /etc/proftp.conf oder in /etc/proftpd/proftp.conf

    Wenn sie leer ist, dann ist proftpd nicht richtig installiert und Du solltest es nochmal installieren.
     
  8. Cybertec

    Cybertec New Member

    Warum sollte proftp nicht richtig installiert sein?

    Es geht doch alles, bis auf die Geschwindigkeit.

    Im ISPConfig steht das die Datei im Verzeichnis /etc/proftp.conf liegt, aber wahrscheinlich ist einfach nur die Pfadangabe falsch.

    Ich kuck mal.
     
  9. Till

    Till Administrator

    Proftpd funktioniert auch ohne Konfigurationsdatei, dann aber halt mit standardwerten, die nicht optimal sein müssen.
     
  10. Cybertec

    Cybertec New Member

    Also es geht ohne Fehler (ausser der Geschwindigkeit), aber halt mit den Standardwerten, wenn ich das richtig verstanden hab.

    Dann kann ich ja einfach die zwei Codes in die Datei schreiben und gut ist, oder?
     
  11. Till

    Till Administrator

    Ja, kannst Du mal versuchen.
     
  12. toca

    toca New Member

    bei mir besteht das gleiche Problem, beide befehle sind in der Config eingegeben und ich habe den FTP Server neugestartet.. ohne spürbare Auswirkungen. Bei der Installation gab es keine Probleme.
     
  13. Till

    Till Administrator

    Dann versuch mal die Direktiven in <global></global> tags zu setzen.
     
  14. toca

    toca New Member

    damit konnte er garnichtmehr starten, hab die befehle wieder entfernt und dann gings wieder.. aber eben natürlich nicht schneller.
     
  15. dexcom

    dexcom New Member

    Hallo toca,

    meine proftp.conf sieht wie folgt aus:

    Code:
    #
    # ServerIdent on/etc/proftpd.conf -- This is a basic ProFTPD configuration file.
    # To really apply changes reload proftpd after modifications.
    # 
    
    ServerName            "Debian"
    #ServerType            inetd
    ServerType            standalone
    DeferWelcome            on
    ServerIdent            on "-===== FTP Server Ready =====-" 
    
    MultilineRFC2228        on
    DefaultServer            on
    ShowSymlinks            on
    
    TimeoutNoTransfer        600
    TimeoutStalled            600
    TimeoutIdle            1200
    
    DisplayLogin                    welcome.msg
    DisplayFirstChdir               .message
    ListOptions                    "-l"
    
    DenyFilter            \*.*/
    
    # Uncomment this if you are using NIS or LDAP to retrieve passwords:
    #PersistentPasswd        off
    
    # Uncomment this if you would use TLS module:
    #TLSEngine             on
    
    # Uncomment this if you would use quota module:
    #Quotas                on
    
    # Uncomment this if you would use ratio module:
    #Ratios                on
    
    # Port 21 is the standard FTP port.
    Port                21
    
    # To prevent DoS attacks, set the maximum number of child processes
    # to 30.  If you need to allow more than 30 concurrent connections
    # at once, simply increase this value.  Note that this ONLY works
    # in standalone mode, in inetd mode you should use an inetd server
    # that allows you to limit maximum number of processes per service
    # (such as xinetd)
    MaxInstances            30
    
    # Set the user and group that the server normally runs at.
    User                nobody
    Group                nogroup
    
    # Umask 022 is a good standard umask to prevent new files and dirs
    # (second parm) from being group and world writable.
    #Umask                022  022
    Umask                022
    # Normally, we want files to be overwriteable.
    AllowOverwrite            on
    
    # Delay engine reduces impact of the so-called Timing Attack described in
    # http://security.lss.hr/index.php?page=details&ID=LSS-2004-10-02
    # It is on by default. 
    #DelayEngine             off
    
    # A basic anonymous configuration, no upload directories.
    
    # <Anonymous ~ftp>
    #   User                ftp
    #   Group                nogroup
    #   # We want clients to be able to login with "anonymous" as well as "ftp"
    #   UserAlias            anonymous ftp
    #   # Cosmetic changes, all files belongs to ftp user
    #   DirFakeUser    on ftp
    #   DirFakeGroup on ftp
    # 
    #   RequireValidShell        off
    # 
    #   # Limit the maximum number of anonymous logins
    #   MaxClients            10
    # 
    #   # We want 'welcome.msg' displayed at login, and '.message' displayed
    #   # in each newly chdired directory.
    #   DisplayLogin            welcome.msg
    #   DisplayFirstChdir        .message
    # 
    #   # Limit WRITE everywhere in the anonymous chroot
    #   <Directory *>
    #     <Limit WRITE>
    #       DenyAll
    #     </Limit>
    #   </Directory>
    # 
    #   # Uncomment this if you're brave.
    #   # <Directory incoming>
    #   #   # Umask 022 is a good standard umask to prevent new files and dirs
    #   #   # (second parm) from being group and world writable.
    #   #   Umask                022  022
    #   #            <Limit READ WRITE>
    #   #            DenyAll
    #   #            </Limit>
    #   #            <Limit STOR>
    #   #            AllowAll
    #   #            </Limit>
    #   # </Directory>
    # 
    # </Anonymous>
    
    # Eigene Ergänzungen
    DefaultRoot ~
    <global>
    IdentLookups off
    ListOptions -a
    AllowOverwrite on
    AllowRetrieveRestart on
    AllowStoreRestart on
    </global>
    
    # login nur von Mitgleidern der Gruppe ftpuser
    #<Limit LOGIN>
    #DenyGroup !ftpuser
    #</Limit>
    
    
    Include /etc/proftpd_ispconfig.conf
    
    Im unteren Abschnitt unter "# Eigene Ergänzungen" kannst Du global Parameter mit Deiner proftpd.conf vergleichen... Bei mir funzt das so...

    have fun

    dexcom
     
  16. Cybertec

    Cybertec New Member

    Ich hab jetzt mal die gleichen Ergänzungen reingeschrieben wie du dexcom, aber geändert hat sich nichts.

    Werd mal noch weiter probieren.
     
  17. toca

    toca New Member

    Danke,hat geholfen!

    Danke für das posten deiner Config, es gab zwar kleine unterschiede zu deiner Config, aber die Dinge die hinzugefügt werden mussten habe ich exakt so hinzugefügt wie es bei dir der Fall war, und ES FUNKTIONIERTE!! *g* danke, endlich geht der Login schnell von statten! Und wieder komme ich meinem Ziel ein Stückchen näher.. :p
     
  18. Clemens

    Clemens New Member

    Hallo zusammen,

    ich hatte auch das problem und habe dann alle Einträge von dexcom bei mir hinzugefügt. Doch nach Neustart von proftpd änderte sich nichts. Also habe ich die komplette conf reinkopiert und dann den proftpd neu gestartet. Und dann ging es superschnell. Es scheint auch an der Reihenfolge bestimmter Einträge zu liegen. Okay, mein FTP hat jetzt einen neuen Namen ;-), aber er wollte schon immer Debian heißen :D
     

Diese Seite empfehlen