PureFTP startet nicht

#1
Hallo,

erstm,al grosses dank für die Anleitung Lenny.
Hat soweit aucuh alles geklappt nur der FTP Server will sich nicht starten lassen.

Rest geht alles.
Wo könnte der Fehler liegen, habe die Schritte jetzt schon 3mal durch.-
Ist ein VServer von Strato, hängt es damit zusammen?
War komplett neues System drauf, keine Altlasten.
Danke euch für jede Hilfe.

h1637934:~# /etc/init.d/pure-ftpd-mysql start
Starting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -b -E -A -O clf:/var/log/pure-ftpd/transfer.log -u 1000 -B

so sieht es aus wenn Start, aber es erscheint kein ftp :(
 
Zuletzt bearbeitet:

Till

Administrator
#3
1) Check mal ob Du wirklich dass pureftpd-mysql Paket geladen ahst und nicht pureftpd ohne mysql.
2) Existiert der User des Webs, also web1, web2 usw (nicht zu verwechseln mit dem virtuellen FTP User). Welcher web User das in diesem Fall ist, kannst Du in der FTP User Tabelle in der ispconfig mysql db nachsehen.
 
#4
zu 1.) ja ist er, wird aber nochmal gegengecheckt
zu2 .) User ist angelegt, Verzeichniss ist angelegleg, in DB steht alles drin nur rein komme ich nicht
FTP sagt User okay, Passwort wrong :(
tata :(
Schreibe erweiterte Statusinformationen... Fertig
Wähle vormals abgewähltes Paket pure-ftpd-mysql.
(Lese Datenbank ... 40444 Dateien und Verzeichnisse sind derzeit installiert.)
Entpacke pure-ftpd-mysql (aus .../pure-ftpd-mysql_1.0.21-11.4_i386.deb) ...
Richte pure-ftpd-mysql ein (1.0.21-11.4) ...
chmod: Zugriff auf â/etc/pure-ftpd/db/mysql.confâ nicht möglich: Datei oder Verzeichnis nicht gefunden
Starting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -B
invoke-rc.d: initscript pure-ftpd-mysql, action "start" failed.
dpkg: Fehler beim Bearbeiten von pure-ftpd-mysql (--configure):
Unterprozess post-installation script gab den Fehlerwert 252 zurück
Fehler traten auf beim Bearbeiten von:
pure-ftpd-mysql
E: Sub-process /usr/bin/dpkg returned an error code (1)
Ein Paket konnte nicht installiert werden. Versuche zu lösen:
Richte pure-ftpd-mysql ein (1.0.21-11.4) ...
chmod: Zugriff auf â/etc/pure-ftpd/db/mysql.confâ nicht möglich: Datei oder Verzeichnis nicht gefunden
Starting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -B
invoke-rc.d: initscript pure-ftpd-mysql, action "start" failed.
dpkg: Fehler beim Bearbeiten von pure-ftpd-mysql (--configure):
Unterprozess post-installation script gab den Fehlerwert 252 zurück
Fehler traten auf beim Bearbeiten von:
pure-ftpd-mysql
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Lese Status-Informationen ein... Fertig
Lese erweiterte Statusinformationen

verdammte Hacke, nun bin ich genausoweit wie vorher
Packet selber gebastelt und nix geht :(
Manchmal könnte ich heulen, aber nur manchmal wenn das Bier alle ist :)
 
Zuletzt bearbeitet:

Till

Administrator
#7
Dann schreiube bitte mal "true" in die Datei /etc/pure-ftpd/conf/VerboseLog

Vielleicht haben die das in einer pureftpd Version geändert, bei mir geht es auch mit yes.
 

Till

Administrator
#12
Dann ist da irgend was schief gegangen. Entweder capabilities sind in dem neuen pureftp immer noch nicht ausgeschaltet oder aber das neue pureftpd hat das alte nicht überschrieben. Hattest Du pureftpd auch deinstalliert, bevor Du ihn neu gebaut hast?
 
#13
Habe das gleiche Problem.
FTP-Server und myDNS-Server gehen nicht.

Möchte mich aber ertsmal um das erste Problem kümmern - FTP-Server.

Debian 5 64bit mit ISPConfig 3.0.1.4.
Bin 2x nach Anleitung gegangen:
Der Perfekte Server - Debian Lenny (Debian 5.0) [ISPConfig 3]

Bei /etc/init.d/openbsd-inetd restart:
Restarting internet superserver: inetdNot starting internet superserver: no services enabled.
Bei /etc/init.d/pure-ftpd-mysql start:
: command not foundtpd-common: line 3:
: command not foundtpd-common: line 8:
: command not foundtpd-common: line 14:
: command not foundtpd-common: line 19:
: command not foundtpd-common: line 22:
 

Till

Administrator
#15
Du kannst da normale einfache Anführungszeichen nehmen (also die über #). Oder aber Du öffnest einfach die Datei /etc/pure-ftpd/conf/VerboseLog mit einem Editor Deiner Wahl, gibst das Wort yes ohne Anführungszeichen ein und speicherst sie.
 

planet_fox

Super-Moderator
#16
Code:
vps-horst:~# /etc/init.d/pure-ftpd-mysql restart
Restarting ftp server: /usr/sbin/pure-ftpd-wrapper: Invalid configuration file /etc/pure-ftpd/conf/VerboseLogyesecho: No corresponding directive
Also zwei Server Debian und bei beiden klappts nicht mit dem verbose, ich kann dir mal nen zugang schicken.Vielleicht siehst du den fehler dann.
 
#18
Ich habe folgenden Server auf einem Vserver installiert, und habe nun auch das problem, das PUREFTP nicht läuft.
Der Perfekte Server - Debian Lenny (Debian 5.0) [ISPConfig 3]



habe auch schon mal versucht aus den logs was zufinden, aber der scheint nichts zu loggen.

Bitte um hilfe
 

Werbung