RAID defekt?

#1
Hi,

habe gerade einen neuen Server installiert und ISPConfig 3 sagt mein RAID 1 wäre defekt. Der Server ist neu, deswegen wundert mich das doch sehr.

Server: server.domain.com (Redhat Unknown) ISPConfig 3.0.5.3

Status: critical (0 unbekannt, 0 Info, 0 Warnung, 1 kritisch, 0 Fehler)
in Ordnung:
Die Festplattenauslastung ist in Ordnung [mehr...]
Ihr Virenschutz ist in Ordnung. [mehr...]
Die E-Mail Wartenschlangenauslastung ist in Ordnung [mehr...]
Die Serverauslastung ist in Ordnung [mehr...]
Alle benötigten Dienste sind online [mehr...]
Das System Protokoll ist in Ordnung [mehr...]

kritisch:
Das RAID hat eine DEFEKTE Festplatte. Bitte schnellstmöglich ersetzen! [mehr...]
OS ist CentOS 6.5. RAID 1 wurde vom Support installiert. Beide Festplatten sind 1 TB groß.

Code:
Personalities : [raid1] 
md127 : active (auto-read-only) raid1 sda2[0]
      4196800 blocks super 1.1 [2/1] [U_]
      
md126 : active raid1 sda1[0]
      972558848 blocks super 1.0 [2/1] [U_]
      
unused devices:
Kann ich das irgendwie genauer überprüfen? Hatte bis jetzt nur Hardware RAIDs.

Danke.
 
#3
Hier meine Ausgabe:

Code:
[user@server ~]# cat /proc/mdstat
Personalities : [raid1]
md127 : active (auto-read-only) raid1 sda2[0]
      4196800 blocks super 1.1 [2/1] [U_]

md126 : active raid1 sda1[0]
      972558848 blocks super 1.0 [2/1] [U_]

unused devices: <none>

[user@server ~]# df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/md126      913G  683G  185G  79% /
tmpfs           3.9G     0  3.9G   0% /dev/shm
Das ist aber sehr komisch, leider kann ich nicht nachvollziehen was der Support da gemacht hat, den ich finde keinen Log.

Hier mal die SMART-Werte, ggf. kann damit ja jemand was anfangen. Wie gesagt, eig sollte das ein RAID 1 sein. HDD Smart Results - Pastebin.com

Ist die Anleitung von Anfang 2007 heute noch aktuell? HowtoForge Linux Tutorials » Eine ausgefallene Festplatte in einem Software RAID1 Array ersetzen

Ich weiß jetzt gar nicht was ich jetzt tun soll. Ich werde mich mal schlau machen und überlegen, neu installieren geht leider nicht da der Server schon aktiv verwendet wird.
 
#4
RAID 5 korrekt eingerichtet?

Habe gerade mein erstes RAID 5 selbst eingerichtet. Da ich leider nirgends ein Tutorial dazu gefunden habe, musste ich's mir irgendwie zusammen suchen. Hat fast 6 Stunden gedauert. :D

Ich wollte fragen ob mein Plan funktioniert hat? Ist mit dem RAID alles ok?

Code:
root@localhost:~# cat /proc/mdstat
Personalities : [raid6] [raid5] [raid4]
md3 : active raid5 sda5[0] sdd5[3] sdc5[2] sdb5[1]
      2911723008 blocks super 1.2 level 5, 512k chunk, algorithm 2 [4/4] [UUUU]

md2 : active (auto-read-only) raid5 sda3[0] sdd3[3] sdc3[2] sdb3[1]
      11712000 blocks super 1.2 level 5, 512k chunk, algorithm 2 [4/4] [UUUU]

md1 : active raid5 sda2[0] sdd2[3] sdc2[2] sdb2[1]
      5853696 blocks super 1.2 level 5, 512k chunk, algorithm 2 [4/4] [UUUU]

md0 : active raid5 sda1[0] sdd1[3] sdc1[2] sdb1[1]
      582144 blocks super 1.2 level 5, 512k chunk, algorithm 2 [4/4] [UUUU]
Das soll ein RAID 5 bestehend aus 4 x 1 TB Festplatten sein.

Volle Version hier: 5324532487834794564345634 - Pastebin.com
 

Werbung

Top