Remote Mysql INSERT geht nicht

#1
Hallo,

ach ja, setze ISPConfig 3 ein

hatte ja vor einiger Zeit schon mal geschrieben, das bei mir immer keine Remote User angelegt werden. Also damit meine ich, es wird niemals ein Universal User angelegt.
Daher mache ich das per Hand. Nun habe ich aber das Problem, dass ich dabei bin ein Programm zu schreiben in Java bzw. Scala und möchte gerne ein Insert ausführen. Jedoch erhalte ich einfach keinen Zugriff darauf. Habe das nun x mal versucht. Lesen kann ich, aber schreiben geht nicht. Auch nicht mit anderen tools wie MySQL Workbench oder ähnlichen. Was kann da falsch sein????

Vielen Dank
 
#7
Sehr komisch, da steht das nicht. Hatte ich auch gedacht, aber da steht nur: Support
Nachricht senden
Nachricht ansehen

Irgendwas läuft da falsch, sehr komisch.

André
 

Till

Administrator
#8
In ganz alten Versionen stand das da auch noch nicht. Ruf bitte den folgenden Befehl auf der Shell auf und aktualisiere ISPConfig:

ispconfig_update.sh
 

Till

Administrator
#10
Ok. Du hast also eine sehr alte Version, die solltest Du auf jeden Fall updaten um Dein problem zu beheben.

Vermutlich hast Du ein Verzeichnis /root/ispconfig oder /home/admispconfug anglegt. Das erkennt der Installer als ISPConfig 2 Installation. Entferne die Verzeichnisse und starte den Updater erneut.
 
#11
okay habe admispconfig im home verzeichnisch gelöscht. Danach funktionierte das Update. Nun habe ich die neuste Version.

Nun bin ich echt zu dämlich. Habe mich gerade angemeldet (richtig) und er lässt mich nicht in die Oberfläche.

Ich bin verwirrt.

Lieben Gruß

André
 
#13
nein keine neuen Spalten. Ich habe nur damit ich extern zugreifen konnte Einträge dupliziert und mit % eingestellt.

Neue Sachen in die Datenbank von ISPConfig habe ich nichts.

André
 
#15
Die Datenbank dbispconfig hat 52 Tabelle und in denen ist auch einiges drinne ich habe mir mal sys_users angesehen und da sind auch alle User drinne.

Danke dir

André
 

Till

Administrator
#16
Hast Du auch Deinen Browser zu gemacht nach dem Update und ganz neu auf. Einzelnes Tab zumachen reicht nciht. Sonst kann es sein dass deine Session hängt.
 
#17
Jupp habe ich auch. Ich habe sogar einen ganz anderen Browser genutzt. Leider hat es auch nichts gebracht. :( Habe mich auch mit einem anderen User angemeldet.

Ach ja der Remote zugriff funktioniert :)

André
 
#19
Ja habe auf stable (voreingestellt) geupdated. Und die sys_session ist auch da, es sind auch drei Einträge drinne. Ich kann diese auch gerne leeren wenn das hilft.

André
 

Till

Administrator
#20
Das ist soweit ok, insbesondere auch, dass da 3 session drin stehen. was bedeutet dass die mysql Anbindung auch zu funktionieren scheint.

Was passiert denn genau, wenn Du versuchst Dich einzuloggen? Versuch bitte auch mal einen reload der seite bzw. den browser cache zu leeren.
 

Werbung

Top