Sämtliche Zertifikate erneuern

#1
Hallo,

ich hab bei den Zertifikaten wohl teilweise etwas falsch gemacht: Die sind nicht auf meine Domain sondern auf localhost ausgestellt.

Daher wollte ich alle Zertifikate noch einmal erstellen und nicht mehr die Standard-Werte einsetzen, sondern eigene Werte.

(Das Problem mit den Zertifikaten trifft mich zum Beispiel beim IMAP im Thunderbird; da meckert mein Thunderbird immer rum, dass das Zertifikat warscheinlich nicht stimmt, weil es auf localhost ausgestellt ist.)

Geändert hab ich zwar eigentlich schon die courier Zertifikate:
  • Code:
    # [B]vim /etc/courier/imapd.cnf[/B]
    RANDFILE = /usr/lib/courier/imapd.rand

    [ req ]
    default_bits = 1024
    encrypt_key = yes
    distinguished_name = req_dn
    x509_extensions = cert_type
    prompt = no

    [ req_dn ]
    C=DE
    ST=BLANK
    L=BLANK
    O=Courier Mail Server
    OU=Automatically-generated IMAP SSL key
    CN=meinedomain.de
    emailAddress=admin@meinedomain.de

    [ cert_type ]
    nsCertType = server
  • Code:
    # [B]vim /etc/courier/pop3d.cnf[/B]
    RANDFILE = /usr/lib/courier/pop3d.rand

    [ req ]
    default_bits = 1024
    encrypt_key = yes
    distinguished_name = req_dn
    x509_extensions = cert_type
    prompt = no

    [ req_dn ]
    C=DE
    ST=BLANK
    L=BLANK
    O=Courier Mail Server
    OU=Automatically-generated POP3 SSL key
    CN=meinedomain.de
    emailAddress=admin@meinedomain.de

    [ cert_type ]
    nsCertType = server
  • Code:
    # [B]rm /usr/lib/courier/imapd.pem[/B]
    # [B]rm /usr/lib/courier/pop3d.pem[/B]
    # [B]mkpop3dcert[/B]
    # [B]mkimapdcert[/B]
Aber ich hatte mindestens noch ein Zertifikat bei der Installation von ISPConfig erstellt und auch noch eins während des Perfect Setup Howtos.

Wie änder ich die Zertifikate, bzw. wie erstelle ich sie neu? Wo liegen sie?

[EDIT]
UNd dann macht mich noch stutzig, dass nachdem ich wie oben beschrieben, die beiden Zertifikate (für POP3 und IMAP) neu erstellt hab, ich zwar ein neues Zertifikat im Thunderbird bekomme, aber zum einen das Ausstelldatum nicht stimmt und zum anderen der Fingerprint nicht überinstimmt...
 
Zuletzt bearbeitet:
#5
Hab jetzt auch das Zertifikat wie im Perfect Setup beschrieben noch einmal erstellt:
Code:
# [B]rm /etc/postfix/ssl/*[/B]
# [B]cd /etc/postfix/ssl/[/B]
# [B]openssl genrsa -des3 -rand /etc/hosts -out smtpd.key 1024[/B]
# [B]chmod 600 smtpd.key[/B]
# [B]openssl req -new -key smtpd.key -out smtpd.csr[/B]
# [B]openssl x509 -req -days 3650 -in smtpd.csr -signkey smtpd.key -out smtpd.crt[/B]
# [B]openssl rsa -in smtpd.key -out smtpd.key.unencrypted[/B]
# [B]mv -f smtpd.key.unencrypted smtpd.key[/B]
# [B]openssl req -new -x509 -extensions v3_ca -keyout cakey.pem -out cacert.pem -days 3650[/B]
Allerdings ist das Zertifikat, was mir im Thunderbird angezeigt wird, immer noch von localhost.
Ich hab auch den Server einmal ganz neu durchgestartet - trotzdem bleibt das alte Zertifikat bzw. eins von localhost.

Allerdings seh ich auch grad, da steht, das man mit diesen Schritten ein TLS Zertifikat erstellt - ist das das gleiche was im Thunderbird bei SSL Verbindung angezeigt wird? Bzw. wo wird das geändert? Das courier-Zertifikat, wie oben beschrieben, hat ja auch nix gebracht.

Ich hab immer noch das Problem, das Thunderbird mich immer nach ner Bestätigung des Zertifikats fragt - genau das gleiche Problem wie das hier.
 

Werbung