Server Standort Wechsel | IP Änderung | Mailprobleme

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von redi78, 14. Dez. 2009.

  1. redi78

    redi78 Member

    Hallo Leute,

    ich habe am Wochenende den Server übersiedelt und eine neue statische IP erhalten. Seit dem kann ich mit meinem Laptop, wenn ich im LAN hänge nur mit der internen IP 192.168.1.99 Emails vom Server empfangen bzw. versenden. Wenn ich in den Konteneinstellungen den hostnamen server.blasmusikforum.at eintrage, erhalte ich eine Zeitüberschreitungsmeldung. Woran kann das liegen?

    main.cf:
    Code:
    root@server:~# postconf -n
    alias_database = hash:/etc/aliases
    alias_maps = hash:/etc/aliases
    append_dot_mydomain = no
    biff = no
    body_checks = regexp:/etc/postfix/body_checks
    broken_sasl_auth_clients = yes
    config_directory = /etc/postfix
    content_filter = amavis:[127.0.0.1]:10024
    header_checks = regexp:/etc/postfix/header_checks
    html_directory = /usr/share/doc/postfix/html
    inet_interfaces = all
    mailbox_size_limit = 0
    message_size_limit = 0
    mime_header_checks = regexp:/etc/postfix/mime_header_checks
    mydestination = server.blasmusikforum.at, localhost, localhost.localdomain
    myhostname = server.blasmusikforum.at
    mynetworks = 127.0.0.0/8 [::1]/128
    myorigin = /etc/mailname
    nested_header_checks = regexp:/etc/postfix/nested_header_checks
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
    readme_directory = /usr/share/doc/postfix
    receive_override_options = no_address_mappings
    recipient_delimiter = +
    relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
    relayhost =
    smtp_sasl_auth_enable = yes
    smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
    smtp_sasl_security_options =
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    smtpd_tls_security_level = may
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtpd_use_tls = yes
    transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
    virtual_alias_domains =
    virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
    virtual_gid_maps = static:5000
    virtual_mailbox_base = /var/vmail
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
    virtual_transport = maildrop
    virtual_uid_maps = static:5000
    

    lg redi78
     
    Zuletzt bearbeitet: 14. Dez. 2009
  2. Till

    Till Administrator

    Du musst den DNS A-Record für server.blasmusikforum.at ändern, so dass er auf die neue IP verweist. Mit postfix hat das wahrscheinlich nichts zu tun, da der mail empfang eh über courier läuft und die IP in postfix auch garnicht konfiguriert wird und sich somit bei einer IP Änderung keine Einstellung ändert.
     
  3. redi78

    redi78 Member

    Nach ner Weile bin ich draufgekommen, dass der komplette Server nur im LAN erreibar war. Das Problem, glaube ich, das es gab, war dass ich bei der Serverkonfiguration versehentlich die Option "Netzwerk Konfiguration" angehackt hatte.
    Irgendetwas ist da scheinbar dann mit /etc/network/interfaces passiert. Hab dort dann eth0 auf dhcp gestellt, dem Router mitgeteilt, er soll doch dieser MAC Adresse eine bestimmte IP zuteilen und danach war der Server wieder erreichbar.

    Was genau macht denn "Netzwerk Konfiguration"?

    lg und vielen Dank,
    redi78
     

    Anhänge:

  4. Burge

    Burge Member

    loel hast wirklich auf deinen screen deine interne ip durchgestrichen ?! :D

    Damit werden die Einstellungen in der interfaces datei gemacht anfuersich.
     
  5. redi78

    redi78 Member

    Hi, nein eine interne würd ich nicht durchstreichen. Dann war das der Fehler. Ich hab hier die externe IP eingetragen. War deshalb der Server dann weg vom Inet?

    Was gehört eigentlich beim Gateway rein?

    lg redi78
     
  6. Burge

    Burge Member

    na das gateway halt ueber was die verbindung hergestellt wird.

    deine subnetmask und dein dns eintraeg deuten aber auf interne ip's.

    du schreibst dhcp hinter router. der gibt dir doch auch ne interne ip. nur muss ip subnet und gateway schon zusammen passen.
     
  7. redi78

    redi78 Member

    Hi,

    danke für die Hilfe. Sollte jetzt passen.

    lg redi78
     

Diese Seite empfehlen