SoftException - Premature end of Script

Dieses Thema im Forum "Allgemein" wurde erstellt von Feanwulf, 12. Aug. 2010.

  1. Feanwulf

    Feanwulf Member

    [Thu Aug 12 20:38:38 2010] [error] [client 8xxx] SoftException in Application.cpp:555: Directory /var/www is not owned by xxx-ftp
    [Thu Aug 12 20:38:38 2010] [error] [client 8xxxx] Premature end of script headers: phpinfo.php


    ----
    bekomme die obige Fehlermeldung und habe keine Ahnung wieso - bzw ich weiss schon warum, aber nicht warum das jetzt so ist seit heute nach dem Update auf ISPconfig 2.2.37

    Es wird aber nicht an ispconfig liegen - aber ich brauche irgendwie hilfe weil ich nicht weiss in welchen logfiles ich noch gucken kann
     
  2. Till

    Till Administrator

    Wo genau erhältst Du den Fehler?
     
  3. Feanwulf

    Feanwulf Member

    Zuletzt bearbeitet: 12. Aug. 2010
  4. Till

    Till Administrator

    Benutzt Du suphp? Wenn ja, poste mal die suphp.conf Datei.
     
  5. Feanwulf

    Feanwulf Member

    Ja benutze ich - zusammen mit eaccelerator (der neu compiliert wurde) habe auch suphp 0.7.1 noch mal neu compiliert.

    Code:
    [global]
    ;Path to logfile
    logfile=/var/log/suphp.log
    
    ;Loglevel
    loglevel=warn
    
    ;User Apache is running as
    webserver_user=www-data
    
    ;Path all scripts have to be in
    docroot=/
    
    ;Path to chroot() to before executing script
    ;chroot=/mychroot
    
    ; Security options
    allow_file_group_writeable=true
    allow_file_others_writeable=false
    allow_directory_group_writeable=true
    allow_directory_others_writeable=false
    
    ;Check wheter script is within DOCUMENT_ROOT
    check_vhost_docroot=true
    
    ;Send minor error messages to browser
    errors_to_browser=false
    
    ;PATH environment variable
    env_path=/bin:/usr/bin
    
    ;Umask to set, specify in octal notation
    umask=0022
    
    ; Minimum UID
    min_uid=100
    
    ; Minimum GID
    min_gid=100
    
    [handlers]
    ;Handler for php-scripts
    x-httpd-php=php:/home/admispconfig/ispconfig/tools/suphp/usr/bin/php-wrapper
    
    ;Handler for CGI-scripts
    x-suphp-cgi=execute:!self
    
    
    
    
    
     
  6. Till

    Till Administrator

    Ändere mal die Zeile:

    x-httpd-php=php:/home/admispconfig/ispconfig/tools/suphp/usr/bin/php-wrapper

    in

    x-httpd-php="php:/home/admispconfig/ispconfig/tools/suphp/usr/bin/php-wrapper"
     
  7. Feanwulf

    Feanwulf Member

    Ah da war doch mal was - aber ändert leider nichts!

    Die dumme Log Datei gibt auch nicht mehr Informationen, woran es liegen könnte - stets der Fehler "not owned by"
     
  8. Till

    Till Administrator

  9. Feanwulf

    Feanwulf Member

    Apache neu gestartet - ich hoffe ich habe nicht zuviel murks eben gemacht -

    suphp habe ich mit "a2dismod suphp" deaktiviert aber aktiviert kommt der gleiche fehler - ich werde mir am besten die anleitung noch mal durcharbeiten!
     
  10. Till

    Till Administrator

    Schau mal nach, wem das /var/www Verzeichnis gehört. Es sollte User und Gruppe root gehören.
     
  11. Feanwulf

    Feanwulf Member

    web-ng:/var# l
    drwxr-xr-x 36 www-data root 4.0K 2010-07-17 18:04 www


    sieht für mich eigentlich OK aus
     
  12. Feanwulf

    Feanwulf Member


    AH das wars:

    nicht www-data als User!!!!
     
  13. Till

    Till Administrator

    OK. Wollte Dir gerade meines posten, da ist es auch root root:

    drwxr-xr-x 60 root root 4096 Aug 15 2009 www
     

Diese Seite empfehlen