[solved] Suse13.2/Ispconfig3: Fehler bei Mailempfang

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von mcrip, 24. Juni 2015.

  1. mcrip

    mcrip New Member

    Hallo,

    ich habe meinen Server entsprechend der Doku "The Perfect Server - OpenSUSE 13.1 x86_64" hier auf howtoforge eingerichtet. Da ich aber openSuSE 13.2 installiert habe, wurden die entsprechenden Quellen aus der Doku den aktuellen Gegebenheiten angepasst.
    Das Senden von EMails funktioniert, nicht jedoch der Empfang. Die entsprechende Mail liegt dann noch in der Mailqueue. Könntet ihr mir mal einen Tipp geben, an welcher Schraube ich drehen kann? Nachfolgend der Auszug aus dem Maillog. Die eigentliche Domain wurde in diesem Posting durch "_meineDomain_" ersetzt.

    Code:
    postfix/smtpd[26922]: connect from mail-wg0-f43.google.com[74.125.82.43]
    postfix/smtpd[26922]: 35E186B407A5: client=mail-wg0-f43.google.com[74.125.82.43]
    postfix/cleanup[26925]: 35E186B407A5: message-id=<558AB29F.3050703@gmail.com>
    postfix/qmgr[26360]: 35E186B407A5: from=<tester@gmail.com>, size=1794, nrcpt=1 (queue active)
    postfix/smtpd[26922]: disconnect from mail-wg0-f43.google.com[74.125.82.43]
    postfix/smtpd[26930]: connect from unknown[127.0.0.1]
    postfix/smtpd[26930]: AA6506B408B3: client=unknown[127.0.0.1]
    postfix/cleanup[26925]: AA6506B408B3: message-id=<558AB29F.3050703@gmail.com>
    postfix/qmgr[26360]: AA6506B408B3: from=<tester@gmail.com>, size=2225, nrcpt=1 (queue active)
    postfix/qmgr[26360]: warning: connect to transport private/dovecot: Connection refused
    amavis[26388]: (26388-01) Passed CLEAN {RelayedOpenRelay}, [74.125.82.43]:34214 [95.88.40.124] <tester@gmail.com> -> <test@_meineDomain_.de>, Queue-ID: 35E186B407A5, Message-ID: <558AB29F.3050703@gmail.com>, mail_id: Jo4Zp0LDO78a, Hits: 0.61, size: 1794, queued_as: AA6506B408B3, 398 ms
    postfix/smtp[26926]: 35E186B407A5: to=<test@_meinDomain_.de>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.52, delays=0.12/0.01/0/0.4, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as AA6506B408B3)
    postfix/qmgr[26360]: 35E186B407A5: removed
    postfix/error[26931]: AA6506B408B3: to=<test@_meineDomain_.de>, relay=none, delay=0.07, delays=0.03/0/0/0.03, dsn=4.3.0, status=deferred (mail transport unavailable)
    Schonmal vielen Dank und Grüsse
    McRip
     
  2. florian030

    florian030 Member

    Ich nehme an, der Transport zu Dovecot haut nicht hin.
     
  3. mcrip

    mcrip New Member

    danke für das spontane Feedback. Wie kann ich das überprüfen? Muss dieses Zeile in der master.cf aktiv sein oder nicht?
    Code:
    #dovecot   unix  -       n       n       -       -       pipe
    #  flags=DRhu user=vmail:vmail argv=/usr/lib/dovecot/deliver -d ${recipient}
    
    Wenn ich diese freigebe, kommt:
    Code:
    postfix/pipe[29683]: B2F8C6B40913: to=<test@_meineDomain_.de>, relay=dovecot, delay=0.1, delays=0.05/0/0/0.04, dsn=4.3.0, status=deferred (temporary failure. Command output: lda: Error: user test@_meineDomain_.de: Error reading configuration: Invalid settings: postmaster_address setting not given lda: Fatal: Internal error occurred. Refer to server log for more information. )
    
    Was habe ich da verknotet?

    Viele Grüsse
    McRip
     
  4. florian030

    florian030 Member

    Die Zeilen müssen - wenn Du Dovecot einsetzt - auskoemmentiert sein. Und in der main. cf solltest Du dann virtual_transport = dovecot und smtpd_sasl_type = dovecot haben.
     
  5. mcrip

    mcrip New Member

    Hallo Florian,
    genau das steht drin. Verstehe ich "auskommentieren" richtig, dass ich die Raute entfernen muss?
    Gerne hätte ich die Konfig gepostet, doch ich bekomme hier die Meldung, dass mehr als 1000 Zeichen nicht erlaubt sind. Was kann ich tun, damit Du Dir ein Bild von der Situation machen kannst?
    Viele Grüsse
    McRip
     
  6. florian030

    florian030 Member

    Ja. Die Raute muss weg. Und Postfix danach neu starten.
     
  7. mcrip

    mcrip New Member

    das Empfangsproblem scheint gelöst zu sein.
    Ich habe in der Datei "/etc/dovecot/dovecot.conf" den Eintrag "postmaster_address" hinzugefügt und anschliessend dovecot neu gestartet.

    vorher:
    Code:
    [...]
    protocol lda {
      mail_plugins = sieve quota
    }
    
    nachher:
    Code:
    [...]
    protocol lda {
      mail_plugins = sieve quota
      postmaster_address = root@_meineDomain_.de
    }
    
    Danke, für die Unterstützung.
     
  8. florian030

    florian030 Member

    "postmaster_address is used as the From: header address in bounce mails" - ich denke nicht, dass es daran lag.
     
  9. mcrip

    mcrip New Member

    hallo Florian,
    das ist wohl richtig. Doch merkwürdigerweise funktioniert es jetzt. In der Fehlermeldung wurde ja uach darauf hingewiesen, dass dovecot die Angabe der postmaster-Adresse vermisst. Nachdem ich eine vergeben habe, werden Mails gesendet und auch empfangen.
    Nachdem Du mir bestätigt hast, dass der Eintrag für dovecot in der master.cf freigegeben sein muss, habe ich Google mal nach der Fehlermeldung befragt und so den Hinweis auf den Eintrag in der dovecot.conf erhalten.
    Nochmals danke, dass Du Dich so schnell um mein Problem bemüht hast.
     

Diese Seite empfehlen