SPAM-Assassin Whitelist

#1
ich habe das Problem, das lokale Domains auf dem Server vom SpamAssissin
als SPAM klassifiziert werden.
Wie kann ich die lokalen Domains in die Whitelist setzen?
 

Till

Administrator
#4
hast Du mal versucht die domains auf dem advanced tab bei den mail user settings einzugeben, soweit ich weiß ist dort das Whitelisting bereits als Feld verfügbar.
 
#7
nochmals zu meinem Problem, ich habe zwei Domains (unterschiedliche Webs)
auf meinem ISPConfig Server (2.2.29) eingerichtet, Domain X und Y!

Wird eine E-Mail von Domain X an Domain Y gesendet (lokal) deklariert
SpamAssassin die E-Mail von Domain X als SPAM!

Wie kann ich nun SpamAssassin konfigurieren, das die lokalen Domains nicht überprüft werden?
 
Zuletzt bearbeitet:

Till

Administrator
#8
Spamassassin wird für jeden user individuell per Procmail script beim Empfang der Email aufgerufen. Die sinnvollste Lösung wäre also erstmal in den Header zu sehen warum spamassassin emails von einer bestimmten Absenderdomain als spam markiert und dann dieses problem zu lösen anstatt die Domain zu whitelisten. Sonst werden Domains von diesem Absender spätesetnes vom spamassassin eines anderen providers als spam ausgefiltert.
 
#9
Moin Anon und Till,

ich hab nun seit der 2.2.35 dasselbe Problem auf meinem Server wie "anon".

Lustigerweise landen emails von max@mustermann.de an lotte@mustermann.de und umgekehrt im Spam. Das hier ist auch nur ein Beispiel, generell passiert das nun bei allen gehosteten Domains auf dem Server. Die Lösung alle in eine Whitlist zu packen, hört dann bei mir und den Domains mit über 100 Postfächern schon alleine vom Arbeitsaufwand auf.

Ich habe nur ein update von ISPConfig von Version 2.2.29 auf .35 eingespielt.

@Till: was läuft hier nun falsch??! Ich kann es mir ehrlich gesagt nicht erklären.

Mein System:
- Linux openSuse 10.3 (brav nach Perfect Server Setup aufgesetzt, läuft so schon nun seit ~2 Jahren)
- ISPConfig 2.2.29 (keine Spam-Probleme mit den lokalen gehosteten Domains!)
- ISPConfig 2.2.35 (aktuell drauf! Vermehrt Probs mit Spam innerhalb der eigenen Domains auf dem lokalen Server)
 
#10
Schaut einfach mal im Header der als SPAM markierten Mails nach, warum das so ist.

Das sollte etwa so aussehen:
X-Spam-Flag: YES
X-Spam-Checker-Version: SpamAssassin 3.2.5 (2008-06-10) on
server.domain
X-Spam-Level: *****
X-Spam-Status: Yes, score=5.4 required=5.0 tests=BAYES_50,FORGED_MUA_OUTLOOK,
FROM_STARTS_WITH_NUMS,MSOE_MID_WRONG_CASE autolearn=no version=3.2.5
Die Tests geben dann einen genaue hinweis darauf, warum die Mails als Spam markiert wurden.
 

Till

Administrator
#11
@Till: was läuft hier nun falsch??! Ich kann es mir ehrlich gesagt nicht erklären.
Mit einem ISPConfig 2 update erhält Dein System auch immer die aktuellste Version von spamassassin. Da jede spamasasin Version neue oder geänderte Regeln enthält, führt dies automatisch zu einer anderen Klassifizierung von emails, was natürlich nicht bedeutet, dass auf einmal "gute" emails als spam gekennzeichnet werden sollten. Um die Ursache dafür zu finden, musst Du das machen was fuxifux in #10 beschrieben hat.
 

Werbung

Top