Spams werden nicht mehr gefiltert

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von daff, 8. Mai 2008.

  1. daff

    daff New Member

    Hallo,

    ich nutze ISPConfig 2.2.23 auf nem Debian Etch System. Heute habe ich spamd installiert, da das in ISPConfig integrierte Spamassassin mein System sehr stark belastet hat. Nun werden aber die Spams nicht mehr gefiltert. Ich habe mich dabei an folgende "Anleitung" gehalten: http://howtoforge.com/forums/showpost.php?p=122551&postcount=6

    Zudem habe ich in der /etc/default/spamassassin ENABLE auf 1 gesetzt. Ich hab auch schon sa-update gemacht - hat nix gebracht. spamd wird auch ausgeführt laut top.
    Haben die Einstellungen in ISPConfig noch Auswirkungen auf Spamassassin wenn ich ihn als spamd laufen hab? Es ändert sich jedenfalls nix, wenn ich in der Datei /etc/spamassassin/local.cf folgende Optionen aktiviere:

    Code:
    rewrite_header Subject *****SPAM*****
    required_score 1.0
    use_bayes 1
    bayes_auto_learn 1
    
    Hat jemand ne Idee was ich flasch gemacht haben könnte?

    daff
     
  2. Till

    Till Administrator

    Ja.

    Setz den Score bitte in ISPConfig runter, da die individuellen User-Einstellungen die Einstellungen in /etc/spamassassin/local.cf überschreiben.

    Ich würde Dir raten mal spamassassin auf der Shell zu testen, indem Du ihm eine spam mail mal direkt übergibst.
     
  3. daff

    daff New Member

    Wie mach ich das? Sorry, bin auf dem Gebiet noch bissl n noob.
    Ich bin mir aber sicher, dass der Spamfilter nicht funktioniert, da ich auf einem Konto schon wieder über 100 Spams seit gestern hab.
     
  4. daff

    daff New Member

    Hat denn niemand ne Idee ?

    UPDATE: Ich habs hinbekommen. In der Datei /root/ispconfig/isp/conf/spamassassin.rc.master muss nicht "| /usr/bin/spamc" stehen sondern "| /usr/bin/spamassassin". Dann gehts.

    UPDATE2: Scheint nu doch nicht zu gehn. wenn ich "| /usr/bin/spamassassin" nutze nimmt der scheinbar wieder den scanner von ISPConfig :(
     
    Zuletzt bearbeitet: 12. Mai 2008
  5. Till

    Till Administrator

  6. daff

    daff New Member

    Ich hab in /root/ispconfig/isp/conf/spamassassin.rc.master den Eintrag auf /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamc geändert. Nun scheint es mit dem Daemon zu funzen.
     

Diese Seite empfehlen