SSL/DNS - https://<domain> landet in /var/www statt in /var/www/<domain>

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von fraser, 1. Jan. 2011.

  1. fraser

    fraser New Member

    Hallo,

    ich verwende nun zum ersten Mal ISPConfig und bin bisher sehr zufrieden. Gegenüber Plesk ist es wesentlich flexibler. Nur mit der Domainverwaltung habe ich noch so meine Schwierigkeiten.

    Die DNS-Einstellungen verwalte ich neuerdings über inwx.de, wo folgendes eingetragen ist:
    Code:
    [B]Name    Typ    Wert    Prio.[/B]
           
    TXT    v=spf1 a mx ~all
    SOA    ns.inwx.de hostmaster@inwx.de 2010122801
    NS     ns.inwx.de
    NS     ns2.inwx.de
    NS     ns3.inwx.de
    MX     mail.[I]<DOMAIN>[/I]   10       *   A   [I]<IP>[/I]
    A      [I]<IP>[/I]
    mail   A   [I]<IP>[/I]
    www    A   [I]<IP>[/I]
    Den Server hoste ich wo anders. Einen lokalen DNS-Server habe ich nicht installiert.
    SMTP und IMAP sind über mail.<DOMAIN> erreichbar.

    In der /etc/hosts steht folgendes:
    Code:
    127.0.0.1       localhost
    [I]<IP> <DOMAIN> [/I]vserver1
    In der /etc/hostname folgendes:
    Code:
    [I]<DOMAIN>[/I]
    Unter "Domains" habe ich in ISPConfig zwei Domains eingerichtet:
    Code:
    [I]<DOMAIN>[/I] 
    und
    mail.[I]<DOMAIN>[/I]
    
    Letztere habe ich nicht als Subdomain, sondern als Domain eingerichtet und RoundCube installiert. Dieses soll natürlich nur über https:// erreichbar sein.
    In den Einstellungen der Domain ist SSL aktiviert und auch ein selbstsigniertes Zertifikat eingetragen. Bei SSL-Domain ist mail.<DOMAIN> ausgewählt.

    Mein Problem, wie schon im Threadnamen beschrieben, ist nun folgendes:
    Wenn ich die Domain mail.<DOMAIN> nun im Browser aufrufe, lande ich im Verzeichnis /var/root statt im Verzeichnis der Domain.

    Hat vielleicht jemand eine Idee, wo hier der Fehler steckt?
     
  2. Till

    Till Administrator

    Du musst bei der webseite mail.domain.tld auch die IP und nicht * in den Webseiteneinstellungen auswählen.
     
  3. fraser

    fraser New Member

    Danke

    Jetzt funktioniert es. Ein Verständnisproblem habe ich aber noch. Wieso wird für eine SSL-Domain immer eine separate IP benötigt?

    Bedeutet das, dass ich für https://mail.<DOMAIN> eine andere IP benötige als für https://<DOMAIN>? Und muss ich diese dann auch bei meinem Domainprovider (inwx.de) eintragen?
    Brauche ich also neben dem MX-Record (erste IP) auch noch einen A-Record (zweite IP) für mail.<DOMAIN>?
    Und wieso hatte ich dieses Problem bei Plesk nie?

    Danke für Eure Hilfe.
    fraser
     
  4. Till

    Till Administrator

    Das ist so im SSL Protokoll festgelegt, ist also nichts ISPConfig spezifisches. Kannst Du auch in den RFC, also den weltweit gültigen Spezifikationen für Internetprotokolle, nachlesen.

    Du verwechselst da glaube ich etwas. Nur weil irgend etwas mail.domain.tld heißt hat es noch lange nichts mit email zu tun. Domainnamen sind beliebig und haben nichts mit den dahinterliegenden Diensten zu tun. Ich kann also problemlos meinen Mailserver unter der Domain das-ist-kein-mailserver.domain.tld betreiben.

    Ein MX record ist der DNS record der auf den hostnamen des zuständigen Emailservers verweist. Wie der Hostname lautet ist absolut egal.
     
  5. fraser

    fraser New Member

    Ich habe vergessen, zu sagen, dass ich den Namen mail.<DOMAIN> sowohl für den Mailserver (IMAP/POP/SMTP) als auch als "Apache-Domain" für RoundCube verwende.

    Ich habe jetzt für meine IP einen NameVirtualHost-Eintrag angelegt und für die "Apache-Domain" mail.<DOMAIN> ein SSL-Zertifikat erstellt. Dies funktioniert auch.

    Wenn ich allerdings die Hauptdomain <DOMAIN> via https aufrufe, lande ich auch auf mail.<DOMAIN>.
    Deshalb dachte ich, ich bräuchte eine zweite IP um sowohl <DOMAIN> als auch mail.<DOMAIN> via SSL erreichbar zu machen.

    So wie ich es verstanden habe, zeigt der NameVirtualHost-Eintrag <IP>:443 immer nur auf eine Domain?

    Liege ich da richtig?
     
  6. Till

    Till Administrator

    Lege bitte keine manuellen namvirtualhost Einträge an. das wird alles automatisch durch ispconfig gemacht. Manuelles editiren fürhrt nur dazu, dass nachher etwas nicht funktioniert. Also bitte den manuell erstellten namevirtualhost Eintrag wieder entfernen und sattdessen die Ip in ispconfig unter system > server IP eintragen und dort wie standardmäßig vorgesehen die namevirtualhost checkbox gesetzt lassen.

    Das ist richtig. Wie oben beschrieben, sieht das SSL Protokoll vor das jede SSL Webseite auch eine eigene IP hat. Daher landest Du auf der ersten Webseite, wenn Du IP Sharing zwischen Seiten verwendest.
     
  7. fraser

    fraser New Member

    Alles klar. Danke für die schnelle Antwort.
    Den NameVirtualHost-Eintrag hatte ich, wie von Dir beschrieben, in ISPConfig gesetzt.

    Ich werde also bei meinem Hoster eine zweite IP beantragen, um <DOMAIN> und mail.<DOMAIN> separat via SSL erreichen zu können. Dann sollte ja alles laufen.

    Gruß
    fraser
     

Diese Seite empfehlen