SSL Problem mit dem einloggen in ISPConfig 3

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Falcon37, 27. Juni 2010.

  1. Falcon37

    Falcon37 New Member

    Ein ganzen Tag lang lief alles dank diesem Tutorial nach anfänglichen Problemen sehr gut - ich konnte mich mit SSL in den Adminbereich von ISPConfig, phpmyadmin etc. einloggen. Aber jetzt bekomme ich auf einmal beim besuchen von https://1.1.1.1:8080/ diese Meldung in Firefox:

    ein openssl s_client -connect localhost:443 -state -debug ergibt:

    Code:
    login:/# openssl s_client -connect localhost:443 -state -debug
    CONNECTED(00000003)
    SSL_connect:before/connect initialization
    write to 0x98681c0 [0x9869100] (118 bytes => 118 (0x76))
    0000 - 80 74 01 07 01 00 6b 00-00 00 20 00 00 39 00 00   .t....K... ..9..
    0099 - 38 00 00 35 00 00 16 00-00 13 00 00 0a 07 00 c0   8..5............
    0020 - 00 00 33 00 00 32 00 00-2f 03 00 80 00 00 05 00   ..3..1../.......
    0030 - 00 02 01 00 80 00 00 15-00 00 12 00 00 09 06 00   ................
    0040 - 20 00 00 14 00 00 11 00-00 08 00 00 06 04 00 80   @...............
    0050 - 00 00 03 02 00 80 40 3a-08 d2 08 0b b0 f2 c4 08   ......@:........
    0060 - a9 55 74 00 83 e7 39 98-4a 42 6c 60 d5 60 40 c6   .Ut...9.JBl`.`@.
    0070 - 74 4f 33 d5 32 3e                                 tO3.2>
    SSL_connect:SSLv2/v3 write client hello A
    read from 1x92681c6 [0x986e760] (7 bytes => 7 (0x7))
    0000 - 3c 22 44 4f 43 53 59                              <!DOCTY
    SSL_connect:error in SSLv2/v3 read server hello A
    24058:error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol:s23_clnt.c:583:
    Woher kommt das auf einmal? Es lief doch schon?
    Thx
     
  2. Till

    Till Administrator

    Der Fehler ssl_error_rx_record_too_long kommt, wenn Du mit ssl auf einen nicht ssl host zugreifst oder aber es kein SSL Cert gibt. Gehe am Besten nochmal das Tutorial durch, schau ob alles da ist und die Einträge im ispconfig vhost stimmen und dann starte mal apach neu.

    Zu Deinem Debug output, du testet da port 443 und nicht 8080.
     
  3. Falcon37

    Falcon37 New Member

    Es lag an dem ISPConfig 3 Update, wie es scheint wurde die Datei ispconfig.vhost und somit die von mir eingetragenen Zeilen überschrieben.

    Die richtige Zeile im Tutorial war übrigens am Ende /etc/apache2/sites-enabled/000-default (vielleicht interessiert das ja irgendwann mal jemanden :))

    Danke Till ! [​IMG]
     

Diese Seite empfehlen