SUbdomains nur ohne SSL erreichbar, mit SSL Fehlermeldung

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von csiebert, 15. Okt. 2011.

  1. csiebert

    csiebert Member

    Nabend,

    habe heute ein merkwürdiges Phänomen festgestellt. Für eine Domain habe ich ein Wildcard-Zertifikat installiert. Zu dieser Domain gibt es diverse Subdomains. Versuche ich nun, eine der Subdomains OHNE SSL aufzurufen, klappt alles wie gewohnt. Rufe ich jedoch eine Subdomain MIT SSL auf, erhalte ich 403.

    Nach einem Blick in den vHost ist das zwar nachvollziehbar (Reweite Rules für die Domain sind nur im :80 Abschnitt eingetragen), aber unbefriedigend - wie erreiche ich, dass auch die Subdomains per SSL erreichbar sind?

    Danke + Gruß, Chris
     
    Zuletzt bearbeitet: 17. Okt. 2011
  2. Till

    Till Administrator

    Verweisen denn alle subdomains auf den gleichen vhost wie die haupt domain? Denn sonst kann apache ja nicht den content der ssl webseite anzeigen.
     
  3. csiebert

    csiebert Member

    jep, gehören alle zum gleichen vhost. die konfig sieht derzeit wie folgt aus:

    Code:
    <Directory /var/www/domain.de>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    <VirtualHost 213.239.220.139:80>
        DocumentRoot /var/www/clients/client24/web126/web
    
        ServerName domain.de
        ServerAlias *.domain.de
        ServerAlias akademie.domain.de
        ServerAlias www.akademie.domain.de
        ServerAdmin webmaster@domain.de
    
        ErrorLog /var/log/ispconfig/httpd/domain.de/error.log
    
        <Directory /var/www/domain.de/web>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
        <Directory /var/www/clients/clientXY/webXY/web>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
    
        # cgi enabled
            <Directory /var/www/clients/clientXY/webXY/cgi-bin>
          Order allow,deny
          Allow from all
        </Directory>
        ScriptAlias  /cgi-bin/ /var/www/clients/clientXY/webXY/cgi-bin/
        AddHandler cgi-script .cgi
        AddHandler cgi-script .pl
        # suexec enabled
        SuexecUserGroup webXY clientXY
        # Clear PHP settings of this website
        <FilesMatch "\.ph(p3?|tml)$">
            SetHandler None
        </FilesMatch>
        # suphp enabled
        <Directory /var/www/clients/clientXY/webXY/web>
                    <IfModule mod_suphp.c>
            suPHP_Engine on
            # suPHP_UserGroup webXY clientXY
            AddHandler x-httpd-suphp .php .php3 .php4 .php5
            suPHP_AddHandler x-httpd-suphp
                    </IfModule>
        </Directory>
    
        RewriteEngine on
        RewriteCond %{HTTP_HOST}   ^domain.de [NC]
        RewriteRule   ^/(.*)$ /homepage/$1
        RewriteCond %{HTTP_HOST}   ^akademie.domain.de [NC]
        RewriteRule   ^/(.*)$ /akademie/$1
        RewriteCond %{HTTP_HOST}   ^www.akademie.domain.de [NC]
        RewriteRule   ^/(.*)$ /akademie/$1
        RewriteCond %{HTTP_HOST}   ^www.domain.de [NC]
        RewriteRule   ^/(.*)$ /homepage/$1
    
        # add support for apache mpm_itk
        <IfModule mpm_itk_module>
          AssignUserId webXY clientXY
        </IfModule>
    
        <IfModule mod_dav_fs.c>
          # DO NOT REMOVE THE COMMENTS!
          # IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
          # WEBDAV BEGIN
          # WEBDAV END
        </IfModule>
    
    </VirtualHost>
    
    jetzt seh ich grade, dass ich dort nichts mehr zum thema ssl stehen habe - ich werde das zertifikat in ispconfig mal löschen und dann neu einrichten, vielleicht hilfts, ich berichte...

    gruß, chris
     

Diese Seite empfehlen