Testsetup upload erfolgt als apache user?

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von methos, 30. Apr. 2016.

  1. methos

    methos New Member

    Hallo,
    hab bisher noch keine Erfahrungen mit ISP-Config, möchte es aber gerne mal als Alternative zu Plesk bzw. einem Server ohne Panel Verwaltung testen.

    Hab jetzt erstmal ein Testsetup mit Centos 7 der 3.0.5.4p9 und nginx durchgeführt.
    Mit PHP 7 aus dem remi repo hat es leider nicht funktioniert, auch nicht mit der Beta Version, deswegen hab ich erstmal die Standard 5.4.16 fpm version verwendet.

    Zum einfachen Testen ob alles funktioniert hab ich erstmal eine Test Wordpress Installation vorgenommen. Hier hab ich schon das erste Problem und zwar kann er die Config nicht schreiben.
    Hab ich hier irgendwo was vergessen?

    Laut der fpm config für die domain verwenet er hier folgendes:

    user = web3
    group = client0

    client0 ist laut der group auch mit in der Gruppe nginx und die widerum in der Gruppe apache.
    Der Upload klappt allerdings nur, wenn ich den wp-content Order zuvor dem apache zuordne:

    Standard:
    drwxr-xr-x 5 web3 client0 4096 30. Apr 09:36 wordpress

    Geht:
    drwxr-xr-x 6 apache apache 79 30. Apr 10:03 wp-content

    Was muß ich einstellen, damit er hier anstelle des apache users den jeweiligen FTP User verwendet?
     
  2. robotto7831a

    robotto7831a Member

    PHP 7 geht mit der aktuellen Version noch nicht.

    FPM ist im Prinzip richtig. Man muss die Berechtigungen eigentlich nicht verbiegen.
     
  3. methos

    methos New Member

  4. methos

    methos New Member

    Hab jetzt das php-fpm Paket noch einmal deinstalliert, neu aufgespielt und auch isp-config neu installiert und nun scheint es zu klappen.
    Hab zwar nichts anderes gemacht als zuvor, aber nun schreibt er es korrekt.

    Dann test ich mal die weiteren Funktionen....
     
  5. methos

    methos New Member

    Nachdem ich nochmals die Installation durchgeführt hab, klappt es wieder nicht.
    Beim erstellen des wordpress blogs legt er die wp-config noch mit dem richtigen Benutzer an, beim upload von Bildern verwendet er allerdings den apache und bringt Fehler, das kann es doch nicht sein...
     
  6. robotto7831a

    robotto7831a Member

    Wenn man nach wordpress und fpm sucht, dann findet man eine Reihe von Beiträgen mit Berechtigungsproblemen.
     
  7. methos

    methos New Member

    Was soll das denn mit wordpress zu tun haben?
     
  8. robotto7831a

    robotto7831a Member

    Je nachdem wie Wordpress den Upload mit PHP macht. Bei Google findet man dazu auch diverse Beiträge.
     
  9. methos

    methos New Member

    Kannst du mir mal so einen Beitrag nennen?
    Ich hab hier einige Serversysteme die mit php-fpm ohne Probleme laufen, allerdings ohne isp-config...
    Wenn ich bei dem isp-config setup ein
    <?php echo exec('whoami'); ?>
    ausgeben lasse, erhalte ich als User apache was ja nicht richtig sein kann und somit kann das meiner Meinung auch nie etwas mit wordpress zu tun haben, sondern nur mit isp-config.
     
  10. robotto7831a

    robotto7831a Member

    Stimmt das ist falsch. Dort müsste webX stehen.
     

Diese Seite empfehlen