The Perfect Setup - Debian Etch (Debian 4.0) - Page 4 (bind auf vServer)

Dieses Thema im Forum "Fragen zu Howtos" wurde erstellt von wiseguy, 20. Nov. 2008.

  1. wiseguy

    wiseguy New Member

    hallo,

    ich hab schon wieder einkleines Problem, wobei ich denke, dass das wieder mal damit zusammen hängt, dass ich einen vserever habe:

    Ich möchte ISPConfig auf meinen debian etch vserver installieren. Also hab ich mich in Vorbereitung darauf an das Tutorial The Perfect Setup - Debian Etch gehalten (soweit es halt möglich war, da wie gesagt: vServer).

    Da ich meinte, bind nicht zu brauchen, hatte ich das im Tutorial übersprungen. Jetzt, als ich ISPConfig installieren wollte, hab ich in der dist.txt gesehn, dass das bind wohl doch benötigt wird. Also hab ich noch mal im Tutorial nachgesehn und nicht mehr ganz gefunden, warum ich kein bind installieren wollte (in Erinnerung ist mir nur noch, dass ichs wohl nicht brauch, weil ich einen vserver hab - andererseits möchte ich auch domains/subdomains im ISPConfig verwalten können... dafür ist doch das bind oder?).

    Also hab ich versucht das zu installieren und bin an folgender Stelle hängen geblieben:
    Code:
    host # mknod /var/lib/named/dev/null c 1 3
    mknod: `/var/lib/named/dev/null': Operation not permitted
    wieso kann ich das als root nicht anlegen?
     
    Zuletzt bearbeitet: 20. Nov. 2008
  2. Till

    Till Administrator

    Deshalb sollte man nie etwas im perfect setup überspringen ;) Wenn ein Schritt nicht nötig wäre, würde er da auch nicht drin stehen.

    Das liegt daran, dass Du einen vserver hast. Mache einfach die restlichen Schritte zuende und schau mal ob bind dann startet.
     
  3. wiseguy

    wiseguy New Member

    Aber dann gibts ja da kein dev/null - meint ihr ich könnte einen hardlink auf /dev/null bzw. /dev/random legen?

    Ist das ein Sicherheitsrisiko?
     
  4. wiseguy

    wiseguy New Member

    Läuft leider nicht. Folgendes hab ich jetzt gemacht:
    • host # apt-get install bind9
    • host # /etc/init.d/bind9 stop
    • in /etc/default/bind9 die Zeile OPTIONS="..." in OPTIONS="-u bind -t /var/lib/named" geändert
    • host # mkdir -p /var/lib/named/etc
    • host # mkdir /var/lib/named/dev
    • host # mkdir -p /var/lib/named/var/cache/bind
    • host # mkdir -p /var/lib/named/var/run/bind/run
    • host # mv /etc/bind /var/lib/named/etc
    • host # ln -s /var/lib/named/etc/bind /etc/bind
    • host # ln /dev/null /var/lib/named/dev/null
    • host # ln /dev/random /var/lib/named/dev/random
    • in /etc/default/syslogd die Zeile SYSLOGD="" in SYSLOGD="-a /var/lib/named/dev/log" geändert
    • host # /etc/init.d/sysklogd restart
    Hier nun der Startversuch von bind
    Code:
    host # [B]/etc/init.d/bind9 start[/B]
    Starting domain name service...: bind failed!
    Das ist der Auszug der syslog nachdem ich bind starten wollte:
    Code:
    Nov 20 14:57:04 host named[20014]: starting BIND 9.3.4-P1.1 -u bind -t /var/lib
    /named
    Nov 20 14:57:04 host named[20014]: found 1 CPU, using 1 worker thread
    Nov 20 14:57:04 host named[20014]: loading configuration from '/etc/bind/named.
    conf'
    Nov 20 14:57:04 host named[20014]: no IPv6 interfaces found
    Nov 20 14:57:04 host named[20014]: listening on IPv4 interface eth1:8, xx.xx.xx.xx#53
    Nov 20 14:57:04 host named[20014]: command channel listening on 127.0.0.1#953
    Nov 20 14:57:04 host named[20014]: couldn't open pid file '/var/run/bind/run/named.pid': Permission denied
    Nov 20 14:57:04 host named[20014]: exiting (due to early fatal error)
    Nov 20 14:57:14 host ntpd[21416]: sendto(yy.yy.yy.yy) (fd=-1): Bad file descr
    iptor
    Nov 20 14:57:15 host ntpd[21416]: sendto(zz.zz.zz.zz) (fd=-1): Bad file descr
    iptor
    xx.xx.xx.xx ist meine eigene IP
    yy.yy.yy.yy und zz.zz.zz.zz kenn ich nicht (evtl. irgendwelche IPs meines Hosters?)

    So wie ich das sehe hängt es gar nicht an dem /dev/null bzw. /dev/random, sondern daran das named nicht gestartet werden kann. Aber warum?
     
    Zuletzt bearbeitet: 20. Nov. 2008
  5. wiseguy

    wiseguy New Member

    hab nach einigem Lesen hier herausgefunden, dass es ein spezielles bind9 für vserver gibt. das hab ich nach der dortigen Anleitung versucht zu installieren:Danach bekam ich die Fehlermeldung (ich hab sie jetzt nicht mehr vor mir), dass verschiedene Versionen von etch1 benötigt werden. Ich habe aber die Versionen von etch3 auf meinem Server installiert - also ließ sich das so nicht installieren.

    Nach weiterem Suchen bin ich hierauf gestoßen.

    Also bin ich (nach Anleitung) wiefolgt vorgegangen (zu allererst hab ich bind9 wieder deinstalliert):
    • host # apt-get remove bind9
    • host # cd /usr/src
    • host # apt-get build-dep bind9
    • host # apt-get source bind9
    • host # cd bind9-9.3.4
    • nach ./configure –prefix=/usr \ habe ich folgendes in der debian/rules geändert:
      • –-enable-threads \ in -–disable-threads \ geändert
      • –-disable-linux-caps \ hinzugefügt
    • host # dpkg-buildpackage
    • host # cd..
    • host # dpkg -i bind9_9.3.4-2_i386.deb \
      > bind9-doc_9.3.4-2_all.deb \
      > bind9-host_9.3.4-2_i386.deb \
      > libbind9-0_9.3.4-2_i386.deb \
      > libbind-dev_9.3.4-2_i386.deb \
      > libdns22_9.3.4-2_i386.deb \
      > libisc11_9.3.4-2_i386.deb \
      > libisccc0_9.3.4-2_i386.deb \
      > libisccfg1_9.3.4-2_i386.deb \
      > liblwres9_9.3.4-2_i386.deb
    Hier hatte ich die ersten echten Bedenken, da ich unter anderem folgende Ausgabe bekam:
    Code:
    Starting domain name service...: bind failed!
    Aber gut evtl. fehlte noch die letzte Anweisung. Also hab ich auch die noch ausgeführt:
    Code:
    host # [B]echo "bind9 hold" | dpkg -set-selctions[/B]
    dpkg: conflicting actions -e (--control) and -s (--status)
    
    Type dpkg --help for help about installing and deinstalling packages 
    [*];
    Use `dselect' or `aptitude' for user-friendly package management;
    Type dpkg -Dhelp for a list of dpkg debug flag values;
    Type dpkg --force-help for a list of forcing options;
    Type dpkg-deb --help for help about manipulating *.deb files;
    Type dpkg --license for copyright license and lack of warranty (GNU GPL) 
    [*].
    
    Options marked 
    [*] produce a lot of output - pipe it through `less' or `more' !
    Was nun? Das hat ebenfalls nicht geklappt.

    Ich benötige eure Hilfe, allein komm ich an dieser Stelle nicht weiter.
     
    Zuletzt bearbeitet: 20. Nov. 2008
  6. wiseguy

    wiseguy New Member

    Ich seh grad noch was, was den dpkg-buildpackage-Schritt angeht:
    Abgesehen davon, dass währenddessen ettliche warnings wie diese:
    Code:
    libtool: install: warning: `../../lib/isc/libisc.la' has not been installed in `/usr/lib'
    angezeigt wurden (die komplette Ausgabe ist wahrscheinlich zu lang und ich will diesen Thread nicht damit zu spammen), kam am Ende auch noch diese Meldung:
    Code:
    gpg: skipped "LaMont Jones <lamont@debian.org>": secret key not available
    gpg: [stdin]: clearsign failed: secret key not available
    
     dpkg-genchanges
    dpkg-genchanges: not including original source code in upload
    dpkg-buildpackage: binary and diff upload (original source NOT included)
    (WARNING: Failed to sign .dsc and .changes file)
    Könnte das etwa mit dem Problem zusammenhängen?
     
  7. Till

    Till Administrator

    Was steht denn im syslog drin, wenn Du versuchst Bind zu starten?
     
  8. wiseguy

    wiseguy New Member

    So, war am WE nicht Zuhause.

    Also der Fehler war eigentlich gar kein Fehler... Bzw. es lag daran, dass ich mich vertippt hatte:
    Code:
    host # [B]echo "bind9 hold" | dpkg --set-selctions[/B]
    muss natürlich
    Code:
    host # [B]echo "bind9 hold" | dpkg --set-sel[COLOR=Red]e[/COLOR]ctions[/B]
    heißen ;-)

    Und dann läuft auch alles soweit. Allerdings musste ich eh nochmal neu installieren, da sich bei der mysql Installation was verhaspelt hatte - und so weit war ich ja noch nicht und Übung kann auch nicht schaden ;-)
     

Diese Seite empfehlen