$user/tmp Ordner wird immer zu voll

#1
Hi,

habe bereits lange gesucht, aber nichts gefunden.
Und zwar geht es um meine Server. Soweit geht alles super, die /tmp sind oft fast leer, aber eine Webseite ist bei mir sehr heavy (4-5 Mio Sessions / Tag). Deshalb muss ich mittlerweile alle 12-24 Stunden den tmp Ordner der Webseite (des "webs") löschen (leeren) per SSH.

Gibt es irgendeine Möglichkeit, die Laufzeit der tmp Dateien zu ändern oder einen Cron laufen zu lassen, der die tmp-Inhalte im Ordner löscht (oder öfter)? Wenn ich den Inhalt des tmp Ordners nicht lösche, werden keine "Befehle" (MySQL, Buchungen etc) mehr durchgeführt. Nach dem Löschen geht wieder alles. Ich nutze dafür immer per SSH:

Code:
root: /var/www/clients/client1/web27# rm -r tmp
rm: cannot remove ‘tmp’: Permission denied
Klar, der Ordner lässt sich nicht löschen, aber den Inhalt löscht er. Ist halt immer etwas Bescheiden, wenn ich jeden Tag min. 1x per SSH den Ordner leeren muss. :/

Gruß
Julian
 
#3
Hallo,

eigentlich nur $Session Dateien. Jedoch wird die Session benötigt, einmalig. Diese werden aber anscheinend dauerhaft dort gespeichert.

Code:
sess_007jfmoqv3u3lrdmh9s952gbb4
sess_016rhmer6u2nbns9alr3sj48s6
sess_018coq7qqghlrf28qflclo11f5
sess_01ej0rrn9h4l2pctkrfd03lmr4
etc...
Die Dateien haben keine Endung.
 
#5
/etc/php5/fpm/php.ini: session.gc_maxlifetime 20

Oder gibt es woanders noch eine ini, welche die globale PHP-Settings überschreibt? Z.B. gc_maxlifetime.
 
#7
Code:
Configuration File (php.ini) Path/etc/php5/fpm
Loaded Configuration File/etc/php5/fpm/php.ini
Scan this dir for additional .ini files/etc/php5/fpm/conf.d
Jap, lädt die Config.

Auch die lifetime ist dort mit 20 angegeben.
 

Werbung

Top